none
Report Builder 3.0 : Uploading reports to SharePoint RRS feed

  • Question

  • Hi, 

    I'm trying to upload some reports I made to a SharePoint site. I made the reports using ReportBuilder 3.0.

    However when I upload the report it will not run on SharePoint and gives out this error:

    The report server cannot process the report or shared data set. The shared data source 'Tfs2010ReportDS' for the report server or SharePoint site is not valid. Browse to the server or site and select a shared data source. (rsInvalidDataSourceReference)

    Does anyone have any ideas how I can get my reports to run on SharePoint ?

    Cheers




    Thursday, June 23, 2011 4:48 PM

Answers

  • Hi Sessie,

    Based on the error massage, I suspect the exact error message is as follows,

    The report server cannot process the report. The reference for the shared dataset 'Tfs2010ReportDS' is not valid. (rsInvalidDataSetReference)

    Generally, I would suggest you check check whether the shared dataset 'Tfs2010ReportDS' has been deployed at first. Please be aware the shared datasource also need to be deployed. If the shared dataset has already been deployed, we need to specify the shared dataset to the report.

    Please follow the steps below:

    1. In the Report Manager, navigate to folder in which you deployed the report.
    2. Move your mouse on the report name and click the triangle after it. Then select Manage in the dropdown list.
    3. Select Shared Datasets in the left list. Click Browse button.
    4. Select the correct dataset name in the tree view. Click OK.
    5. Click Apply button.

    For more information about Managing Shared Datasets, please see: http://msdn.microsoft.com/en-us/library/ee636147.aspx

    Thanks,
    Eileen

    • Marked as answer by Eileen Zhao Sunday, July 3, 2011 3:38 PM
    Monday, June 27, 2011 4:24 PM