none
One or more of the server network addresses lacks a fully qualified domain name (FQDN). RRS feed

  • Question

  • Hello Guys,

    I had been trying to solve this error with no success :

     

    One or more of the server network addresses lacks a fully qualified domain name (FQDN).  Specify the FQDN for each server, and click Start Mirroring again.

    The syntax for a fully-qualified TCP address is:
    TCP://<computer_name>.<domain_segment>[.<domain_segment>]:<port>

     

    I had installed three instances on my local machine to test Data base mirroring :

    Principal : running SQL Developer Instance

    Mirror :  running SQL Developer Instance .

    Witness : Running SQL Express.

     

    Database mirroring already enabled using startup flag : -T1400

     

    i even tried to configure it with out a witness but still have the same error .

     

    I used the follwoing server name in the mirroring wizard(not localhost) :

    Principal : TCP://Ali-laptop:5022

    Mirrored : TCP://Ali-laptop:5023

    Witness : TCP://Ali-laptop:5044

     

    whats the problem guys?!

     

    Monday, June 11, 2007 9:31 AM

All replies

  • Can you ping the server using FQDN (fully qualified domain name)?
    Monday, June 11, 2007 3:26 PM
  • yes sure ,i mentioned that ALL instances are running on a single machine.
    Tuesday, June 12, 2007 7:36 AM
  • Guys, any bright ideas?!
    Wednesday, June 13, 2007 8:23 AM
  • Did you restore the database WITH NORECOVERY? The error about FDQNs is spurious sometimes.
    Wednesday, June 13, 2007 3:28 PM
  • Hmmm.  The wizard seems to suck a bit.  It only handles one scenario, with all machine participating in a domain.  Change the machine names to IP addresses of the machines. So it will read "TCP://192.168.0.8:5022 or what ever your IP and ports are set to.  I also had to use certificates to get it to work in my instances (high safety and availability).  Two must reads from MS on this are "Achieve High Availability for SQL server" and "Using Certificates for Database Mirroring"  These are the ONLY two MS articles that will address certificates.  They are not complete and you still need more info.  "Database Mirroring in SQL Server 2005" is also a required document to get it working, but they do not address a setup correctly if you want High safety and availability.  The first two docs I mentioned take precidence and then the information they lack, you have to backfill with the third. 

     

    I ended up with a thirty page how to guide for my scenario when I finally got it working.  Hte trick was really the swapping f the machine names with the IPs.  That did the trick for me.

     

    Sorry about the lack of links to the MS docs.  The doc names are vebatum so you can esily search for them.  Sorry there is no easy answer either.  MS needs some serious work on the wizard at the moment, but it is a decent first stab at it.  The mirroring works great once it is established.  I would recommend it in opposition to other methods.  Setup is painfull however. 

    Wednesday, June 13, 2007 7:04 PM
  • BTW - I could NOT use the wizard as it does not allow for IP addresses.  You must use SQL commands.  The documents spell them out.
    Wednesday, June 13, 2007 7:05 PM
  • thanks for all replies ,but this is really frustrating ,i follow ALL instruction to apply one of the NEWEST technologies MS boasts ,step by step ,i restored the mirror in no recovery mode ,stupid wizard always taking me back to the same place ,my server naming has a problem! ,i changed my server name to be :localhost so the wizard can capture :

     

    TCP://localhost:5023

     

    still getting the same misleading error ,i was NOT able to change my machine name to an IP address as windows XP doesnt allow special characters in a machine name ,i am starting to think by default the stupid wizard of MS assumes that you are a part of a DOMAIN and expects to see the domain name as a part of your server name .

    I wonder why they design wizards if one has to go eventually to scripts?!!

     

    will let you guys know if i have further updates!

     

    Ali

    Thursday, June 14, 2007 10:33 AM
  • Guys,

    Do you have any more suggestions? i am still stuck wih the Wizard.

    Sunday, June 17, 2007 8:42 AM
  • Hi Ali,

     

    I have had the same problem, but it solved Smile

     

    I have a stand alone SQL Server 2005, without member of any domain. I put "local" to the "Primary DNS Suffix of this computer" textbox, then I specified my server as MyServer.local

     

    Then it worked. Try this please. If it will not be working for you, then you have a problem of something else.

     

    Regards,

     

    Janos

    Sunday, July 1, 2007 2:44 PM
  • Janos,

    where did you give this option? and where did u specify this server as myserver.local. your reply will be appreciated.

    Thursday, July 12, 2007 5:59 PM
  • Hi Narayan,

     

    I tried to set up on my local machine with 3 instances this option. I got the same error message. I just got the idea to set up my computer to avoid this error like this:

     

    1. Right click on the "My Computer" then properties.
    2. Click on the "computer name" tab, then click on the change button next to the "To Rename this computer or join a domain, click change"
    3. then you see the "Computer name changes" window, click the "More" button on it.
    4. You will see the "DNS suffix and NetBIOS ComputerName" window. Here, type "local" to the "Primary DNS Suffix of this Computer" textbox.
    5. then press OK 3 times and restart computer.

     

    After put this "computername.local" to your computer name for the mirroring computer server network address.

     

    Regards,

     

    Janos

    Friday, July 13, 2007 7:45 AM
  • Thanks Janos, I will try it today and let you know for sure. again thanks for the reply.
    Saturday, July 14, 2007 10:32 AM
  • Janos,

    I tried and it worked for me Thanks a lot for your detailed help i really appreciate it a lot.

    Monday, July 16, 2007 12:00 AM
  • Hi Narayan,

     

    I'm glad to hear it. If you are in domain environment, just use really the FQDN. This is applicable just in case of stand alone machine.

     

    Regards,

     

    Janos

     

     

     

    Please mark the answer as helpful, when it was.

    Monday, July 16, 2007 6:07 AM
  • Hi,

     

    if the wizard failes the t-sql always works. Just run these lines:

     

    --in mirror

    ALTER DATABASE yourDB SET PARTNER = 'TCP://original_server:5022'

     

    --in original server

    ALTER DATABASE yourDB SET PARTNER = 'TCP://mirror_server:5022'

    ALTER DATABASE yourDB SET WITNESS = 'TCP://witness_server:5022'

     

    where 5022 is the port you stated in wizard. If you want to do everything manually (starting from the endpoints) then heres the commands and info:

    Database Mirroring in SQL Server 2005

     

    Ats

     

    Thursday, February 14, 2008 8:52 PM
  • Hi guys,,

     

     

                   i am working with two servers both are work group. i am getting the same error.

     

     

    Thanks

    Ayyappan

     

    Tuesday, July 15, 2008 1:16 PM
  • Hi Ali,

     

        We are not require to script to change the server name instead ip address. while you configure mirror thru wizard you need to mention all the information as per the system configuration at the end of the wizard configuration (ie, after clicking finish button) it will as you whether you are starting mirron now or not. click not now then 2 textbox having your server names with be enable for editing.

     

    please contact me if you have any doubt.

     

    Thanks

     

    Ayyappan

     

    (Adolf.ayyappan@gmail.com)

     

    Tuesday, July 15, 2008 1:38 PM
  • Did u upgrade to SP2.Its working realy nice.Try
    Friday, May 15, 2009 12:49 PM
  • I configured mirroring with GUI. When I'm pressing START MIRRORING I got this message:

    "One or more of the server network addresses lacks a FQDN. Specify the FQDN for each server and click Start Mirroring"


    Both servers are in separate locations with no active directory domain (just WORKGROUP), I made changes in hosts file, both servers runs under the same accont with the same password, I can ping servers by host and IP number. Just mirroring doesn't want to start. Both servers are updated including SP3. I did even DNS sufix trick - no help. I can telnet of 5022 ports.

    I was curious and done this on db2 server:

    ALTER DATABASE [db] SET PARTNER = 'TCP://db2:5022'

    and I got this:

    The server network address "TCP://db2:5022" can not be reached or does not exist.
    Check the network address name and that the ports for the local and remote endpoints are operational.

    Anyone can help me with it?
    Wednesday, November 25, 2009 7:18 PM
  • Can you try to see your computer's name and then select workgroup and specify the workgroup name that you are dealing with and restart your computer.?
    Thanks, Leks
    Thursday, November 26, 2009 12:07 AM
    Answerer
  • This problem that you can solved by set the dns suffix .
    The SQL database mirroring need the dns suffix to concate server name to FQDN.

    1. Open the server's properties window then click the [change] button
    2. Click [More] button
    3. Input the [Primary DNS suffix of this computer]
    4. Click [OK]

    When you change this setting, the win server need to restart.

    Jerrymow


    Thursday, January 28, 2010 4:50 PM
  • You need to run this on each of the sql servers that your going to use for mirroring. there normally is a endpoint that you need to delete and recreate.

    command is

    DROP ENDPOINT mirroring

    Go

    ·          

    and then click on the execute button.

    Friday, February 4, 2011 5:25 AM
  • it is a good post here.

    however, by changing Primary DNS suffix does not help for problems.

    my case is I use two standalone SQL2005 servers (SP2), I tried to change the Primary DNS suffix on both DB servers, but it doesn't work anymore.

    any experts who can post a T-SQL example?

     

     

    Saturday, July 30, 2011 11:43 AM
  • I resolved finally by setting both of MSSQL services with same account.

    also, combined methods by Jerrymow. by the way, alter host file, too.

    Thursday, August 4, 2011 12:48 PM
  • I am getting same error while setting up mirroring that need fully qualifed domain name. I am left to change dns suffix. But i am afraid i am running number of database does it impact any side line on running database. 

     

     

    Tuesday, October 11, 2011 11:24 AM