none
Cannot Restore AdventureWorksDW2014

    Question

  • Hi,

    I just downloaded "Adventure Works DW 2014 Full Database Backup.zip" from http://msftdbprodsamples.codeplex.com/releases

    After extracting the Backup File, I tried to restore the DB into SQL Server 2014 SP1 but it did not work. using the script results in:

    Msg 3201, Level 16, State 2, Line 2
    Cannot open backup device 'D:\martinv\Databases\AdventureWorksDW2014.bak'. Operating system error 2(The system cannot find the file specified.).
    Msg 3013, Level 16, State 1, Line 2
    RESTORE DATABASE is terminating abnormally.

    BTW: The Backup File has only the Size of 21MB, which seems even to samll for me.

    The File seems to be corrupt.

    Regards

    Martin Vollmer



    • Edited by theVollmix Saturday, October 17, 2015 12:47 PM
    Saturday, October 17, 2015 12:46 PM

All replies

  • 1) check backup folder and file name

    2) see you have full permission that folder.


    Please click "Mark As Answer" if my post helped.

    Saturday, October 17, 2015 5:33 PM
  • The error message is clear: the backup file is not where you pointed SQL Server to. Keep in mind that unless you are running SQL Server on your desk/laptop, D: means something else to SQL Server than it means to you. As it does, if D is a mapped network disk.

    Yes, 21 MB seems far too small, but if the file was damagaed, the error message would be different.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Saturday, October 17, 2015 7:22 PM
  • check the result..

    RESTORE VERIFYONLY FROM DISK = 'D:\martinv\Databases\AdventureWorksDW2014.bak' GO


    Please click "Mark As Answer" if my post helped.

    Sunday, October 18, 2015 11:06 AM
  • In addition to other advices make sure to start SSMS running in Admin mode.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Sunday, October 18, 2015 7:15 PM
    Moderator
  • Make sure this path exists D:\martinv\Databases. If still error copy the backup file to some other drive and restore the file. Few times we will not have permissions on the few drives which makes to throw such errors.


    Regards, Pradyothana DP. Please Mark This As Helpful if it helps to solve your issue. ========================================================== https://social.technet.microsoft.com/Profile/pradyothanadp http://www.dbainhouse.blogspot.in/

    Monday, October 19, 2015 5:48 AM
  • Hi,

    @Dinesh: the query:

    RESTORE
     VERIFYONLY FROM DISK = 'D:\martinv\Databases\AdventureWorksDW2014.bak'
    GO

    results in:

    Msg 3241, Level 16, State 0, Line 1
    The media family on device 'D:\martinv\Databases\AdventureWorksDW2014.bak' is incorrectly formed. SQL Server cannot process this media family.
    Msg 3013, Level 16, State 1, Line 1
    VERIFY DATABASE is terminating abnormally.

    So for me it Looks like the file is corrupt. I successfully restored other SQL Backups from the same Directory.

    I downloaded the File on several machines and I always get the same corrupted file:

    If you go to codeplex downlaod site, you can see the Fiel Size as 21027K, which seems way to small for me.

    Best Regards

    Martin

    Monday, October 19, 2015 8:54 AM
  • 1. Select @@version from both servers
    2. Please post output of Restore Headeronly

    Please click "Mark As Answer" if my post helped.

    Monday, October 19, 2015 11:21 AM
  • Hi everybody,

    Ok, it is embarrassing for me to admit that I was too stupid to notice, that SQL Management Studio was still connecting with the "old" SQL Server 2012 instance. I thought instaling SQL Server 2014 will automatically upgrade to SQL Server 2014. But I have both instances running right now. Connecting SQL Management Studio with the new (named) Instance of SQL Server 2014 solved the problem.

    The Question about the actual Version of the DB engine gave me the hint to my fault.

    Sorry for bothering and thanks for the Support.

    Martin

    Monday, October 19, 2015 12:37 PM