none
powerpivot add-in disappeared in excel.... RRS feed

Answers

  • 1) Check whether the add-in is disabled, you can find that from file->options-->addins-->Manage Disabled Items and click Go. If you find PowerPivot for Excel is disabled enable it

    2) Check whether the add-in is unloaded, you can find that from file-->options>addins->Manage COM addins and click Go. If PowerPivot for Excel is unchecked, check it again.

    3) Make sure your Excel Version is compatible with PowerPivot.

    4) If you still have problem, try the below steps which should give you error

    1) Open My Computer Properties
    2) Click on Advanced Tab
    3) Click on the Environmental Variable
    4) Click on New User Variable
    5) Add VSTO_SUPPRESSDISPLAYALERTS with value 0 press OK
    6) Repair PowerPivot For Excel from add/remove
    program
    7) Open Excel again, it will prompt an error message.

     

    Hope this helps!

     

    Thanks,

    Deva [MSFT]


    Deva
    Tuesday, April 20, 2010 3:45 PM

All replies

  • Check if you are using the latest version of Power Pivot for excel 2010.
    Nitesh Rai- Please mark the post as answered if it answers your question
    Monday, April 19, 2010 12:20 PM
  • One way you can check the build number is to look at file version for c:\program files\microsoft analysis services\as excel client\10\Microsoft.AnalysisServices.Modeler.FieldList.dll

    Thanks,

    Lisa

    Monday, April 19, 2010 6:01 PM
    Moderator
  • i had the same error. Reinstalling PowerPivot-MSI or manual activating the addin in excel (Backstage>Options>Add-Ins..) didn't help.

    So i logged on to the system with another useraccount and with this useraccount i could see the powerpivot icon in the excel ribbon!

    So my tipp is:  
    use another useraccount/profile to test if your problem has to do with userprofile or powerpivot installation in general..
    Is so try to delete the existing userprofile and logon again to create a new windows-userprofile..

     

    Tuesday, April 20, 2010 2:54 PM
  • 1) Check whether the add-in is disabled, you can find that from file->options-->addins-->Manage Disabled Items and click Go. If you find PowerPivot for Excel is disabled enable it

    2) Check whether the add-in is unloaded, you can find that from file-->options>addins->Manage COM addins and click Go. If PowerPivot for Excel is unchecked, check it again.

    3) Make sure your Excel Version is compatible with PowerPivot.

    4) If you still have problem, try the below steps which should give you error

    1) Open My Computer Properties
    2) Click on Advanced Tab
    3) Click on the Environmental Variable
    4) Click on New User Variable
    5) Add VSTO_SUPPRESSDISPLAYALERTS with value 0 press OK
    6) Repair PowerPivot For Excel from add/remove
    program
    7) Open Excel again, it will prompt an error message.

     

    Hope this helps!

     

    Thanks,

    Deva [MSFT]


    Deva
    Tuesday, April 20, 2010 3:45 PM
  • File/Options/Add-Ins/Manage/Disabled items/ 

    enable: Microsoft.AnalysisServices.Modeler.FieldList.Addin.Integration

    Tuesday, April 27, 2010 9:15 PM
  • Hi Deva

    The second option worked for me.. thank you

    Arun

    Friday, March 9, 2012 2:54 PM
  • Hi Deva,

    The second option works for me too. but the problem is I have to do this everytime I open Excel. I have another com addin (Acrobat) which loads fine everytime.

    Any suggestions? TIA.

    • Proposed as answer by Gr3en39 Thursday, November 22, 2012 5:54 PM
    • Unproposed as answer by Gr3en39 Thursday, November 22, 2012 5:54 PM
    Monday, June 11, 2012 3:20 PM
  • This worked for me :

    File/Options/Add-Ins/Manage/COM Add-ins/  -> go

    Check : PowerPivot for Excel -> ok

    Thursday, November 22, 2012 6:10 PM
  • second option worked! Why would they disable the add-in right after you installed it?

    Thursday, December 20, 2012 10:16 PM
  • This worked for me too. Thanks
    Friday, December 16, 2016 9:09 PM
  • I had the same problem. I am running Windows 10 and Excel 2016.  I would be working fine with PowerPivot, but then sometimes after closing and reopening the Spreadsheet, the PowerPivot Menu Pad option would not show up, even though it was in my add-ins.  It did not matter what spreadsheet file I opened, it would not show up.  The only way it would show up again was after rebooting my system.  Not fun !!

    After great frustration, I decided that maybe there was a lingering Excel process running, even after closing all my Excel spreadsheets.  Sure enough, there was, and so I killed the Microsoft Excel process from Task Manager.  I then opened my Excel Spreadsheet, and like magic, PowerPivot menu pad option was there again and I did not have to go through the pain and suffering of a reboot.

    Hope this works for you.

    • Proposed as answer by Jake Burns Saturday, March 10, 2018 1:04 AM
    Monday, March 6, 2017 3:11 PM
  • My case was similar: for the main user, no Power Pivot. For my admin and test accounts, the Power Pivot tab was visible in Excel.

    The fix was to export the Addins reg key from a good profile where it worked, then import into the broken user's profile.

    Here is the one for my specific install. Yours may vary:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins]

    [HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Microsoft.AnalysisServices.Modeler.FieldList]
    "Description"="Microsoft SQL Server PowerPivot for Microsoft Excel"
    "FriendlyName"="PowerPivot for Excel"
    "LoadBehavior"=dword:00000003
    "Manifest"="C:\\Program Files (x86)\\Microsoft Analysis Services\\AS Excel Client\\110\\Microsoft.AnalysisServices.XLHost.Addin.vsto|vstolocal"
    "CartridgePath"="C:\\Program Files (x86)\\Microsoft Analysis Services\\AS OLEDB\\110\\Cartridges\\"

    Monday, July 24, 2017 10:24 PM
  • Bingo,

    Worked for me.  Phew!  Did not want to go through all the other steps.  Thanks for this tip Greg.  To all the other uses, make sure to check in PROCESSES from the task manager, not APPLICATIONS.

    Saturday, March 10, 2018 1:05 AM