none
Update SSIS packages to use Microsoft.ACE.OLEDB.16.0 driver RRS feed

  • Question

  • Hi ,

    Can we update SSIS Packages, Excel connection manager to use provider "Microsoft.ACE.OLEDB.16.0". currently all our packages are using "Microsoft.ACE.OLEDB.12.0" provider  and are cerated in 2008 Business intelligence.

    Can you please provider the steps to be followed inorder to update packages.

    Thanks in advance.




    • Edited by Gopi520 Tuesday, April 3, 2018 3:38 PM
    Tuesday, April 3, 2018 3:37 PM

All replies

  • Hi Gopi520,

    I guess this is driven by a need of being able to process the newer MS Office file format-wise.

    Then I see it even necessary, but you would need to redeploy the packages after you installed the newer driver.


    Arthur

    MyBlog


    Twitter

    Tuesday, April 3, 2018 6:17 PM
    Moderator
  • which is your IS server version? what SSDT version are you using to create the package?

    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Tuesday, April 3, 2018 6:47 PM
  • HI ,

    My IS sever version is IIS7.5 and   I'M using  2008 Business intelligence to create packages.


    Thanks,

    Tuesday, April 3, 2018 9:03 PM
  • HI,

    Thanks for the info .We will redeploy the packages after we succesfully connect new provider. 

    I have installed Microsoft Access Database 2016 to get drive "Microsoft.ACE.OLEDB.16.0" and it was installed sucessfuly.But when i tried creating new excel connection Manager in 2008 BI studio it taking the older driver i.e "Microsoft.ACE.OLEDB.12.0" .

    Can we connect "Microsoft.ACE.OLEDB.16.0" Provider from 2008 Bi studio?

    Thanks in advance

    Tuesday, April 3, 2018 9:27 PM
  • Hi Gopi520,

    IS means Integration Service.

    Likely you are using SSIS 2008, there's no document describes the minimum version requirement for the ACE 16.0 driver. I guess ACE 16.0 is not supported to SSIS 2008.

    By the way, BIDS 2008 is too old to develop SSIS packages, try to use SSDT 2012.

    See: Previous releases of SQL Server Data Tools (SSDT and SSDT-BI)

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 4, 2018 7:21 AM
    Moderator
  • HI ,

    My IS sever version is IIS7.5 and   I'M using  2008 Business intelligence to create packages.


    Thanks,

    Not IIS 

    I meant SSIS server.

    SO I guess you're on SSIS 2008 based on your BIDS version

    Also what is the version of the ACE provider you installed? Is it 32/64 bit?


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Wednesday, April 4, 2018 7:34 AM
  • HI ,

    Yes i am using 2008 BI Studio.

    I have installed 64 bit ACE Provider.

    Thanks,

    Wednesday, April 4, 2018 3:20 PM
  • Hi Gopi520,

    Perhaps SSIS 2008 is not supported to use ACE 16.0 driver.

    Just install proper drive which works on your server .

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, April 10, 2018 9:15 AM
    Moderator