Variable error


  • I'm trying to set up a simple package that can be run after other packages to move packagelog files to another folder(I'm doing this because it doesn't look like we can overwrite a package log file and I really don't want to have to manually keep these in check). Anyway, I've got a source variable and a destination variable.  I'm using an expression to build these values in the File System Task. When I run the package I get this error :  

    Error: 0xC0014054 at CopyPackageLog: Failed to lock variable "C:\Temp\MyPackageLog.xml" for read access with error 0xC0010001 "The variable cannot be found. This occurs when an attempt is made to retrieve a variable from the Variables collection on a container during execution of the package, and the variable is not there. The variable name may have changed or the variable is not being created."

    It looks like the variables are getting loaded with the correct path names. Any suggestions?


    Wednesday, March 29, 2006 9:28 PM

All replies

  • It looks like you have specified C:\Temp\MyPackageLog.xml as the variable name, but it seems more like what should be in the value. What is your expression?
    Thursday, March 30, 2006 8:09 AM
  • I was building path expressions and assigning them to the source and destination in the task. I was also doing the same thing in the package explorer. Once I eliminated the assignment in the task everything worked fine.


    Thanks for the response!!!!


    Thursday, March 30, 2006 2:56 PM