none
SQL2008 keeps asking for restart

    Question

  •  

    Hi,

     

    I'm trying to install SQL2008 RTM, but the installer keeps asking to restart the computer?

     

    Any thoughts?

     

    Yours sincerely,

     

    Henk Simmelink

    Tuesday, August 19, 2008 6:29 AM

Answers

  • Hi,

     

    I have the same problem before, endup I need to modify the register setting to by pass this.  You can open Regedit, and modify this key"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"  and delete any value in "PendingFileRenameOperations"

    Wednesday, September 03, 2008 10:52 PM

All replies

  • If you have shared components (DLL's) that are used/loaded by other programs (another SQL instance, etc.), sql2k8 setup need to restart the system to get the new libraries loaded. You see this sorts of requests with Windows updates for .NET, service pack, for example.

     

     

     

    Tuesday, August 19, 2008 7:27 AM
    Moderator
  •  

    Before insatlling it gathers all required components for installtion and running flowlessly, Like as OJ mentioned libraries and .net framework if not installed something like, These cahnges takes effect after retstarting System.

    Its normal,

    After installing i can assure it  must not need retsart as we were doing MSSQL 2000 for any changes to take effect.

     

    Thanks

    Praveen barath

    Tuesday, August 19, 2008 9:41 AM
  • Hi Praveen,

     

    I'm sorry if my question wasn't clear enough.

     

    But I've now started my computer at least ten times, but still I can't go any further with the setup.

     

    Thanks for your answer!

     

    Yours sincerely,

    Henk Simmelink

     Praveen Barath wrote:

     

    Before insatlling it gathers all required components for installtion and running flowlessly, Like as OJ mentioned libraries and .net framework if not installed something like, These cahnges takes effect after retstarting System.

    Its normal,

    After installing i can assure it  must not need retsart as we were doing MSSQL 2000 for any changes to take effect.

     

    Thanks

    Praveen barath

    Tuesday, August 19, 2008 10:13 AM
  • Could you please define where, i mean in which step it is asking for restart or it is asking after restarting it constantly.

    See what i feel is remove completely 2008 and rerun the setup and before commiting run the system check it will appear before installation tab.

    And do not ignore any error or baloon it shows.

    I hope it would inline your need, make sure no other installtion is running simaltaniously.

    Close all internet explorer pages if opens and try.

    Post your errors if any.

     

    Thanks

    BR
    Praveen Barath

     

    Tuesday, August 19, 2008 10:24 AM
  • If you get a time i would suggest you go through this page.

    http://blogs.msdn.com/psssql/default.aspx

    Many things has been discussed.

     

    Gud luck

     

    BR
    Praveen Barath

     

    Mark as anwer if it helps

     

    Tuesday, August 19, 2008 10:32 AM
  • Praveen,

     

    It doesn't matter what I do: configuration check or installation (new or update).

     

    There is no explaination, only the demand to restart my laptop.

     

    Installed on my laptop:

    VS2008 SP1

    SQL Server 2005 Developer Edition 9.2.3042

     

    Yours sincerely,

     

    Henk

     

     Praveen Barath wrote:

    Could you please define where, i mean in which step it is asking for restart or it is asking after restarting it constantly.

    See what i feel is remove completely 2008 and rerun the setup and before commiting run the system check it will appear before installation tab.

    And do not ignore any error or baloon it shows.

    I hope it would inline your need, make sure no other installtion is running simaltaniously.

    Close all internet explorer pages if opens and try.

    Post your errors if any.

     

    Thanks

    BR
    Praveen Barath

     

    Tuesday, August 19, 2008 10:53 AM
  • Does it MSSQL 2008 which requires restarts or windo updates or something else.

    See untill unless i wont get the exact problem, wount be able to provide you right solution.

    Installations are not require that much restarts its doesnt seems to be normal behaviour of SQL.

    I would suggest you to check your error logs or if doesnt comes up reinstall MSSQL 2008 after removing OLD MSSQL 2008 insatllation.

    then follow errors and try to resolve those.

     

    Any any errors occured please post.

     

    Praveen

     

    Tuesday, August 19, 2008 12:41 PM
  • Hi Praveen,

     

    Thank you again for your assistance.

     

    The only thing that I do is after reboot is double click the setup.exe and then I click the Configuration Checker.

     

    In the log file is then written:

     

    2008-08-19 21:20:39 Slp: Initializing rule      : Restart computer
    2008-08-19 21:20:39 Slp: Rule applied features  : ALL
    2008-08-19 21:20:39 Slp: Rule is will be executed  : True
    2008-08-19 21:20:39 Slp: Init rule target object: Microsoft.SqlServer.Configuration.SetupExtension.FacetRebootRequired
    2008-08-19 21:20:39 Slp: Rule 'RebootRequiredCheck' results: IsRebootNotRequired=False
    2008-08-19 21:20:39 Slp: Evaluating rule        : RebootRequiredCheck
    2008-08-19 21:20:39 Slp: Rule running on machine: LAPTOPEIGER
    2008-08-19 21:20:39 Slp: Rule evaluation done   : Failed
    2008-08-19 21:20:39 Slp: Rule evaluation message: A computer restart is required. You must restart this computer before installing SQL Server.

     

    All other rules are succeeded or not executed.

     

    Under Add or Remove Programs there is no mention of a previous install of SQL-server 2008, so I can't undo it (anymore).

     

    That is all that I can find.

     

    Yours sincerely,

     

    Henk

     

     

     

     

     

    Tuesday, August 19, 2008 7:53 PM
  •  SQLUSA wrote:

    Henk,

     

    The above log is from the new feature: Policy-Based Management.

     

     

    This is the setup bootstrap log, and has nothing to do with policy based management.

     

    I had this same problem on my laptop where I had VS 2008 installed first.  I removed VS 2008, rebooted, and was able to install SQL 2008.  Then I installed VS 2008 and SP1 and all is well.  You might give this a shot.  Also make sure that you have the actual SP1 and not one of the betas installed for VS 2008.  I did this based on the following blog post recommendation #2:

     

    SQL Server 2008, Visual Studio 2008 SP1, and .Net Framework 3.5 SP1 explained....

     

    Tuesday, August 19, 2008 9:25 PM
    Moderator
  • Hi,

     

    I have the same problem before, endup I need to modify the register setting to by pass this.  You can open Regedit, and modify this key"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"  and delete any value in "PendingFileRenameOperations"

    Wednesday, September 03, 2008 10:52 PM
  • Thanx!!!

     

    SQL server is now installing in background.

     

    Yours sincerely,

     

    Henk

    Sunday, September 07, 2008 11:34 AM
  • Thank you!

    Sunday, September 28, 2008 3:34 PM
  • Thank you. Deleting the entry in the registry worke.
    Thursday, October 02, 2008 8:18 PM
  • Cheers Tomas that worked a treat.

     

    Alixx

     

    Tuesday, October 21, 2008 10:58 AM
  • I have this exact problem but there is no such value in my registry.  How what?  Thanks.

     

    Monday, October 27, 2008 6:39 PM
  •  

    Thanks TomasLeung !
    Tuesday, October 28, 2008 4:39 AM
  •  

    Thanks Tomas, your trick regarding registry helped.

     

    Regards,

    Anwar

    Wednesday, October 29, 2008 9:52 AM
  • Thanks a lot Thomas........
    tanx

    Friday, October 31, 2008 4:59 AM
  • Thanks for you kindly shared this method for ignore RebootRequiredCheck fail.

    But I still get the alert notice after I delete the key. Because I had had the windows updates before the install check. But I couldn't reboot the machine right away. Does it not any work if I delete the key after the windows update? Please kindly adivce ~~ Thanks!!


     

     

    Thursday, November 13, 2008 3:33 AM
  • thank you very much

    Friday, November 28, 2008 2:29 AM
  • That fixed it for me! Tnx!
    Brave Cobra
    Monday, December 29, 2008 12:57 PM
  • Yup worked great thanks
    Wednesday, February 25, 2009 5:42 PM
  • Hi everybody, I did what TomasLeung said about deleting a key in FileRenameOperations, but I have no key there, it is already empty! I still can't install SQL Express Edition because of the "Restart computer" failed. Can anyone help me??
    Saturday, February 28, 2009 11:49 PM
  • I'm having the same problem as sir Jamsheed - no value in the registry but still keeps asking for reboot.

    Can anyone help?
    Thursday, April 23, 2009 1:45 PM
  • Thomas,

    You are the best.  It solved my problem.  I think I know why I may have this problem.   Here are the key values that I deleted from my registry:

    \??\C:\Windows\TEMP\logishrd\LVPrcInj03.dll
    \??\C:\Windows\TEMP\logishrd\

    These values appear to have something to do with the logi tech camera or logitec mouse driver that I've installed.   I did notice periodically that I get a "ballon" message on the task tray stating that there is something wrong with the logitec devices I installed.

    JIM

    Saturday, May 02, 2009 10:16 AM
  • Hopefully the following notes would be useful...

    In my case, after I deleted the registry keys, then rebooted my computer, the unwanted registry keys reappeared.  

    Thus, to install SQL 2008 express, I had to

    1) Delete the registry keys that Tomas recommended above (and not boot the computer)
    2) Then clicked "Re-Run".  The status then changed from "Failed" to "Passed"
    Saturday, May 02, 2009 12:04 PM
  • Jim555, you are right, I have the same siatuation

    I have clean installation on Windows 7 and Logitech webcam installed with the latest updates - SQL2008 fail to setup with the same symptoms - even after deleting the keys from registry and restarting system.

    After deleting this Registry key and Re-Run without restarting checks all pass successfully. Great thanks.
    • Proposed as answer by Estyfen Alzate Tuesday, June 16, 2009 11:50 PM
    Monday, May 11, 2009 8:35 AM
  • The solution for installed SQL Server 2008 in Windows Server 2008  realy is the next:

    Before disculped for my english I am from Colombia city: Ibague

    1. Disabled for one moment the Windows Defender for could modify registry of windows 
    2. start > Run
    3. Regedit.exe   and Enter
    4. Modify this key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"  and Rename any value in   "PendingFileRenameOperations" by for example ""PendingFileRenameOperations2"

    5. After restarting setup or checks validation rules of SQL Server 2008 and succesfully..


    my email is : atyfen@gmail.com
    • Proposed as answer by Kalman Toth Wednesday, June 17, 2009 12:44 AM
    Tuesday, June 16, 2009 11:39 PM
  • Fantastic.... my problem got resolved and I was able to install Sql Server 2008 on win 7.

    Ravi Gokulgandhi
    Saturday, August 08, 2009 8:45 AM
  • Thank you for the solution.  Worked great.

    Christopher Blanchard
    Tuesday, August 11, 2009 11:32 PM
  • Hi,

    I had this problem installing SQL 2008 RTM on a Windows server 2008 R2 and didn't found any mentioned regristry entries.

    I run
               D:\Setup /action:install /skiprules:RebootRequiredCheck
    in a Dos box and the test was skiped.

    regards
    Frank

    • Proposed as answer by Zekayi BAŞARA Wednesday, July 13, 2011 4:01 PM
    Saturday, October 10, 2009 1:49 PM
  • THank you, Thank you, THank you
    I have also got SQL running now^^"
    So happy
    Tuesday, February 16, 2010 7:55 PM
  • TomasLeung , thanks! you just helped solved my problem.. your workaround works! wonderfully!
    a
    Thursday, February 25, 2010 3:02 PM
  • I tried doing the regedit and it didnt help any other advice

     

    Chris

    Tuesday, June 15, 2010 2:22 PM
  • Thanks. This worked for me ....
    • Proposed as answer by tdas Wednesday, August 11, 2010 9:12 AM
    Wednesday, August 11, 2010 9:12 AM
  • Thanks! it worked on my Win7.
    Thursday, November 04, 2010 1:55 PM
  • This helped for my Windows XP.

    But registry path for key "PendingFileRenameOperations" was little bit different (HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Session Manager). So suggestion is to run Regedit and find the key by the following parameters:

    TEMP\logishrd

    ,then delete any values for the key "PendingFileRenameOperations"

    Tuesday, January 18, 2011 12:24 PM
  • Thanks TomasLeung. Deleting those values worked.

     

    Wednesday, March 23, 2011 2:19 PM
  • thanks Tomas... worked for me too after 3 times restart of the server... :) thanks for posting this.
    Thursday, August 25, 2011 11:01 AM
  • /SkipRules=VSShellInstalledRule RebootRequiredCheck

    Rick

    Friday, June 15, 2012 7:13 PM
  • Changing the registry key doesn't made any effect, than I tried your suggestion and I got a message that the argument "=" is missing, so I changed ":" for "="

    For me worked using the following command:

     D:\Setup /action=install /skiprules=RebootRequiredCheck

    Thanks for the tip.


    Thursday, November 29, 2012 2:25 PM
  • Hi,

     

    I have the same problem before, endup I need to modify the register setting to by pass this.  You can open Regedit, and modify this key"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager"  and delete any value in "PendingFileRenameOperations"

    This works on Win 2012 Standard. Exchange 2013 asked me to restart because of this "PendingFileRenameOperations".

    Thank you,

    Sunday, February 01, 2015 8:01 AM