none
Unable to install Client Print Control for SSRS 2014 onto a 32-bit Windows 7 PC RRS feed

  • Question

  • The title pretty much says it all.

    We have a client who recently upgraded to SQL Server 2014. Everything looked good until they tried to print out a SSRS report on a 32-bit Windows 7 machine. First the prompt pops up asking if you want to download the control from Microsoft. Hit yes, and it acts like it is going to install. Instead of the printer dialog, we get an error that states: Printing is not available. Verify that ActiveX is enabled, or try using Internet Explorer for the desktop. 

    We had no problem with SSRS 2012 Client print control. I have tried installing it with UAC turned off, and as Domain admin (which normally fixed the problem in older versions).

    I have tried to install it manually by extracting the files from the C:\Program Files\MSRS12\Reportingervices\ReportServer\Bin\RSClientPrint-x86.cab and putting the files at C:\Windows\Downloaded Program Files and ran  regsvr32.exe /s "C:\Windows\Downloaded Program Files\RSClientprint.dll" This has not worked either.

    Any suggestions on what I should try next? Or will this even run on a 32-bit version of Windows 7? 

    Monday, June 15, 2015 6:18 PM

Answers

  • Hi Breeser-vms,

    According to your description, when you try to install client print control, the error “Printing is not available. Verify that ActiveX is enabled or try using IE from the desktop” is thrown out, right?

    In Reporting Services, each user who wants to use the print feature must download and install the ActiveX control that provides client print functionality. The first time a user clicks the Printer icon on the report toolbar, the Microsoft ActiveX control is downloaded to the computer. After the control is downloaded, the Print dialog box displays whenever the user clicks the Printer icon. In your scenario, please refer to some tips below to troubleshot the issue:

    Firstly, you should check if the EnableClientPrinting is set to true. Please refer to screenshot below:

    Then please check if you have selected "Enable for Download signed ActiveX controls" in IE browser. Please refer to steps below:
     1.Click Tools -> Internet options.
     2.Switch to the Security tab, select the Trusted sites zone, and then click Sites.
     3.Type the URL of Report Server, click Add, and then click Close .
     4.Click the Custom level button, scroll to the ActiveX controls and plug-ins node.
     5.Click Enable for Download signed ActiveX controls, and then click OK.

    Besides, please always run the IE as administrator and in the compatibility mode.

    Reference:
    Enable and Disable Client-Side Printing for Reporting Services

    If you have any question, please feel free to ask.

    Best regards,
    Qiuyun Yu


    Qiuyun Yu
    TechNet Community Support


    • Marked as answer by Breeser-vms Thursday, June 18, 2015 3:57 PM
    Tuesday, June 16, 2015 8:43 AM
    Moderator

All replies

  • Hi Breeser-vms,

    According to your description, when you try to install client print control, the error “Printing is not available. Verify that ActiveX is enabled or try using IE from the desktop” is thrown out, right?

    In Reporting Services, each user who wants to use the print feature must download and install the ActiveX control that provides client print functionality. The first time a user clicks the Printer icon on the report toolbar, the Microsoft ActiveX control is downloaded to the computer. After the control is downloaded, the Print dialog box displays whenever the user clicks the Printer icon. In your scenario, please refer to some tips below to troubleshot the issue:

    Firstly, you should check if the EnableClientPrinting is set to true. Please refer to screenshot below:

    Then please check if you have selected "Enable for Download signed ActiveX controls" in IE browser. Please refer to steps below:
     1.Click Tools -> Internet options.
     2.Switch to the Security tab, select the Trusted sites zone, and then click Sites.
     3.Type the URL of Report Server, click Add, and then click Close .
     4.Click the Custom level button, scroll to the ActiveX controls and plug-ins node.
     5.Click Enable for Download signed ActiveX controls, and then click OK.

    Besides, please always run the IE as administrator and in the compatibility mode.

    Reference:
    Enable and Disable Client-Side Printing for Reporting Services

    If you have any question, please feel free to ask.

    Best regards,
    Qiuyun Yu


    Qiuyun Yu
    TechNet Community Support


    • Marked as answer by Breeser-vms Thursday, June 18, 2015 3:57 PM
    Tuesday, June 16, 2015 8:43 AM
    Moderator
  • Thanks for the assistance. This helped to allow me to getting it working.

    Also should mention that on the machines I was working on, I had to turn UAC off on some machines, and needed to install Microsoft Visual C++ 2010 Redistributable Package (x86) found here on some of the 32-bit machines, as they appeared to be missing it.



    • Proposed as answer by banou Thursday, August 25, 2016 5:08 PM
    • Unproposed as answer by banou Thursday, August 25, 2016 5:08 PM
    Thursday, June 18, 2015 4:02 PM
  • My computer is in a domain and my user domain has not permission to install and copy.

    My sqlserver is 2014.

    my operating system is windows 7-32bit. I did this tasks with administrator domain account ,but my problem did not solve.

    1- I extracted rsclientprint-x86.cab and copied those files in c:\windows\system32

    2- I ran "cmd" in "Run as administrator" Mode and execute  Regsvr32 rsclientprint.

    then I logged off and logged in with simple user domain account and it worked.

    but when I restarted or shut-ted down , i had to do this routine again.

    please help me.Thanks.

    Thursday, August 25, 2016 3:12 AM