none
SQLAgent is not allowed to run

    Question

  • Hi 

    Keep getting this message in the Application Event Viewer.


    Source:        SQLAgent$SHAREPOINT

    Category:     Alert Engine

    Event ID:       324

    Description: SQLAgent is not allowed to run.


    Can't find any help online. Anyone out there got any ideas?

    TIA

     

    Thursday, February 9, 2006 2:17 PM

Answers

  • try this link, it worked for me

    http://www.alanbarber.org/index.php/weblog/comments/fixing_sqlagent_is_not_allowed_to_run_error1/

    Nige
    Monday, February 13, 2006 2:25 PM

All replies

  • try this link, it worked for me

    http://www.alanbarber.org/index.php/weblog/comments/fixing_sqlagent_is_not_allowed_to_run_error1/

    Nige
    Monday, February 13, 2006 2:25 PM
  • "This is for anyone running Sharepoint on Microsoft Windows Server with MS-SQL and you are getting an error along the lines of “SQLAgent is not allowed to run”.

    All you have to do is make a small registry change.  Navigate to:
    “HKEY_LOCAL_MACHINE/ SOFTWARE/ MICROSOFT/ MICROSOFT SQL SERVER/ SHAREPOINT/ SQLSERVERAGENT”

    Look for the key “GUID” and delete it.

    the SQLAgent service should now start up without problems."



    I'm surprised there wasn't an official response from Microsoft on this error.




    Friday, August 10, 2007 4:44 PM
  • You don't mention what versions of the products are involved which alway makes it more difficult to help out but I would guess you hit something similar to the following issue documented by Microsoft:

    http://support.microsoft.com/?id=823467

     

    -Sue

    Sunday, August 12, 2007 4:19 PM
  • Hi

     

    I am also geting this problem but running on a SQL2005 instance running share point services. Is it the same fix as in the artical regarding SQL2000 delete the GUID key in the reg???

     

    ta

    Jon 

     

    After feeling like taking a bit of a risk i tried deleting the GUID on the 2005 instance and so far (touch wood) it seems to have worked the SQL Agent is running again

     

    Monday, October 22, 2007 2:56 PM