none
The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.

    Question

  • Hi,

     

    I am facing the below mentioned error:

     

    The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.
    [OLE/DB provider returned message: New transaction cannot enlist in the specified transaction coordinator. ]
    OLE DB error trace [OLE/DB Provider 'SQLOLEDB' ITransactionJoin::JoinTransaction returned 0x8004d00a].

     

    I have a Insert statement which i am using to insert data into a remote server from my local server. I have added the remote server as a linked server in my local server but when i try to execute the statement i am getting the above mentioned error. I am using Windows Enterprise Edition 2003 and SQL Server 2000.

     

    I have also enabled the Allow InBound and Allow OutBound in the security configuration of My Computer properties but still i am facing the same problem. Kindly let me know how to resolve this issue.

     

    Thanks.

    Monday, January 14, 2008 2:51 AM

All replies

  • Tuesday, January 15, 2008 9:36 PM
    Moderator
  • Hi,

     

    I checked the article and tried the option. MSDTC service is already enabled. But still i am facing the same problem.

     

    Thanks

    Wednesday, January 16, 2008 5:02 AM
  • Is it enabled both on a client and on a server?
    Also have you checked the Component Services->Computers->My Computer->Properties->MSDTC->Security Configuration?

    Friday, January 18, 2008 9:47 PM
    Moderator
  • I am having the very same issue, I have the service running on both servers and currently running Server 2000/SQL2000.

     I am moving from Server 2003 cluster with 2 nodes /SQL2000, I have followed the articles to a "T" and still do not know why I get the error. Any ideas? Thanks

     

    Monday, January 21, 2008 10:51 PM
  • I have the the service running on both servers. But still i am facing the same issue. Any ideas?

     

    Thanks

    Tuesday, January 22, 2008 9:50 AM
  •  

    Hi,

    Have you solved the problem yet? Do you configure Windows Firewall to include the MSDTC program and include port 135 as an exception? Please have a look at the following link for more info :http://support.microsoft.com/kb/839279.

     

    Regards

    Jing

    Friday, July 11, 2008 7:07 AM
  • Have you guys tried restarting first the DTC and then the SQL services on both computers? That might fix it.

     

    Wednesday, July 30, 2008 3:28 PM
  • Any solutions?
    Thursday, January 29, 2009 4:41 AM
  • Start the MSDTC service.

    Windows 2008 example here::

    From "administrative tools" -> "component services" -> "computers" -> 

    "my computer" , "local dtc" right click "properties" 

    goto MSDTC tab and select "security configuration", enable checkbox 

    for "network dtc access" and "allow outbound".

    Check No Authentication Required.

     

    • Proposed as answer by LBSysadmin Thursday, December 05, 2013 7:59 PM
    Tuesday, October 27, 2009 10:47 PM
  • Thanks SIGUESIGUESPUTNIK!  That worked like a champ.

    SQL 2000/Windows 2003 <--> SQL 2008/Windows 2008


    -Jim Roberts
    Thursday, April 08, 2010 5:28 AM
  • Thank you Sigues! That solved my problem as well.
    Wednesday, July 07, 2010 6:27 PM
  • Hi, I am facing the same problem when tried to execute a distrubed query from 2000 linked on SQL 2008

    and as mentioned above that I have to check the DTC on both servers and I followed the instruction for SQL 2000 but I can't do the same for 2008 coz it's clusterd enviroment..

     

    any clue i will be greatly appricaited

    Thursday, September 16, 2010 12:10 PM
  • Please check this Link



    Nareshkar Pakanati 

    MCTS, MCITP IT Specialist
    My Blog: www.mssqlfix.com
    Twitter: @mssqlfix
    -------------------------------------------------------
    Please mark the post as Answered if it answers your question.
    -------------------------------------------------------

    Wednesday, November 07, 2012 5:46 AM