none
SSMS2018 - Installed, but will not run RRS feed

  • Question

  • Windows 2016 Standard Edition.  Brand new Hyper-V image.  No prior SSMS on the server.  Freshly installed SQL 2014, 16, and 17, Standard and Enterprise as 6 named instances.  Restarted multiple times.  Repaired the SSMS install.  Restarted.  I chose to install in a named folder: C:\Program Files (x86)\SSMS18  ..\Common7\ Size on disk: (1,090,367,488 bytes)

    All that shows is the splash screen, then nothing.  Run as administrator - I am a Local Admin - nothing.

    Event Viewer - Nothing.  I have my doubts that this is relevant - but it could show some kind of permissions problem - so I could so easily be wrong, not being a Windows Admin but a DBA:

    sqlservr (3320) SoftwareUsageMetrics-Api: An attempt to open the file "C:\Windows\system32\LogFiles\Sum\Api.log" for read only access failed with system error 5 (0x00000005): "Access is denied. ".  The open file operation will fail with error -1032 (0xfffffbf8).

     sqlservr (3320) SoftwareUsageMetrics-Api: Error -1032 (0xfffffbf8) occurred while opening logfile C:\Windows\system32\LogFiles\Sum\Api.log.

    Please assist.

    Thursday, April 25, 2019 12:08 AM

Answers

  • Quote From the Azure Feedback Referenced above

    STARTED · ADMINMicrosoft SQL Server (Product Manager, Microsoft Azure) responded  · datetime="2019-05-24"   

    The issue (in .NET) has been investigated and understood.

    The recommended workaround, in the interim, is:
    1) Close all instances of SSMS
    2) Edit ssms.exe.config 
    3) Remove the line that has the following text (should be line 38):
    NgenBind_OptimizeNonGac enabled=“1”

    That’s the same change that will be in the next release of SSMS 18.x

    THIS IS THE DEFINITIVE SOLUTION FROM MICROSOFT, AND IS THE TRUE ANSWER.


    • Marked as answer by SAinCA Tuesday, May 28, 2019 10:13 PM
    • Edited by SAinCA Tuesday, May 28, 2019 10:13 PM
    Tuesday, May 28, 2019 10:12 PM

All replies

  • Hi SAinCA,
    Could you please try to uninstall and reinstall SSMS 18.0? You can uninstall it from Control Panel>Programs>Programs and Feature. 
    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Proposed as answer by Av111 Thursday, April 25, 2019 3:20 PM
    Thursday, April 25, 2019 6:28 AM
  • Can you check Windows application event log to see if there are errors/warnings that provide more information about why SSMS is failing to launch?

    HTH,


    Phil Streiff, MCDBA, MCITP, MCSA

    Thursday, April 25, 2019 3:03 PM
  • check and reinstall ssms and if it is not working you can use azure studio as alternative

    https://docs.microsoft.com/en-us/sql/azure-data-studio/what-is?view=sql-server-2017

     

    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Thursday, April 25, 2019 3:22 PM
  • Sorry - ADS is so far functionally behind re third-party add-on's I won't even consider it as any kind of option...  But thanks for posting the same essential info as Cathy.
    • Edited by SAinCA Thursday, April 25, 2019 11:52 PM
    Thursday, April 25, 2019 4:54 PM
  • Hi Phil,

    I clicked all five of the Windows Logs in Event Viewer.  I just cleared the entire Log as we're in setup mode, then "started" SSMS 2018.  A refresh of the App.Log folder shows nothing at all.  Cleared all five logs.  Started "it".  Nothing at all anywhere.

    Stumped.

    Per Cathy - uninstall #1 coming.  I will use the default location this time around.

    Thanks for posting.

    Thursday, April 25, 2019 5:00 PM
  • About to do that, Cathy.  Seems like the blunt instrument has to be used, as, per my reply to Phil's post, Event Viewer provides nothing at all.
    Thursday, April 25, 2019 5:01 PM
  • BUG: Use alternate location does not work - default location works just fine - FOR JUST ME!

    Colleague, also a Local Admin (explicitly added to Local Admin Group on the server), actually a Network Admin, gets the same flash-to-nothing as I originally endured.  So, it is STILL a BUG, sadly...  Mine is working fine..

    Please treat this an UNRESOLVED BUG.

    I shall install 17.9.1 so he has a working SSMS.


    • Marked as answer by SAinCA Thursday, April 25, 2019 5:10 PM
    • Edited by SAinCA Thursday, April 25, 2019 11:52 PM
    • Unmarked as answer by SAinCA Thursday, April 25, 2019 11:52 PM
    Thursday, April 25, 2019 5:10 PM
  • Hi SAinCA,

    On my environment, I installed the SSMS 18.0 using alternate location, it works well. As you mentioned, you can installed SSMS 17.9.1.
      
    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, April 26, 2019 9:38 AM
  • I have that same problem on Windows Server 2016.

    Funny thing is that on 5 server works fine in default installation and on 3 machine not working, only show splash-screen and nothing.

    This 3 machine where SSMS 18GA not working are SQL Server.

    No error, no log nothing :/ 17.9.1 working fine.


    Friday, April 26, 2019 11:42 AM
  • Very glad to see that the BUG is not limited to my 6-instance SQL Server.

    The answer won't be "works on my box", and it cannot be "use 17.9.1" because it won't properly "see" SQL 2019 artifacts.

    How can this be escalated to BUG STATUS in Microsoft, given it is a free tool, with no support built in?

    How can I, or Jan even, provide additional information that will resolve this "SSMS 2018 is useless for multiple users when installed on a SQL Server box" issue?  (And it has absolutely nothing to do with using a non-default install folder, just to be completely clear.)

    Please advise.


    • Edited by SAinCA Friday, April 26, 2019 5:40 PM
    Friday, April 26, 2019 5:25 PM
  • Hi SAinCA,
    You can submit your issue to the Microsoft feedback at this link https://feedback.azure.com/forums/908035-sql-server. 
    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, April 29, 2019 9:48 AM
  • Try this, it solved my problem both on Windows 10 1903 and on Windows Server 2016 with .NET Framework 4.8 and SQL Server 2019 CTP2.5:

    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies>copy ..\PrivateAssemblies\Interop\Microsoft.VisualStudio.Shell.Interop.8.0.dll . 
    Overwrite .\Microsoft.VisualStudio.Shell.Interop.8.0.dll? (Yes/No/All): y 
    1 file(s) copied. 
    and BOOM it loads nicely.

    The version of the file in PrivateAssemblies\Interop is 15.0.0.0, the version of the file in PublicAssemblies is 8.0.0.0.

    Veeery ugly.


    • Proposed as answer by itsystems Monday, April 29, 2019 8:02 PM
    • Edited by itsystems Monday, April 29, 2019 8:04 PM
    • Unproposed as answer by SAinCA Monday, April 29, 2019 8:11 PM
    Monday, April 29, 2019 8:01 PM
  • I daren't try that!  .Net 4.7.2 for one, not SQL 2019 for two, and "we don't have the expertise to verify this, nor a box we can try it on, just yet" for three.

    But very much appreciate the information for when a box like that is spun up and we still have the problem.

    So, as your suggestion is for 4.8 w/ SQL 2019, I've Unproposed the post as the solution.

    Monday, April 29, 2019 8:15 PM
  • It fixed the problem just the same on a local Windows 10 1903 with no SQL installation whatsoever.

    The problem is that "Microsoft.VisualStudio.Shell.Interop.8.0.dll" is not the same version in the Path "IDE\PrivateAssemblies\Interop" and in the Path "IDE\PublicAssemblies". SSMS 18 is looking for version 15.0.0.0 of this DLL and by overwriting the old version in the Path "IDE\PublicAssemblies" we make sure there is no more version mismatch.

    You can find the error entry concerning the failure to load this DLL in <userProfile>\AppData\Roaming\Microsoft\AppEnv\15.0\ActivityLog.xml.


    • Edited by itsystems Monday, April 29, 2019 8:24 PM
    Monday, April 29, 2019 8:23 PM
  • So, by co-installing SSMS 17.9.1, one would have inadvertently "cured" the problem?
    Monday, April 29, 2019 8:49 PM
  • I’m seeing this same Splash screen then nothing problem. In my case installed SSMS 18 on a Win 10 Enterprise 1809 that has never had SSMS on it. It works fine for a while, then I go to use it again and the Splash screen/nothing occurs. I uninstalled, rebooted and reinstalled. Works again for a while, then the same problem.

    I checked those PublicAssemblies / PrivateAssemblies folders. In my case both have Microsoft.VisualStudio.Shell.Interop.8.0.dll version 8.0.50727.938


    Jim Brown

    Tuesday, April 30, 2019 10:37 PM
  • My 8.0.0.0 "version" that the installer errors-out on, is, like Jim's, 8.0.50727.938

    "System.IO.FileLoadException: Could not load file or assembly 'Microsoft.VisualStudio.Shell.Interop.8.0, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)"

    Does this point to an installer gaff, perhaps?

    Tuesday, April 30, 2019 11:05 PM
  • Try to https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-2017

    Microsoft SQL Server Management Studio 14.0.17289.0
    Microsoft Analysis Services Client Tools 14.0.1016.283
    Microsoft Data Access Components (MDAC) 10.0.10586.0
    Microsoft MSXML 3.0 6.0 
    Microsoft Internet Explorer 9.11.10586.0
    Microsoft .NET Framework 4.0.30319.42000
    Operating System 6.3.10586


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Wednesday, May 1, 2019 4:56 AM
  • Already did that, in order that my colleague could work on the box itself.  He used 17.9.1 and was fine, because we don't have any 2019 Preview instance there.  The next time he logged in, he decided to try 2018 - to his surprise, and mine, it worked.

    Now all we need is for Microsoft to fix their dll problems, and 2018 is ready for multi-user prime-time.

    Wednesday, May 1, 2019 6:07 PM
  • Got the same problem, just a splash screen afte start.

    The Microsoft.VisualStudio.Shell.Interop.8.0.dll file seems to be in two places:

    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies\
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop\

    Both are the same size, both show the same version in Properties->Details (8.0.50727.938). But when i opened them up in ILSpy the one in \PrivateAssemblies\Interop\ shows AssemblyVersion 15.0.0.0 and the one in \PublicAssemblies\ shows AssemblyVersion 8.0.0.0.

    What fixed it for me was just copying the file with the right version from \PrivateAssemblies\Interop\ to \PrivateAssemblies\ (not overwriting anything). Seeing that it's the only file in \PrivateAssemblies\Interop\ maybe the extra dir is an oversight of some sort.

    • Proposed as answer by Chris Frary Wednesday, May 8, 2019 6:32 PM
    • Unproposed as answer by SAinCA Wednesday, May 8, 2019 6:49 PM
    Thursday, May 2, 2019 9:54 AM
  • So, as I reported earlier in this thread, for me I’ll install SSMS 18, it will work for a while, then it goes into Splash screen, beep, nothing mode again.

    I was at that point again and did the dll copy as described by Jaroslav Kubík, and it’s working again. We’ll see! This is one of the oddest problems I’ve ever come across.


    Jim Brown

    Thursday, May 2, 2019 11:41 AM
  • Found a better way without copying any DLLs.

    Step 1:

    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\CommonExtensions\Platform\Microsoft.VisualStudio.MinShell.Interop.pkgdef

    Rename and make sure this file does not have the ".pkgdef" extension anymore. Or remove the file.

    Step 2:

    Remove the following Registry Key (which is created at SSMS 18 Startup using the ".pkgdef" file mentioned above):

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\SQL Server Management Studio\18.0_IsoShell_Config\RuntimeConfiguration\dependentAssembly\bindingRedirection\{8BC7AF31-B6DA-4B97-8B36-F0500DECB147}

    From now on SSMS 18 will start.


    • Edited by itsystems Thursday, May 2, 2019 5:37 PM
    • Proposed as answer by pituachMVP Monday, May 27, 2019 2:31 AM
    • Unproposed as answer by SAinCA Monday, May 27, 2019 4:05 PM
    Thursday, May 2, 2019 5:36 PM
  • before doing registry changes,take backup of registry.

    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Friday, May 3, 2019 6:26 AM
  • That's a decent workaround.

    I'm trying to chase down this issue. If folks that run into this issue could kindly update https://feedback.azure.com/forums/908035/suggestions/37502512 with the following information:

    1) The OS you are using?

    2) What OS updates (and specifically, .NET Framework 4.7.2) are installed?

    3) Does the issue go away if, before applying the workaround, you install all the latest critical updates?

    Much appreciated.

    -Matteo


    -Matteo

    Saturday, May 4, 2019 8:21 AM
  • Many thanks for your input Jaroslav

    You solution also worked for me!


    Wednesday, May 8, 2019 10:12 AM
  • As the O.P., a workaround this may be, but MS is working on a FIX for this.  When that is delivered, see the uservoice link already posted on April 29, I'll update this thread with THAT as the "Answer".

    Workarounds ARE appreciated, but they aren't, in this case, the real answer.

    Wednesday, May 8, 2019 6:52 PM
  • This worked, thank you so much!
    Tuesday, May 14, 2019 10:09 PM
  • Quote From the Azure Feedback Referenced above

    STARTED · ADMINMicrosoft SQL Server (Product Manager, Microsoft Azure) responded  · datetime="2019-05-24"   

    The issue (in .NET) has been investigated and understood.

    The recommended workaround, in the interim, is:
    1) Close all instances of SSMS
    2) Edit ssms.exe.config 
    3) Remove the line that has the following text (should be line 38):
    NgenBind_OptimizeNonGac enabled=“1”

    That’s the same change that will be in the next release of SSMS 18.x

    THIS IS THE DEFINITIVE SOLUTION FROM MICROSOFT, AND IS THE TRUE ANSWER.


    • Marked as answer by SAinCA Tuesday, May 28, 2019 10:13 PM
    • Edited by SAinCA Tuesday, May 28, 2019 10:13 PM
    Tuesday, May 28, 2019 10:12 PM
  • This answer worked for me. Thank you!
    • Proposed as answer by Raja Udyog Pvt Ltd Saturday, June 1, 2019 9:27 AM
    • Unproposed as answer by SAinCA Saturday, June 1, 2019 12:00 PM
    Thursday, May 30, 2019 1:57 PM
  • I have already Choose Following 

    1) Close all instances of SSMS
    2) Edit ssms.exe.config 
    3) Remove the line that has the following text (should be line 38):
    NgenBind_OptimizeNonGac enabled=“1”

    That’s the same change that has been in the next release of SSMS 18.x

    But still not Run so please suggest to me as soon as possible.


    Saturday, June 1, 2019 8:06 AM
  • Can I suggest you go to the Uservoice link and post to Matteo for further assistance. He is very responsive and you will get Microsoft’s attention via that forum.
    Saturday, June 1, 2019 12:02 PM
  • After Uninstall and than again install. Its working Now So Thank you so Much.
    Saturday, June 1, 2019 1:20 PM
  • Worked well for me, thanks. :-) 
    • Edited by Egil-007 Thursday, June 6, 2019 8:54 PM
    Thursday, June 6, 2019 8:52 PM
  • Just tried this method on mine and a coworkers computer and it works.  Just for anyone that is wondering, the ssms.exe.config file can be located in C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE
    Thursday, June 13, 2019 7:15 PM
  • Good day,

    You can get all the information here:
    http://ariely.info/Blog/tabid/83/EntryId/229/issues-with-opening-SQL-Server-Management-studio-version-18-summarize-the-issue-and-providing-the-workaround.aspx

    But notice the update in the post from several days ago! 
    Update: The fix for this issue was included in SSMS 18.1.


    signature   Ronen Ariely
     [Personal Site]    [Blog]    [Facebook]    [Linkedin]


    • Edited by pituachMVP Friday, June 14, 2019 8:46 AM
    Friday, June 14, 2019 8:46 AM