network related or instance specific error occurred while establishing a connection to sql server


  • Hi all,


    I am getting  a SQL error - A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified).

    Problem is when a user tries to connect with remote SQL Server through VPN from Domain, it throws this error, and when the same machine tries to connect with Remote SQL Server through VPN as a standlone machine, it is getting connected. I checked all the settings but ....... There is no any policies deployed in Active Directory.

    Any suggetion?



    Rajneesh Kumar MCITP - SA, MCSE, CNA
    Friday, December 16, 2011 10:30 AM

All replies

  • what port is service is running - can you telnet onto the port from remote servers?


    also check this for resolving network related issues
    • Edited by RamJaddu Friday, December 16, 2011 10:51 AM
    • Proposed as answer by PenDraKon Thursday, December 11, 2014 12:47 PM
    • Unproposed as answer by PenDraKon Thursday, December 11, 2014 12:47 PM
    Friday, December 16, 2011 10:50 AM
  • it is running on 1433 & 1434, when I run portquery to remote server it says said port is filtered from domain-joined-machine. I can ping that server and it is also resolving the server name. when I try to run GPResult tool for the problematic machine, it says Access is denied.


    Rajneesh Kumar MCITP - SA, MCSE, CNA
    Friday, December 16, 2011 12:34 PM
  • check these

    1) Make sure your server name is correct, e.g., no typo on the name.
    2) Make sure your instance name is correct and there is actually such an instance on your target machine. [Update: Some application converts \\ to \. If you are not sure about your application, please try both Server\Instance and Server\\Instance in your connection string]
    3) Make sure the server machine is reachable, e.g, DNS can be resolve correctly, you are able to ping the server (not always true).
    4) Make sure SQL Browser service is running on the server.
    5) If firewall is enabled on the server, you need to put sqlbrowser.exe and/or UDP port 1434 into exception.
    Friday, December 16, 2011 12:52 PM
  • I already gone through all these steps before posting this problem. It was working few days back, it is not connecting with the remote server from last few days. In these few days I gone through all the necessary steps. Any new possiblity?


    Rajneesh Kumar MCITP - SA, MCSE, CNA
    Friday, December 16, 2011 1:02 PM
  • Check any errors in Error log / windows event log more specific to the problem - you might involve network team for me it looks  network issue
    Friday, December 16, 2011 1:05 PM
  • Hi Pinto,

    Check the sql server tcp port ( default 1433) and reconfigure you firewall to allow this TCP port and UDP 1434 (it's for sql browser service) via vpn subnet. this issue looks network problem.



    Kadir Evciler

    DBA at Eurobank Tekfen

    Friday, December 16, 2011 2:17 PM
  • Sorry I didn't see this post before answer your question. Don't forget 1434 is UDP port, I think you should review firewall rules
    Friday, December 16, 2011 2:21 PM
  • I tried it with a newly created testdomain, when I try to connect with remote server, it gets connected. does their any policy which can stopping this connection with prod domain.



    Rajneesh Kumar MCITP - SA, MCSE, CNA
    Wednesday, December 21, 2011 10:50 AM
  • Below are the list of things to be check

    1. SQL Server is running or not
    2. Check TCP/IP Port is open or not
    3. check for firewall settings port is open or not
    4. SQL Server security settings have windows/sql authentication
    5. check for sql server configuration settings allow remote connections

    Ramesh Babu Vavilla MCTS,MSBI

    Monday, December 03, 2012 9:18 AM
  • Can you please share output of telnet servername portnumber?

    • Edited by anuragsh Tuesday, December 04, 2012 9:25 AM
    Monday, December 03, 2012 9:45 AM
  • Hello,

    I found the way to fix this issue was to start some of my link services that had for some strange reason stopped.

    Kind Regards, PenDraKon

    Thursday, December 11, 2014 12:48 PM