none
Can not open SQL Management Studio

    Question

  • All of a sudden out of the blue today, Sql Server Management Studio refuses to load and open.

     

    I'm running Windows XP x64.

    Sql Server Dev. Edition x64. (Release version.. There were never Beta versions on the machine)

     

    When I open the program this dialog opens:

    ---------------------------
    Microsoft SQL Server Management Studio
    ---------------------------
    Package 'Microsoft SQL Management Studio Package' failed to load.
    ---------------------------
    OK  
    ---------------------------

    (It appears twice and then the UI fails to open)

    Also, in Visual Studio 2005, when I try to make a database connection in Server Explorer, I get this error

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Could not load file or assembly 'Microsoft.VisualStudio.Data, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Failed to grant minimum permission requests. (Exception from HRESULT: 0x80131417)
    ---------------------------
    OK  
    ---------------------------

    These problems have not been encountered before and I have been using my current setup for months. Cannot thikn of anything that has changed today to cause this.

     

    Ideas?

     

     

    Thursday, April 13, 2006 11:13 PM

Answers

  • I also encountered the error Package 'Microsoft SQL Server Management Studio' failed to load (even with my shortcut correctly pointing to "C:\program files....") but have discovered that it was caused by .NET permission settings. I had changed the My_Computer_Zone code group permission set from "FullTrust" to "Everything" (for the local Machine policy).  Changing it back to FullTrust fixed it and Management Studio fired up ok.

    Tom.

    • Proposed as answer by PaulM_ATL Tuesday, January 26, 2010 2:20 PM
    • Marked as answer by Kalman TothEditor Tuesday, December 7, 2010 4:28 AM
    Sunday, February 25, 2007 5:06 PM
  • The most likely cause of this is if a file has been deleted or corrupted.  Does repairing the SQL Server management tools fix the problem? 

    Repairing SQL Server is a command-line operation. You can repair by inserting the installation media into the disk drive and typing the following:

    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    You can find more information on installing SQL Server from the command line here: http://msdn2.microsoft.com/en-us/library/ms144259.aspx

     

    Hope this helps,
    Steve

    Wednesday, April 19, 2006 7:50 PM
  • Ok.  I just figured out both the errors in SQL Management Studio and Visual Studio.  It was really stupid.  Somehow, the shortcut icons on the desktop were altered.  Instead of having the path to the executables of each application be "c:\program files\....", the path read "\\computername\c$\program files\...".  Therefore, the two applications, based on .NET themselves were running as intranet zoned applications.  Therefore, they were unable to make data connections because of the default setup for the intranet zone CAS.  I changed the paths back to c:\ and it worked fine.

    I have no idea how they got like this because I just dragged them out of the start menu and dropped them on the desktop like I've done for every other application.  I checked my other shortcuts and they are all OK.  Got me...
    Monday, May 1, 2006 12:44 PM
  • I reinstalled .Net 2.0 and that fixed it for me.
    Thursday, May 25, 2006 1:07 PM
  • Somehow this has happened to me again.  Following the repair instructions

    start /wait d:\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    fixed the problem.

    I didn't notice the other post about checking out the shortcuts until after I did this, so I dont know if that was the problem.

    Tuesday, June 27, 2006 10:26 PM
  • It seems you have changed the permission set of My_Computer_Zone to Everything instead of Full Trust , if you return it back to Full Trust it will work just fine.
    • Proposed as answer by AhmadYaseen Wednesday, March 10, 2010 9:49 AM
    • Marked as answer by Kalman TothEditor Tuesday, December 7, 2010 4:29 AM
    Wednesday, March 10, 2010 9:47 AM
  • Some Feature of SQL Server 2005 have based on .Net FrameWork 2.0 and SQL Server 2008 base on .Net Framework 3.5.

    So for any related issue, we can reinstall those programs to fix our issue.

    Thanks a lot.

     

    Friday, December 3, 2010 3:48 AM

All replies

  • Did you try the repair option from the Add and Remove PRograms?
    Monday, April 17, 2006 8:30 PM
  • I ended up un-installing every .Net Fx 2.0 related and installed all over again.

     

    (SQL Server 2005, Visual Studio 2005 etc)

     

    That was a waste of a day.. But it works again.

    Tuesday, April 18, 2006 1:17 PM
  • I'm experiencing the exact same problem.  Uninstalling and re-installing VS .NET fixed the Visual Studio error, but the SQL Management Studio problem persists.  I tried uninstalling and reinstalling the management componenets, but that did not work.  Even so, re-installation is a workaround, and one I'm not willing to do everytime a problem creeps up.  Does anyone have any permenant solutions?

    Thank you.
    Wednesday, April 19, 2006 4:54 PM
  • The most likely cause of this is if a file has been deleted or corrupted.  Does repairing the SQL Server management tools fix the problem? 

    Repairing SQL Server is a command-line operation. You can repair by inserting the installation media into the disk drive and typing the following:

    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    You can find more information on installing SQL Server from the command line here: http://msdn2.microsoft.com/en-us/library/ms144259.aspx

     

    Hope this helps,
    Steve

    Wednesday, April 19, 2006 7:50 PM
  • I just installed SP1 for SQL Server 2005.  However, this problem persists. 
    Thursday, April 27, 2006 6:56 PM
  • Ok.  I just figured out both the errors in SQL Management Studio and Visual Studio.  It was really stupid.  Somehow, the shortcut icons on the desktop were altered.  Instead of having the path to the executables of each application be "c:\program files\....", the path read "\\computername\c$\program files\...".  Therefore, the two applications, based on .NET themselves were running as intranet zoned applications.  Therefore, they were unable to make data connections because of the default setup for the intranet zone CAS.  I changed the paths back to c:\ and it worked fine.

    I have no idea how they got like this because I just dragged them out of the start menu and dropped them on the desktop like I've done for every other application.  I checked my other shortcuts and they are all OK.  Got me...
    Monday, May 1, 2006 12:44 PM
  • I reinstalled .Net 2.0 and that fixed it for me.
    Thursday, May 25, 2006 1:07 PM
  • Somehow this has happened to me again.  Following the repair instructions

    start /wait d:\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    fixed the problem.

    I didn't notice the other post about checking out the shortcuts until after I did this, so I dont know if that was the problem.

    Tuesday, June 27, 2006 10:26 PM
  • I want to comment on Jetgunner's post.

    I have found that my shortcuts have changed just as his has.. instead of C:\...  they were \\machine\c\....

     

    I have no idea why they are like that either.

     

    Wednesday, June 28, 2006 4:04 PM
  • I also encountered the error Package 'Microsoft SQL Server Management Studio' failed to load (even with my shortcut correctly pointing to "C:\program files....") but have discovered that it was caused by .NET permission settings. I had changed the My_Computer_Zone code group permission set from "FullTrust" to "Everything" (for the local Machine policy).  Changing it back to FullTrust fixed it and Management Studio fired up ok.

    Tom.

    • Proposed as answer by PaulM_ATL Tuesday, January 26, 2010 2:20 PM
    • Marked as answer by Kalman TothEditor Tuesday, December 7, 2010 4:28 AM
    Sunday, February 25, 2007 5:06 PM
  • Running that worked for me.

    Thanks so much...

    start /wait E:\apps\SQL2005\Tools\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    Thursday, March 8, 2007 10:49 PM
  • Hey Jetgunner,

     

    Not sure if you're still going to see that there has been anything posted to this thread, as it was a year ago.  But I wanted to ask if you had been using Virtual PC on the same machine you were having this issue.


    I have several virtual PC installations with SQL server 2005, and that's the reason I think the shortcut gets the "c$" accidently carried over into it.  It has to be either something to do with Virtual PC or something to do with Remote Desktop.  Those are the two things I use quite a bit and might have effected my shortcut to SQL Management Studio.


    Can anyone else confirm or deny this?

     

    Thanks,

    Doug

    Thursday, May 10, 2007 3:09 PM
  • Package 'Microsoft SQL Management Studio Package' failed to load.

    -------------------------------------------------------------------------------------------------

    I tried to reinstall .NET 2.0 framework and IT WORKED FOR ME***********

     

    Scenario-->In a virtual machine (Vmware) copied from another one,sql server management studio was throwing the error [Package 'Microsoft SQL Management Studio Package' failed to load.]

    Tuesday, June 26, 2007 4:45 PM
  • ***WORKED FOR ME TOO***

    Thanks,

    Deepesh

    Tuesday, June 26, 2007 4:48 PM
  • Running the Setup/Repair worked for me also, thanks for the info.

     

    Thursday, October 4, 2007 1:41 PM
  • Thanks, this was the cause of my error and you just saved me a reinstall.
    Tuesday, December 11, 2007 2:45 PM
  • Hey Jetgunner,

     

     

    It got resolved for me after reinstalling the .Net Framework 2.0 with 1.0 it wasn't working and as 2.0 was a prereq for sql management studio for sql 2005 server it worked.

     

    Thanks

    Maddy

     

    Friday, February 15, 2008 9:41 AM
  •  

    Had the same problem and it was the shortcut who had changed. Changing it back to C:\...... worked. Thanks a lot!
    Thursday, March 20, 2008 4:11 PM
  •  

    This works 4 me!!! Thank u!
    Saturday, April 19, 2008 8:14 AM
  • It work for me too. thank

     

    Wednesday, May 7, 2008 9:55 AM
  • I don't have a "repair" option available :-(

    Tuesday, May 13, 2008 1:02 PM
  • Go to Add/remove programe of window to use repair option

    Wednesday, May 14, 2008 1:28 AM
  • One thing which i tried and it works is that reinstall .Net Framework 2.0. It works...

    Wednesday, May 14, 2008 1:21 PM
  • One thing which i tried and it works is that reinstall .Net Framework 2.0.

    Wednesday, May 14, 2008 1:21 PM
  • V weird.  My Start Menu link somehow changed to \\pcname.  Changed back to c:\ and all is now well in the world.

     

    Thursday, June 5, 2008 12:13 PM
  • Before re-installing software etc, you might just perform the following simple check.

    Right click on the short-cut you use to launch SQL Server Management Studio, then ensure that 'Start in' is set to the same PATH as 'Target' 

    e.g. if  Target is set to  

    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\SqlWb.exe"

    then 'Start in' should be set to the same path (minus the filename) i.e.

    "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\"

     

    (On a PC which I was given at work, 'Start in' was blank and this gave the same error as reported in the above posts.)

    Sunday, August 31, 2008 11:07 PM
  • Hi,

    thanks for the very good reply it helped solve the problem, so just change the shortcut file path and there you go the problem is resolved.

     

    All the Best

     

    Nauman

     

    Wednesday, November 26, 2008 3:49 PM
  • Reinstalling .Net Framework 2.0 solved the problem. Thanks.
    Tuesday, December 9, 2008 8:13 AM
  • Solution might be quite simple.

    Increase the permissions for the appropriate zone through the .Net Framework 2.0 configuration wizard.

    Thursday, December 11, 2008 4:59 PM
  • Jetgunner said:

    Ok.  I just figured out both the errors in SQL Management Studio and Visual Studio.  It was really stupid.  Somehow, the shortcut icons on the desktop were altered.  Instead of having the path to the executables of each application be "c:\program files\....", the path read "\\computername\c$\program files\...".  Therefore, the two applications, based on .NET themselves were running as intranet zoned applications.  Therefore, they were unable to make data connections because of the default setup for the intranet zone CAS.  I changed the paths back to c:\ and it worked fine.

    I have no idea how they got like this because I just dragged them out of the start menu and dropped them on the desktop like I've done for every other application.  I checked my other shortcuts and they are all OK.  Got me...

    Thanks for posting this!  I was remoting around yesterday trying to find a database and tried to open sql management studio on a server that didn't have it  installed.  This somehow changed my desktop shortcut to the path you posted.  I recreated the shortcut on the sql server and it worked fine.
    Tuesday, February 3, 2009 2:43 PM
  • Thank you, your solution...

    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    Helped me.

    Thanks again.
    Monday, December 21, 2009 2:34 PM
  • I am using MS SQLServer 2008 and I got the same error (Package 'Microsoft SQL Server Management Studio' failed to load) since last couple of days. 

    I tried with this solution 
    C:\Users\romah>start /wait f:\setup.exe /qb REINSTALL=SQL_Tools100 REINSTALLMODE=OMUS

    but it says

    TITLE: SQL Server Setup failure.
    ------------------------------

    SQL Server Setup has encountered the following error:

    The syntax of argument "/QB" is incorrect. Either the delimiter '=' is missing or there is one or more space characters before the delimiter '='. Please use /? to check usage.

    Error code 0x84B40001.

    ------------------------------


    I also tried with this solution but again i got the same error (Package 'Microsoft SQL Server Management Studio' failed to load)

    Target:
    "C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Ssms.exe"

    Start in:
    "C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\"

    Thursday, January 28, 2010 2:40 PM
  • It seems you have changed the permission set of My_Computer_Zone to Everything instead of Full Trust , if you return it back to Full Trust it will work just fine.
    • Proposed as answer by AhmadYaseen Wednesday, March 10, 2010 9:49 AM
    • Marked as answer by Kalman TothEditor Tuesday, December 7, 2010 4:29 AM
    Wednesday, March 10, 2010 9:47 AM
  • Thank you, Prachi Tyagi - my issue, Microsoft SQL Server Management Studio - Package 'Microsoft SQL Management Studio Package' failed to load. when opening SQL Management Studio, on a virtual windows 2003 server was solved by using the Repair option in the Add/Remove programs on Net Framework v3.5 SP1. 
    Friday, March 26, 2010 4:58 PM
  • Confirmed as well, reinstalling my version of .net fixed this problem on a windows 2003 server.  I only had .net 2.0 installed, but still, reinstalling it worked great.

     

    Thanks!

    Wednesday, April 7, 2010 9:28 PM
  • Thank Guys
    start /wait <CD or DVD Drive>\setup.exe /qb REINSTALL=SQL_Tools90 REINSTALLMODE=OMUS

    this option worked for me .
    Have nice and levely evening
    • Proposed as answer by ChunRCP Tuesday, June 29, 2010 10:23 PM
    Thursday, May 27, 2010 7:18 PM
  • Windows 7 Ultimate x64 and SQL 2008 R2 gave me the same error Package 'Microsoft SQL Management Studio Package' failed to load.

    I downloaded .Net Framework 4 again and selected repair. Problem solved.

    Tuesday, June 29, 2010 10:25 PM
  • Windows 7 Ultimate x64 & SQL 2008 R2 (Developer):

    Can't launch SSMS despite following some ideas such as: re-installing it, and re-installing .Net Framework 4.

    Note that SQL Server is running (I'm able to connect with Toad, http://toadforsqlserver.com/).

    Any other ideas? Honestly, I'm quite disappointed (just got a new copy I purchased)... :-(

     

     

    Friday, October 22, 2010 4:04 AM
  • If you are using domain computer then try with giving administrator rights to user. It works at my place.

    Regards,

    Pradeep Pawar

    Tuesday, November 23, 2010 7:32 AM
  • Some Feature of SQL Server 2005 have based on .Net FrameWork 2.0 and SQL Server 2008 base on .Net Framework 3.5.

    So for any related issue, we can reinstall those programs to fix our issue.

    Thanks a lot.

     

    Friday, December 3, 2010 3:48 AM
  • I had the same problem and never found the solution unless I found this article :

    http://www.intowindows.com/how-to-fix-windows-7-search-problems/

    I had some troubles with the search in start menu feature of Win 7, and this article solved this problem AND the problem mentionned in this thread.

     

    hth


    Paying back the community for its help by writing articles :
    Have a Nice Day.Net Blog
    Wednesday, January 26, 2011 9:30 PM
  •             Hello everyone,

     

     

    I'm running Windows7(x86) and I installed MS SQL Server 2008  but trying to open the SS Management Studio I got the error : 

    Package 'Microsoft SQL Management Studio Package' failed to load 

     

    For some weeks ago I could open the server and even some new Reporting and Analyses Projects I create. the BIDS is working properly but I can connect to the server.
    Though I repaired the installed SQL Server 2008 from the control panel, it didn't change anything.

    I installed .Net framework 4 Client Profile and Extended, but I'm not quite sure If this is the rigth version.

    May you have any idea how I can fix it please help me.

    Thank you in advance and best regards,

    Lynn


    Yvanna
    Monday, August 8, 2011 1:01 PM
  • It's me again !! I did a repair from the CD and I got a failure on the features :

     - Management Tools- Complete

     - Management Tools- Basic


    It's driving me mad. I don't know how to go ahead.

    Best regards



    Yvanna
    Monday, August 8, 2011 1:29 PM
  • Hi everyone,

    I'm having exactly the same issue as Lynn. Have tried reinstalling/repair .Net Framework 4.0, SQL server and SSMS several times. Still unable to get over that error, any ideas would be greatly appreciated.

    Note: Running Windows 7 Professional 64bits and MS SQL Server 2008 R2

    Thanks in advance.

    SN


    Tuesday, May 29, 2012 2:49 AM
  • While reading your reply it gave me an idea.  I went in to remove my profile on that computer then relogin.  Once I did that, I tried to launch SQL Management Studio again.  It went thru that preparing SQL Server Management Studio for the 1st time message and I waited until it completed.  After that, I was able to launch SQL Management Studio again.
    Friday, October 19, 2012 10:37 PM