none
SQL Server 2008 Service Pack 2 fails to install

    Question

  • Trying to install SQL Server 2008 Service Pack 2 on a Windows Server 2008 x64 server. 
    The install fails through both windows update and manual installation.

    The error message received when trying to install via Windows Update: 
    Installation Failure: Windows failed to install the following update with error 0x80070643: Microsoft SQL Server 2008 Service Pack 2 (KB2285068).

    Manual Installation error from sqlsetup.log file:

    8/09/2011 16:35:30.401 Checking to see if policy file exists
    08/09/2011 16:35:30.410 .Net security policy file does exist
    08/09/2011 16:35:30.442 Attempting to load .Net security policy file
    08/09/2011 16:35:30.480 Error: Cannot load .Net security policy file
    08/09/2011 16:35:30.490 Error: InitializeSqlSetupCodeGroupCore(64bit) failed
    08/09/2011 16:35:30.493 Error: InitializeSqlSetupCodeGroup failed: 0x80004005
    08/09/2011 16:35:30.496 Setup closed with exit code: 0x80004005
    08/09/2011 16:35:30.502 ======================================================================

     

    We have tried the following to get this to install without success:

    removed .net framework version 4
    tried the install with .Net Framework v 3.5 SP 1
    reinstalled the .Net Framework version 4

     

    What else can we do in order to install SQL Server 2008 Service Pack 2 successfully?

    Thanks

     

    Tuesday, August 9, 2011 8:45 PM

Answers

  • Can you reset the .net permission on the 2008 server by running : C:\Windows\Microsoft.NET\Framework\v2.0.50727\caspol.exe -machine -reset

    I have seen cases where Caspol.exe cmd enabled security permission for a .Net application when we run from a UNC location.

    • Marked as answer by costanza Wednesday, August 10, 2011 3:15 PM
    Wednesday, August 10, 2011 12:49 AM

All replies

  • Can you reset the .net permission on the 2008 server by running : C:\Windows\Microsoft.NET\Framework\v2.0.50727\caspol.exe -machine -reset

    I have seen cases where Caspol.exe cmd enabled security permission for a .Net application when we run from a UNC location.

    • Marked as answer by costanza Wednesday, August 10, 2011 3:15 PM
    Wednesday, August 10, 2011 12:49 AM
  • I change the path to c:\Windows\Microsoft.NET\Framework64\ v2.0.50727\caspol.exe -machine -reset

    and it worked.  SQL Server 2008 SP2 has been installed successfully!

     

    Thank you for your help!

    Wednesday, August 10, 2011 3:15 PM
  • I had the exact same Problem. It took me two days to find this solution and I probably tried twenty other approaches from forums and MS-help before.

    Now this entry helped. Thank you for that.

    It is very frustrationg that install.exe just exits without any message whenever it encouonters this situation. This is just not the way Software should work. There should be an error message or a warning.

    Sunday, August 12, 2012 9:20 AM