none
msmdpump.dll Errors Occured in Http Access AS 2005 RRS feed

  • Question

  • I tried to use the http to access the AS2005 with SP2. It worked after I configured them following the guide http://www.microsoft.com/technet/prodtechnol/sql/2005/httpasws.mspx. But after sometime (a couple of hours late), it failed and got the following information in the system application event.

    The description for Event ID ( 10 ) in Source ( MSOLAP ISAPI Extension:
    \\?\c:\inetpub\wwwroot\olap\msmdpump.dll ) cannot be found. The local
    computer may not have the necessary registry information or message DLL
    files to display messages from a remote computer. You may be able to use the
    /AUXSOURCE= flag to retrieve this description; see Help and Support for
    details. The following information is part of the event: 

    Based on the above informatin, I totally have no idea what is wrong. Any comments would be greatly appreciated.
    Wednesday, October 8, 2008 11:23 AM

All replies

  • r u using windows 2003 ?If you are using windows xp then here is the link

     

    http://www.microsoft.com/technet/prodtechnol/sql/2005/httpssas.mspx

     

    Thursday, October 9, 2008 1:04 PM
  • I am using Win2003 with SP2 + SQL 2K5 with SP2. I verified MSXML core service 6.0 and OLE DB9.0 is installed and registered.

    Following http://www.microsoft.com/technet/prodtechnol/sql/bestpractice/cisql2005ascs.mspx, I double checked all setting and still got the some the error information the above information. And sometimes, the service is down.

    Is there any tricky about the setting?  Thx.
    Friday, October 10, 2008 3:45 AM
  • Hi,

    I'm getting the same error. Has anyone resolved this yet?

    Thanks!
    Monday, November 17, 2008 12:10 PM
  • I just had the same error,

    The description for Event ID ( 25 ) in Source ( MSOLAP ISAPI Extension: \\?\C:\somefolder\MSOLAP\msmdpump.dll ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: msmdsrv.rll, 1033.

    fixed by applying the follwing steps:

    So, Make sure that you've registered the msmdpump.dll under the Application Extensions.

    1- In IIS management, go to properties of the folder containing the dll.
    2- Click Configuration (assuming that you've already created an application here)
    3- Under Mappings tab \ Application Extensions  click add,
    4- Executable : Browse, locate the msmdpump.dll
    5- Extension : Type in "dll" , Leave other options as is, (Verbs: All verbs )

    You should be good to go.
    Friday, December 12, 2008 5:05 PM
  • Maybe you need to install Microsoft SQL Server 2008 Analysis Services 10.0 OLE DB Provider

    http://www.microsoft.com/downloads/details.aspx?FamilyID=C6C3E9EF-BA29-4A43-8D69-A2BED18FE73C&displaylang=en

    But i thing it is not necessary for access over XMLA.

    I have the same problem and fixed it by disabling anonymous access in IIS. And set "Basic authentication" and domain.

    If you want to keep anonymous access to xmla you must give access rights to special user account of IIS.

    (IUSR_MACHINENAME by default) Users for acces AS setting up in SQL Managment console in "server"->Security.

    In all settings - path to folder, extention and filter - you must have same path to msmdpump.dll.

    check msmdpump.ini.

    <ConfigurationSettings>  
    <ServerName>localhost</ServerName>  
    <SessionTimeout>3600</SessionTimeout>  
    <ConnectionPoolSize>100</ConnectionPoolSize>  
    </ConfigurationSettings> 

    Wednesday, February 11, 2009 12:44 PM