none
Blank space in subreport in pdf format while hiding a rectangle in SSRS 2008R2 RRS feed

  • Question

  • Hi all,

    I am creating a report in SSRS 2008 with subreport in it. Subreport contains multiple rectangles with various information in it.

    These rectangles are to be displayed or hidden based upon parameter values passed.

    The problem is when hiding a rectangle, same amount of blank space is left on the report while rendering it in pdf format.

    This problem is not occurring in HTML view.

    My guess is that main report is calculating the size of subreport beforehand and hence leaving blank space.

    Is there any way to overcome this problem?

    Sunday, March 10, 2013 7:19 AM

Answers

  • Hi Dhirajkumar,

    I have tested it on my local environment, the solution which in that blog works either for the contents in main report or in subreport. Here are the screenshots.

    If the issue persists, please elaborate the design steps of your report. If possible, provide us some screenshots about it, so that we can make further analysis.

    Regards,


    Charlie Liao
    TechNet Community Support

    Tuesday, March 12, 2013 8:19 AM
    Moderator

All replies

  • http://sqlserverpedia.com/blog/sql-server-bloggers/dealing-with-white-space-due-to-a-hidden-textbox-in-reporting-services/

    I think it is by design , see this thread

    http://social.msdn.microsoft.com/Forums/eu/sqlreportingservices/thread/564b10ac-e1c2-405f-a89e-1a450a4c1731


    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Blog: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance

    Sunday, March 10, 2013 8:32 AM
  • I know the solution given in http://sqlserverpedia.com/blog/sql-server-bloggers/dealing-with-white-space-due-to-a-hidden-textbox-in-reporting-services/.

    But this works only for contents in main report. This doesn't work if the content is present in subreport.

    Any other options you would know of?


    Sunday, March 10, 2013 9:52 AM
  • Hi Dhirajkumar,

    I have tested it on my local environment, the solution which in that blog works either for the contents in main report or in subreport. Here are the screenshots.

    If the issue persists, please elaborate the design steps of your report. If possible, provide us some screenshots about it, so that we can make further analysis.

    Regards,


    Charlie Liao
    TechNet Community Support

    Tuesday, March 12, 2013 8:19 AM
    Moderator