PowerPivot Add-In will not load


  • I've spent countless hours troubleshooting and trying every PowerPivot fix I can find online, and haven't had any luck. The PowerPivot (PP) Add-in tool won't load. When I go into Options----> Add-Ins---> COM Add-ins--->check the PowerPivot Add-in, PP doesn't load. When I try to enable it again I get: "Not Loaded. A runtime error occurred during the loading of the COM Add-in." Hopefully someone can help.

    I was previously running Office Professional Plus 32-bit with the 32-bit PP add-in, with no issues. Then I uninstalled Office Pro 32-bit and PP 32-bit to install the 64-bit versions of both and now PP won't work. I've installed .NET 4 package (Client Profile and Extended) and Microsoft Visual Studio 2010 Tools for Office Runtime (x64) and still no luck. I've also installed all available programs with Office Professional Plus (including shared features, .NET Programmability Support, etc.).

    Excel version: 14.0.6129.5000 (64-bit)

    PowerPivot version: 11.0.3000.00

    Windows 7 (64-bit)

    Any help would be greatly appreciated!

    Friday, January 11, 2013 11:10 PM


All replies

  • Hi,

    I haven't tested the latest release. However, I had issues with the beta PowerPivot Add-In for SQL Server 2008R2 release which I think was where x64 I wasn't able to add the PowerPivot Add-in. I ended up moving back to x86 version of Office at the time due more to the to Outlook integration with QuickBooks and it worked when reinstalled.  There is a newer version 11.0.3129.0 of the PowerPivot Add-in for Excel 2010 available, this may resolve the issue as the error looks to be the com component was not being installed correctly

    The most recent version of the PowerPivot documentation is available from PowerPivot for Excel Online Help. You can access additional articles, blogs, and other community content on the PowerPivot TechNet page.

    Also, this may not help but in Excel 2013 the Add-In as part of the product and not a separate download.


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.

    Sunday, January 13, 2013 4:56 AM
  • I installed the most recent version and that didn't seem to resolve the issue either. 

    If it makes any difference-- I also have a COM add-in named Visual Studio Tools for Office Design-Time Adaptor for Excel that is behaving the same way as PowerPivot. When I check the add-in to turn it on, the ribbon doesn't appear and it then it automatically unchecks itself. The Load Behavior also returns the same error (Not Loaded. A runtime error occurred during the loading of the COM Add-in.)

    Monday, January 14, 2013 5:20 PM
  • Same problem here.  I used to receive the error, not loaded. A runtime error occurred during loading of the com add-in, now when I go in and check the box under manage com add-ins, it doesn't stay checked, so no chance it will load now.

    I installed the new 2012 SQL Power Pivot x86 for Excel 2010 (my office version is x86).  I noticed that the vstor_redist.exe is only one file now.  There used to be 2, one for x64 and one for x86.  When I look into the programs, I only see x64 vstor installed.  My computer is Win 7 SP1 x64, and Office 2010 x86 SP1.  I do have the prerequisites listed installed.  However, uncertain if the x86 version of vstor is installed.

    Any advice would be appreciated.


    FYI - I don't have the same problem on a x86 Win 7 SP1 machine.  Power Pivot (same version as above) installed fine on the x86 platform.  Having trouble on the mixed environment.
    • Edited by Footballer123 Wednesday, July 10, 2013 4:21 PM forgot something
    Wednesday, July 10, 2013 4:19 PM
  • Unfortunately, this issue remains unresolved and I still can't load PowerPivot. Thankfully, I have another computer which is operating the 32-bit version that I can work from.<o:p></o:p>

    Good luck in resolving this issue. If you reach a solution to this issue, please share your workflow.<o:p></o:p>

    Wednesday, July 10, 2013 5:25 PM
  • Is this still an issue?

    Ed Price, SQL Server Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Monday, September 16, 2013 3:29 AM
  • Yes, this is still an issue.

    I'm using PowerPivot on Windows 7 64-bit witrh Office 32-bit and PowerPivot 32-bit.  It worked for a few days. Then my Excel crashed. probably due to too large file.  Now the PowerPivot button doesn't show up anymore. It appears that the crash corrupted something. I reinstalled (repair option). Without success so far. Shoot!

    Saturday, October 26, 2013 7:18 AM
  • I resolved the issue myself. Due to crash of Excel the PowerPivot add-in was automatically disabled. I had to "enable" it again in Options --> Addins ....
    Saturday, October 26, 2013 9:13 PM