SQL Server Management Studio Error 64


  • Hi!<o:p></o:p>

    I am experiencing some difficulties with SQL
    management studio for some users in a domain:<o:p></o:p>

    User DomainA\Joe is granted SQL login rights on a
    SQL2008 SP2 instance, and can log into the instance from a domain member
    laptop. Joe can also log into the same instance from the SQL server(when using

    User DomainA\Johnny is granted the same SQL login rights
    on the same SQL2008 SP2 instance as DomainA\Joe, and cannot login to the
    instance from the same domain member laptop as Joe.

    If Johnny tries to login to SQL management studio to the same SQL instance from
    the server(using rdp) it works out fine.<o:p></o:p>

    The error DomainA\Johnny receive:

    A connection was
    successfully established with the server, but then an error during the login
    process.(provider TCP Provider, error: 0 - The specified network name is no longer
    available.)(Microsoft SQL Server, Error: 64)

    SQL Server edition: SQL Server 2008 SP2(10.0.4064.0)

    Windows OS: Windows 2008 R2 Enterprise(SP1 not installed)

    Domain information: Windows 2008 R2 Domain level

    Forrest level: Windows 2008 R2 <o:p></o:p>

    The computer, server and users are all in the same
    domain and IP subnet (so no firewall is blocking). Windows firewall is disabled
    on both server and computer and there are no IPsec communication requirements.<o:p></o:p>

    The question is: Why is a user denied login using SQL
    management studio on a domain laptop, but is granted login on the server - when
    another user with the same level of permission is granted login using SQL
    management studio on the same domain laptop(and is also granted login on the
    SQL server)?<o:p></o:p>

    ---------------------------------------------------------- Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    Wednesday, October 03, 2012 11:32 AM


  • Hi,

    thank you all for the replies. Due to a domain migration a lot of the users kept their old Active Directory Groups from the parrent domain causing Kerberos to fail.
    I wrote a blogg post for this, for more information see:

    Best regards,


    ---------------------------------------------------------- Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    Monday, October 08, 2012 8:29 PM

All replies