none
Migrating Packages

    Question

  • Hello

    I am trying to migrate some SSIS packages from a 2008 instance to a 2008 R2 instance.  I have exported the dtsx file from the 2008 instance.  When I attempt to import the package into the R2 instance, Management Studio > SSIS > Import Package > File System > Rely on server storage and roles for access control (I am not encrypting the credentials).  I receive an error message below when trying to import the package.  I have run the package within Visual Studio on R2 instance and it runs perfectly.  I have tried rebuilding the package on the R2's Visual Studio and importing but am still running into the same issue.  Unfortunately I cannot do a side by side installation (so I have to migrate via the file system).  If the error message displayed the actual problem I think I would be able to figure this one out.  By the way I am naming the package LocalityFuzzy not 꽸產ᢼ甦ᣘ甦.  Does anyone have any clues?  Thank you

    TITLE: Import Package
    ------------------------------

    Object name "꽸產ᢼ甦ᣘ甦" is not valid. Name must contain only alphanumeric characters or underscores "_".
     ({8BBB7189-4388-43F8-A081-9E01A9AB9C8E})

    ------------------------------
    ADDITIONAL INFORMATION:

    Object name "꽸產ᢼ甦ᣘ甦" is not valid. Name must contain only alphanumeric characters or underscores "_".
     ({8BBB7189-4388-43F8-A081-9E01A9AB9C8E})

    Wednesday, October 20, 2010 12:52 AM

All replies

  • change your package name as error said, you should only have alphanumeric characters or underscores, could you set English name for package and try again( I think package name is Chinese)

    http://www.rad.pasfu.com
    Wednesday, October 20, 2010 5:16 AM
    Moderator
  • Rob

    Did you ever fix this - I am getting a similar problem

     

    Seth


    http://lqqsql.wordpress.com
    Monday, January 17, 2011 11:15 AM
  • Hi,

    The problem isn't with the names in the package it is with SSIS itself.

    I had recently installed SP4 on SQL 2005 on the same server where SQL 2008 r2 sat. I realised this was the only change I had made before this problem came along.

    To fix it I re-installed the latest hot fix for SQL 2008 r2 and rebooted the machine.

    Seth


    http://lqqsql.wordpress.com
    • Proposed as answer by Visakh16MVP Monday, April 6, 2015 11:36 AM
    Monday, January 17, 2011 3:25 PM
  • this is not the answer, Im facing the same problem. I get the same message regardless the name of my packages. I even change the name to a single leter "A" and I get the same error.
    Thursday, August 23, 2012 9:56 PM
  • Could Send me resolve step for above problem,i am also facing same problem?

    After installing SSIS its works fine , recently i am getting same error...!

    Is it because of compatibility of database?

    Tuesday, September 11, 2012 7:23 PM
  • First goto the solution in BIDS, click 'file' then 'Save a Copy of PackageName.dtsx As..' option.  Then select 'SSIS package store', provide server name and the package path where you want to deploy. Finally click ok. Thats it

    Note: Make sure to give read/write permission to the folder and the package  'C:\Program Files\Microsoft SQL Server\100\DTS\Packages\PackageName.dtsx'

    Thursday, March 26, 2015 2:05 PM