none
SSRS 2008 Report Parameter Default Value doesnt work when deployed RRS feed

  • Question

  • Hi,

    I have a parameter that chooses its available items from a query (with a label and a value column). I set the default for the parameter to the a particular value.

    It works in Preview from design mode, but when I deploy it and run the report, it does not set the default.

    Any ideas?

    Thanks!


    Rick
    Wednesday, May 12, 2010 6:41 PM

Answers

  • Hi Rick ,

    Try deleting the report from report manager then re-deploying

    The parameters can be set  from report manager and are sometimes a little sticky to revert to the new ones you have defined in BIDS.

    I'm sure it is just a cacheing issue,  but it is satisfying to delete it and start again.

     


    Hope this helps Robert Edgson
    • Marked as answer by Rick Hodder Wednesday, May 12, 2010 7:27 PM
    Wednesday, May 12, 2010 7:08 PM
  • When you deploy the report over an existing report that originally did not have the defaults set, this could happen.

    you have 2 options

    1. Delete the report from report manager and do a fresh deployment

    2. Go to properties of report in report manager, in 'parameters'section check if 'has default' is set.

    • Marked as answer by Rick Hodder Wednesday, May 12, 2010 7:27 PM
    Wednesday, May 12, 2010 7:08 PM

All replies

  • Double check in the parameters section on the deployed report that the parameters are set as you would like.

    This is on the left hand side once you have gone to look at the report properties.

     

    -Eric


    Eric Hilton
     
    The science of turning data into decisions.
     
    LiveLogic, LLC
    Wednesday, May 12, 2010 7:05 PM
  • Hi Rick ,

    Try deleting the report from report manager then re-deploying

    The parameters can be set  from report manager and are sometimes a little sticky to revert to the new ones you have defined in BIDS.

    I'm sure it is just a cacheing issue,  but it is satisfying to delete it and start again.

     


    Hope this helps Robert Edgson
    • Marked as answer by Rick Hodder Wednesday, May 12, 2010 7:27 PM
    Wednesday, May 12, 2010 7:08 PM
  • When you deploy the report over an existing report that originally did not have the defaults set, this could happen.

    you have 2 options

    1. Delete the report from report manager and do a fresh deployment

    2. Go to properties of report in report manager, in 'parameters'section check if 'has default' is set.

    • Marked as answer by Rick Hodder Wednesday, May 12, 2010 7:27 PM
    Wednesday, May 12, 2010 7:08 PM
  • Hi All,

    Instead of delete and re deploy the report, we can use "nothing" as value for  default parameter.

    Its works for me.

    Wednesday, September 23, 2015 3:19 PM
  • Experiencing the same thing. 
    Friday, November 4, 2016 6:31 PM
  • Another way is click to Open the Manage page, then click on Parameters.  Then correctly set  the "Has Default" --chances are it was not checked if it is not working), then ensure these are set correctly too "Default Value", "Null" and for good measure "Hide", "Prompt User" and "Display Text".  It works this way in 2012, but the 2008 SSRS may be different.
    • Edited by BernieIII Friday, January 20, 2017 3:12 PM
    • Proposed as answer by Shishpal Singh Friday, August 16, 2019 10:57 AM
    • Unproposed as answer by Shishpal Singh Friday, August 16, 2019 10:58 AM
    Friday, January 20, 2017 3:02 PM
  • I have fixed this as the following mention below as I don't have access to report manager:
    Create another dataset for default values and set it to parameters "Default Values" section using a selection of "Get values from a query" using newly created dataset and it will be working fine for me when deployed.
    Friday, August 16, 2019 11:01 AM