none
After update windows including SQL 2012 SP2 unable to start SQL service/instance RRS feed

  • Question

  • We have SQL 2012 Ent 64 bit SP1

    Window 2008 R2 Datacenter

    After update windows including SQL 2012 SP2 unable to start SQL service/instance and following event log

    Cannot recover the master database. SQL Server is unable to run. Restore master from a full backup, repair it, or rebuild it. For more information about how to rebuild the master database, see SQL Server Books Online.

    Script level upgrade for database 'master' failed because upgrade step 'SSIS_hotfix_install.sql' encountered error 945, state 2, severity 25. This is a serious error condition which might interfere with regular operation and the database will be taken offline. If the error happened during upgrade of the 'master' database, it will prevent the entire SQL Server instance from starting. Examine the previous errorlog entries for errors, take the appropriate corrective actions and re-start the database so that the script upgrade steps run to completion.


    ABDUL HAFEEZ MCSE MCITP

    Monday, October 20, 2014 4:31 AM

Answers

  • Solution of the problem

    1. Start SQL Server service with Trace Flag 902: 
      • >Net Start MSSQL$InstanceName /T902
    2. Open SQL Server Management Studio, go to Availability Group and remove SSISDB from the availability databases
    3. Open New Query, execute the SSIS_hotfix_install.sql script which can be found inInstall folder under \Program Files\Microsoft SQL Server\MSSQL11.MSSQL$InstanceName \MSSQL
    4. Stop SQL Server services:  
      • >Net Stop MSSQL$InstanceName
    5. Start SQL server service from SQL Server configuration manager
    6. Add SSISDB back to Availability Group


    ABDUL HAFEEZ MCSE MCITP

    Tuesday, October 21, 2014 4:25 AM

All replies

  • upgrade step 'SSIS_hotfix_install.sql' encountered error 945, state 2, severity 25.

    Hello

    select *
    from sys.messages
    where message_id = 945

    => Database '%.*ls' cannot be opened due to inaccessible files or insufficient memory or disk space.  See the SQL Server errorlog for details.

    Have you checked the disk for free space?


    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Monday, October 20, 2014 7:30 AM
  • Hi Abdul,

    Can you please check Below link this seems to me like a bug it should not have happened assuming you did not changed permission for account running SQL Server service. If you changed then Olaf is correct to point about issue

    http://ayadshammout.com/2014/02/04/sql-2012-sp1-cu6-issue-with-ssis-db-in-availability-group/


    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My Technet Wiki Article

    MVP

    Monday, October 20, 2014 8:53 AM
  • Solution of the problem

    1. Start SQL Server service with Trace Flag 902: 
      • >Net Start MSSQL$InstanceName /T902
    2. Open SQL Server Management Studio, go to Availability Group and remove SSISDB from the availability databases
    3. Open New Query, execute the SSIS_hotfix_install.sql script which can be found inInstall folder under \Program Files\Microsoft SQL Server\MSSQL11.MSSQL$InstanceName \MSSQL
    4. Stop SQL Server services:  
      • >Net Stop MSSQL$InstanceName
    5. Start SQL server service from SQL Server configuration manager
    6. Add SSISDB back to Availability Group


    ABDUL HAFEEZ MCSE MCITP

    Tuesday, October 21, 2014 4:25 AM
  • The same was pointed clearly in link I posted

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My Technet Wiki Article

    MVP

    Tuesday, October 21, 2014 9:59 AM
  • You saved my life, thank you Abdul!

    Monday, September 25, 2017 5:10 AM