returned status value 2 error


  • Could someone please explain why I get the following errors ?

    I have them in 15 out of 20 packages and its always the same, I have tried, removing the columns from the data source but it just seems to jump then to another column.

    I have also tried redirecting the errors to a differnet error database but ALL the rows just seem to be errors then

    In event viewer I get no further information simply

    Event Type: Error
    Event Source: SQLISPackage
    Event Category: None
    Event ID: 12291
    Date:  14/01/2006
    Time:  14:57:56
    Package "Policy_PC" failed.

    [Flat File Source [1]] Error: Data conversion failed. The data conversion for column "Column 42" returned status value 2 and status text "The value could not be converted because of a potential loss of data.".

    [Flat File Source [1]] Error: The "output column "Column 42" (176)" failed because error code 0xC0209084 occurred, and the error row disposition on "output column "Column 42" (176)" specifies failure on error. An error occurred on the specified object of the specified component.

    [DTS.Pipeline] Error: The PrimeOutput method on component "Flat File Source" (1) returned error code 0xC0202092.  The component returned a failure code when the pipeline engine called PrimeOutput(). The meaning of the failure code is defined by the component, but the error is fatal and the pipeline stopped executing.

    Any input at all is welcome, Im still a newbie at this

    Saturday, January 14, 2006 3:06 PM

All replies

  • I would guess that you have a value incoming that you are trying to convert to a string and the length of the output string column is not large enough to accomodate the incoming value.

    Increase the length of output column "Column 42".



    Saturday, January 14, 2006 5:54 PM
  • Thanks for getting back to me Jamie.

    The data incoming is from a delimited csv file after which I use the "Suggest Datatype" to get the different datatypes for the columns.

    The problem seems to occur on all different datatypes

    eight-byte signed integer [DT_18],double-precision float [DT_R8] as well as strings and then my Destination table doesnt show length for a lot of the columns it just shows something like

        [Column 12] DOUBLE PRECISION


        [Column 43] BIGINT,

    Should I try adding in values to the output columns such as BIGINT (15) or some such ?

    Saturday, January 14, 2006 6:58 PM
  • Actually when hover my Pointer over a Column in "SQL Destination Editor" it gives a lenght of "0" is this ok for a column such as     [Column 12] DOUBLE PRECISION ?


    Saturday, January 14, 2006 7:09 PM
  • Try changing the suggested data types and see if that makes a differrence. Without seeing the data its hard to suggest what to do.

    One thing you should definately do though is check each column individually. So only import one column at a time. You can test this out in another "scratch" package if needs be.



    Sunday, January 15, 2006 9:25 AM