locked
SQL Server Express 2008 Installation error. PLEASE HELP. RRS feed

  • Question

  • Hey guys anyone know what I should do to install SQL Server Express 2008?

    Im running Vista Home Premium SP1 32bit
    These are folders i got on framework folder:
        *      v3.5
        *      v3.0
        *      v2.0.50727
        *      v1.1.4322
        *      v1.0.3705

    Installing SQL Server 2008 Express (run time only)
    And this is the error I get during the process

    "Attributes do not match. Present Attributes (Directory, Compressed), included attributes (0), excluded attributes (Archive, Compressed, Encrypted)."

    I have downloaded and installed all Visual Studio 2008 SP1 Express Ed (C++, C#, VB, WebDev) and all worked well

    I get this error during the "Feature Selection" setup process.

    I also noticed when I tried to use Windows Update, I saw Microsoft SQL Server 2008 Service Pack 1 (KB968369) suddenly available (I have updated windows and installed all important updates before installing Microsoft Visual Studio and SQL). Then I used Windows Update to install SQL Server 2008 SP1 and I still got this error:

    Error
    Code 84B40000 Unknown error....

    I also get this downloading error on SQL Server while installing all 4 Visual Studio Express Editions (C#, C++, VB, WebDev).
    "The following cannot be downloaded:"

    I've already tried the troubleshooting guide about BITS but the tool fix seems to only supports Windows XP Operating Systems.

    Please please please Help Me (^_^).. thanks to all.

    P.S.

    I think this might have some connections to why I get errors on a simple 'Hello World' Website.

    I was just trying to simply make a 'Hello World' Website .. Just THAT on my website.

    A simple Website for me to start. Just showing those text on the website. But when I tried to run (debug) the program. This error shows...

    'Firefox can't establish a connection to the server at localhost:5903.'

    I have Build the Web Site and there was no error. Since it was just simply 'Hello World' text.

    Im sure there's some problem but I'm completely stuck here.  I dunno if its connected to the problem above.

    Please help me solve this problem. Thank you so much.

    I appreciate everyone's help.
    Sunday, May 3, 2009 9:40 AM

Answers

  • You don't need to have SQL Express installed to build a simple "hello world" app.

    I suspect that you're trying to install SQL Server into a compressed directory - is this the case?
    Aaron Alton | thehobt.blogspot.com
    • Marked as answer by Aaron Alton Monday, May 4, 2009 1:39 PM
    Monday, May 4, 2009 1:40 AM

All replies

  • You don't need to have SQL Express installed to build a simple "hello world" app.

    I suspect that you're trying to install SQL Server into a compressed directory - is this the case?
    Aaron Alton | thehobt.blogspot.com
    • Marked as answer by Aaron Alton Monday, May 4, 2009 1:39 PM
    Monday, May 4, 2009 1:40 AM
  • O wow great that fixed my error hahaha... i finally installed SQL server 2008 thanks to you. I did have my files compressed.  Thanks a lot that fixed the problem.  As for my other problem creating a basic website. I think i should post that on ASP.net so yah im gonna try anywayz thanks a lot again for the help.
    Monday, May 4, 2009 5:03 AM
  • Step 1: Goto C:\Program Files\Microsoft SQL Server

    Step 2: Right clikc -> Properties

    Step 3: Click Advanced on General Tab

    Step 4: uncheck all the checkbox

    Step 5: Click OK

    Step 6: now try to install SQL Server 2008

    -Ramki

    • Proposed as answer by Ramadan Cola Thursday, January 6, 2011 1:27 PM
    Friday, April 30, 2010 6:01 PM
  • That was a great answer and very helpful.. thank you so much
    Tuesday, September 20, 2011 1:02 PM
  • Very helpful, Thank you so much
    Thursday, March 22, 2012 8:04 AM
  • In my case I had to uncheck "Allow files in this folder to have contents indexed in addition to file properties"

    • Right click on C:\Program Files\Microsoft SQL Server
    • Click Advanced on General Tab
    • Uncheck "Allow files in this folder to have contents indexed in addition to file properties"
    • Edited by JosipM Monday, November 24, 2014 2:12 AM
    Monday, November 24, 2014 2:07 AM
  • Thanks!
    Wednesday, September 4, 2019 3:37 PM