none
Error CS2001 & CS2008 RRS feed

  • Question

  • After installing and configuring RS June CTP, when attempting to deploy a new report or when browsing http://localhost/reports

    I'm getting error:

    Error 1 Server was unable to process request. ---> Unable to generate a temporary class (result=1). error CS2001: Source file 'C:\WINDOWS\TEMP\9a1mhqzb.0.cs' could not be found error CS2008: No inputs specified



    Friday, July 1, 2005 8:09 PM

Answers

  • You're right this is caused by the permissions on the windows temp folder.  You should only need to grant Read, Write, Modify, and Delete, rather than full control.

    -Lukasz
    Tuesday, August 2, 2005 9:48 PM
    Moderator

All replies

  • Probably ASP.net does not have permissions to the asp.net temporrary files folder.

    Try running "aspnet_regiis.exe -ga <username>" from the Windows\Microsoft.Net\Framework\v2.xxxx folder where <username> is replaced with the account that asp.net is to run under.  This would mean it is the account set for report server virtual directory application pool (default is Network Service).

    -Lukasz
    Friday, July 15, 2005 11:50 PM
    Moderator
  • Hi,

    I am having same problem. I tried the solution that Lukasz suggested. i.e. I executed aspnet_regiis.exe -ga "NT AUTHORITY\NETWORK SERVICE" from the command prompt and tried to deploy the report as well as browse http://localhost/Reports and I am still getting CS2001 and CS2008 errors.

    How do I find which account is set for report server virtual directory app pool?

    I have just used default installation of SQL Server 2005 so I thought NETWORK SERVICE would work. Any ideas?

    Regards,
    Ketan
    Monday, July 18, 2005 8:04 PM
  • just simply go to c: > windows > temp
    right clik and click on properties > Security >
    here Click on Add and find out the ASP.Net user, add and then allow full control
    and now Debug and run your application again.
    it will (Insha Allah) work if this is the problem....enjoy
    Tuesday, August 2, 2005 6:03 PM
  • You're right this is caused by the permissions on the windows temp folder.  You should only need to grant Read, Write, Modify, and Delete, rather than full control.

    -Lukasz
    Tuesday, August 2, 2005 9:48 PM
    Moderator
  • I had a similar issue, but had to add the NETOWRK SERVICE account with the same privileges to the windows\temp directory.
    Saturday, June 17, 2006 5:46 PM
  • This is sometimes required as a manual step when using SQL Server 2000 Reporting Services.

    When using SQL 2005 RS, you should be able to use the aspnet_regiss -ga command to grant sufficient rights to the appropriate account.

    [revision] Based on comments lower in the thread: You need to ensure the report server has access to the windows\temp folder on the report server computer. 

    -Lukasz

    Monday, June 19, 2006 4:19 PM
    Moderator
  • I tried all three solutions and am still seeing the error.  I am using a domain account.

    1) aspnet_regiis -ga testdomain\myalias, "NETWORK SERVICE", and "ASPNET"

    2) Gave both the ASPNET user and the NETWORK SERVICE Full Control over my C:\WINNT\Temp folder (where the error is showing up)

    3) Restarted my application, and still I get the same error. 

    Could my user context have anything to do with this?

    Thursday, June 22, 2006 9:14 PM
  • Ok, found out my mistake.  This is happening on the web server, not my client where I'm running my test application.  Duh...  Adding the correct permissions to the C:\Winnt\temp folder on the IIS server did the trick.

    Thanks for the 411 everyone.

    Thursday, June 29, 2006 6:56 PM
  • I also had an similar issue after installation of Microsoft SQL Server 2005 Express Edition with SP1 (needed for Symantec Backup Exec) on an Windows Server 2003 R2 with SP2.

     

    The error at my environement was, that WSUS dont work and displays the CS2001 & CS2008 errors.

     

    It works now fine after given the Network Service Account the standard rights which Windows adds when the Account is added to the list of users in security page.

     

    Friday, April 20, 2007 11:47 AM
  • This is an OLD post but I think I'll try anyways...Now I'm getting this error...seems to be server related, not client. Can you let me know the 'minimum' permissions you applied to C:\windows\temp for this? This server is in production so I dont want to jeopardize anything currently running...thanks!
    Tuesday, June 5, 2007 4:57 PM
  • i granted the %systemroot%\temp directroy for the IIS_WPG and Netwrok Service with FULL access

    and then it worked !!

     

    (Win2003Server)

     

    good luck

    Tuesday, October 30, 2007 8:26 AM
  •  

     

    Hi,

    Let me explain the environment in which we are working. We are working on the Client's Network Via VPN. We deployed Cube solution, ETL solution, Report Solution Via VPN.

     

    While Deplyoing the Report Solution we got the Error CS2001. So we followed every step and granted permission for various user(ASPNET, SqlReportingServices.. etc. etc.)on C:\Windows\Temp and everything worked seamlessly. Next day we tried accessing the reports but we were not able to see it. Only the report parameters were available that too without any data.

    We checked permissions on C:\Windows\Temp and it was all gone. The permission that we gave was no more there.

    We gave all the permissions again and than everything started again. We checked the next day and the same problem, all the pemissions were removed and reports again stopped working.

    I am not able to figure out what the problem is?

    I am administrator on the system and i have full access to the system.

     

    Any help will be appreciated...

    Thanks in advance.

     

    Regards,

    Swapnil

    Thursday, March 20, 2008 11:45 AM
  • i try to give temp folder full permission (asp.net /network service/IIS_WPG)
    and also give the full permission  to website but the problem also had. how can i do to solution the problem
    Monday, May 26, 2008 4:10 PM
  • This was the thread that answered the question for me!

     

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=211440&SiteID=1

     

    Basically, I had to grant 'Read, Write, modify' authority to the 'Network Service' user and everything is good to go again.

     

    The thing that caused this problem in the first place is that this server is in our test environment and was the Domain controller for our test domain. Well, we had a software problem from a vendor that required that their databases could not be on the domain controller. So we demoted this server and promoted another one to domain controller. This demotion process caused IIS to stop working.

     

    Thanks everyone for your help! - ERic -

     

    Wednesday, December 3, 2008 8:31 PM
  • Based on the information in these posts, I granted the service account that I am using for the Reporting Services service and app pool read-write permissions in C:\WINDOWS\TEMP. That did not solve the issue at first. After restarting the Reporting Services service and doing an IISReset, I was able to access the report manager page.
    Thursday, February 19, 2009 9:13 PM
  • Eric - This solved the problem that cost my company $20,000 today. God bless you, man.
    Thursday, November 12, 2009 5:05 AM
  • Common problem with security to access

    C:\WINDOWS\Temp.

    You need to grant full security access for IIS_WPG and Network Service Account

    Tuesday, October 2, 2012 8:39 PM
  • Thank you, I add IIS premission to Temp Folder and my problem solved

    Unfortunately, I can not speak English well I am a beginner programmer. I love the improvements

    Thursday, February 23, 2017 12:59 PM