locked
DBPROCESS is dead or not enabled RRS feed

  • Question

  • why the error message "DBPROCESS is dead or not enabled" appear frequently , but when i run the application again ,it can connect to the server.

    What can i do to solve the problem?

    SERVER 2000 enterprise edition (not sp4)

    Saturday, February 3, 2007 6:39 AM

All replies

  • Hi,

    this is a very generic one, indicating mainly that the communication between the server and the client failed, due to problems like a lost connection, problems in the used protocol, timeouts, or simply a SQL Server error which should be protocolled in the SQL Server log and/or event log (depending on the severity). In addition make sure that you enabled remote connections for named Pipes / TCP.

    HTH, Jens K. Suessmeyer.

    ---
    http://www.sqlserver2005.de
    ---

    Saturday, February 3, 2007 12:31 PM
  • The version of the sql server is enterprise edition, not at the level sp4.
    But is there any problems, when i update the sql server to sq4, will the problem be resolve?
    Is this sql server's bug or the network problems or client application's problem.
    Anyone can help?

    Saturday, February 10, 2007 3:27 AM
  • Anybody has the same problem with me?
    Saturday, February 10, 2007 3:28 AM
  • J'ai exactement le même problème au bout d'un certain temps d'inactivité. Je cherche à le résoudre. J'ai ce problème depuis que je suis passé à SQL Server 2005. J'accède à SQL Server par l'intermédiaire d'un accès natif dans mes applications Windev. A bientôt avec la solution, j'espère

    Tuesday, March 6, 2007 7:23 AM
  • also check whether the Auto close property of the database is on ... if it is on .. set it OFF and try

     

    select DATABASEPROPERTY ('somedatabase' , 'isAutoClose' )  run this statement and if it returns 1 set this property off and see

    Madhu

    Tuesday, March 6, 2007 8:14 AM
  • Je rencontre également ce problème seulement sur un ordinateur client parmi une dizaine sous Windev en accés natif ( l'ancien ) : j'attends le nouveau avec impatience mais si quelqu'un a une solution ?.

     

     

    Idem : somedy has solved this problem  ?

    Thursday, July 19, 2007 2:02 PM
  •  ZhenYuan wrote:
    Anybody has the same problem with me?

    We have recently started having this problem as well.
    we thought maybe it was Forefront Client Security as it started a day or 2 after we rolled this out to our users and servers. But after removing Forefront the issue still Remains.

    The only other change we did was the install of Server 2003 SP2.

    We are also getting "Error Message - SQL Server Message 10054"

    We are only getting this on MS Dynamics SL our other software that connects to the database seems to be ok... as far as we know as no users have said anything about other programs.

    Autoclose is off and named pips TCP/IP is configured.

    The only lead we have right now is we are thinking it has to do with disk I/O as we seem to be maxing it out more then 100% for 6seconds or longer around the time of disconnects... we have only started watching this so we are not too sure yet.

    ________________________________________________________
    update

    Issue resolved with the following

    Cause 1

    The TCP/IP offload engine (TOE) is turned on in Windows Server 2003. The TOE may have been turned on when you installed Windows Server 2003 Service Pack 2. To resolve this problem, see Resolution 1.


    Resolution 1

    To disable the TOE, follow these steps:

    1.

    Click Start, click Run, type regedit, and then click OK.

    2.

    Expand HKEY_LOCAL_MACHINE, expand SYSTEM, expand CurrentControlSet, expand Services, expand Tcpip, and then click Parameters.

    3.

    Right-click EnableTCPChimney, and then click Modify.

    4.

    In the Value Data box, type 0, and then click OK.

    5.

    Exit Registry Editor.

    6.

    Restart the server.



    So it was because of the SP2 install.
    Tuesday, March 11, 2008 4:32 PM
  • Hello, Sean Boudreau
    I think the only method is to update the server and SQL SERVER 2000

    Wednesday, March 12, 2008 1:19 AM