none
SQL 2008 R2 - Error Code 2337

    Question

  • Background: I am upgrading a VPC with SQL 2005 std on Server 2003 SP1.  I am using a .iso for SQL 2008 R2 Standard downloaded from MSDN.

    I have tried installing several times {upgrade, fresh install, uninstall-reinstall}  Same error every time.  I downloaded a fresh ISO from msdn, same error.  I tried SQL 2008 R2 EE.  Same.
    I tried unpacking the ISO to a local HDD. Same.
    My VM has plenty of hdd space, the source/destination work fine.  No Antivirus getting in the way either. 

    The last lines in the two log files are:

    [sql_engine_core_shared_Cpu32_1.log]
    -MSI (s) (E0:3C) [16:17:55:820]: Executing op: SetTargetFolder(Folder=C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\)
    -MSI (s) (E0:3C) [16:17:55:820]: Executing op: SetSourceFolder(Folder=1\PFiles\SqlServr\100\Tools\Binn\VSShell\Common7\IDE\|Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\)
    -MSI (s) (E0:3C) [16:17:55:820]: Executing op: RegisterSharedComponentProvider(,,File=SSIS_MS_DTS_Controls_DLL_SQL_32,Component={CE43BE0B-D75C-4E48-A0AF-513DA6CDF89D},ComponentVersion=10.50.1600.1,ProductCode={4C9D82EB-9001-4E59-8F64-0BEEE5F4A30A},ProductVersion=10.50.1600,PatchSize=0,PatchAttributes=0,PatchSequence=0,SharedComponent=1,IsFullFile=0)
    -MSI (s) (E0:3C) [16:17:55:840]: Executing op: AssemblyCopy(SourceName=bxt3bqyh.dll|Microsoft.DataTransformationServices.Controls.DLL,SourceCabKey=SSIS_MS_DTS_Controls_DLL_SQL_32,DestName=Microsoft.DataTransformationServices.Controls.DLL,Attributes=0,FileSize=837472,PerTick=32768,,VerifyMedia=1,,,,,ComponentId={CE43BE0B-D75C-4E48-A0AF-513DA6CDF89D},IsManifest=1,,,AssemblyMode=0,)
    -MSI (s) (E0:3C) [16:17:55:840]: Source for file 'bxt3bqyh.dll' is uncompressed, at 'D:\x86\setup\sql_engine_core_shared_msi\PFiles\SqlServr\100\Tools\Binn\VSShell\Common7\IDE\'.
    -MSI (s) (E0:3C) [16:17:56:231]: Assembly Error:The module '%1' was expected to contain an assembly manifest.
    -MSI (s) (E0:3C) [16:17:56:231]: Note: 1: 1935 2:  3: 0x80131018 4: IStream 5: Commit 6: 
    -MSI (s) (E0:3C) [16:17:56:231]: Note: 1: 2337
    -DEBUG: Error 2337:  Could not close file:  GetLastError:

    [Detail.log]
    2010-08-16 16:17:14 Slp: Running Action: Install_sql_engine_core_shared_Cpu32_Action
    2010-08-16 16:17:14 Slp: Sco: Attempting to create base registry key HKEY_LOCAL_MACHINE, machine
    2010-08-16 16:17:14 Slp: Sco: Attempting to open registry subkey
    2010-08-16 16:17:14 Slp: Sco: Attempting to open registry subkey SOFTWARE\Microsoft\VisualStudio\9.0
    2010-08-16 16:17:14 Slp: Sco: Attempting to get registry value InstallDir
    2010-08-16 16:17:14 Slp: Target package: "D:\x86\setup\sql_engine_core_shared_msi\sql_engine_core_shared.msi"
    2010-08-16 16:17:56 Slp: MSI Error: 2337 The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2337.

    Could it be that the ISOs on MSDN are bad?  Its hard to believe that I am the only one who would have noticed!

    Monday, August 16, 2010 9:18 PM

Answers

All replies

  • Hello,

    If VPC means Virtual PC, then please take a look at the workaround posted on the following link:

    https://connect.microsoft.com/SQLServer/feedback/details/550502/r2-rc0-install-problem-on-virtual-pc-2007

    Hope this helps.   

    Regards,

    Alberto Morillo
    SQLCoffee.com

    • Marked as answer by tgolisch Tuesday, August 17, 2010 1:02 PM
    Monday, August 16, 2010 11:20 PM
    Moderator
  • Surprising that this kind of thing could be caused by the ISO reader for VPC 2007.

    Last night, I got a physical DVD from my IT guy.  It was the official "Microsoft Licensing" dvd for SQL 2008 R2 (with laser-etched holograms, etc).  That copy worked fine.

    Tuesday, August 17, 2010 1:02 PM
  • After two failed install attempts using WinZip to extract the ISO, I found this article and used WinRAR to do the extract and the install worked fine.

    The WinZip DID extract the files, but on both failed attempts, everything installed except the Database Engine and Agent Browser.  Both failing with a 2337 error code in the sql_engine_core_shared_Cpu32_1.log.

    Once I did the extract using WinRAR and re-running the install, it worked perfect...

    hth,

     

    Adym

     

    Friday, January 28, 2011 2:44 AM
  • Boy am I glad I found this thread... Like Adym; I had sever failed attempts at installing SQL Server 2008 R2 x64 with a 2337 error code that prevented the Database Engine and Agent Browser from installing.  I also extracted the ISO using Winzip 14. 

    After the install failed, I was not able to uninstall the remnants until i copied setup.rll from the \resources\1033 folder in the installer to the target installation folder: C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2\Resources\1033.

    I uninstalled all the SQLServer 2008 bits and pieces, restarted (just to get clean) and then after extracting the ISO with WinRar x64 that I downloaded from Cnet, the installation completed successfully.


    There's someone in my head and it's not me - Pink Floyd
    Saturday, February 26, 2011 5:35 AM
  • I had the same problem, it's due to a bug in Winzip 14.0.

    I contacted WinZip and they upgraded me to WinZip 14.5 -  that fixed the problem.

    7-zip works perfectly as well.

    Monday, June 27, 2011 7:42 PM
  • After upgading the WinZip from 14.0 to 15.0, later extracted ISO file, and it works smooth like cream :)
    San...
    • Proposed as answer by Santhosh Aryan Friday, September 09, 2011 3:28 AM
    Friday, September 09, 2011 3:27 AM
  • I did all you wrote, but Im still stuck with a virtual SO W2008 server Enterprise R2 x64 4GB RAM

    It crash when it try to open the last setup screen , just after the installation of support files,

    and never open the screen where you select the features.  I Tried , Map network , virtualPC

    winzip 16 , and now I cannot install the DVD SQL server 2008 R2 from MSDN that finish with _520517.iso

    Any other hint?

    more info , all after the error code 2337

     

     



    • Edited by Satcholic Friday, January 27, 2012 5:00 PM
    Friday, January 27, 2012 4:51 PM