locked
The webpage cannot be found, Unable to bind to the underlying transport for [::]:80. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine. RRS feed

  • Question

  • Problem: When attempting to view the report server internet explorer give the error The webpage cannot be found. A look at event viewer shows the following error: Unable to bind to the underlying transport for [::]:80. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine.  The data field contains the error number.

    Workaround: Webservice url and report manager url should be changed from 80, I used 85 and it worked. Use Configuration manager to make this change. Drawback to this approach is that when accessing the report server you need to use the following url: http://localhost:85/Reports/Pages/Folder.aspx

    Reason For Posting: Would like to understand why I receive the error when using default port 80 and what I can do prevent this error, I do not want to use the workaround simply because it makes the url longer and harder to remember.

    edit:

    Solution

    I ran netstat -aon and discovered that port 80 was being used by PID 3532
    I used task manager, processes tab and added the PID column to identity process 3532
    The culprit was identifed as Skype
    I opened up Skype and unticked the advanced connection setting "Use port 80 and 443 sa alternatives for incoming connections"
    I reconfigured report server to use port 80 for Report Manager and Web Service URL
    I can now access report server using http://localhost/Reports/Pages/Folder.aspx
    Tuesday, June 26, 2012 9:36 AM

Answers

  • Solution

    I ran netstat -aon and discovered that port 80 was being used by PID 3532
    I used task manager, processes tab and added the PID column to identity process 3532
    The culprit was identifed as Skype
    I opened up Skype and unticked the advanced connection setting "Use port 80 and 443 sa alternatives for incoming connections"
    I reconfigured report server to use port 80 for Report Manager and Web Service URL
    I can now access report server using http://localhost/Reports/Pages/Folder.aspx
    • Marked as answer by jameslester78 Tuesday, June 26, 2012 10:20 AM
    Tuesday, June 26, 2012 10:20 AM

All replies

  • Do you have IIS installed on this machine?

    It looks like the port 80 is being used by some other process (ex: IIS). 

    Tuesday, June 26, 2012 9:49 AM
  • Do you have IIS installed on this machine?

    It looks like the port 80 is being used by some other process (ex: IIS). 

    No I dont have IIS installed, is there anyway to tell what is using port 80?

    edit: ran netstat -o, nothing shows up as using port 80

    edit: ran netstat -aon, shows skype is listening on port 80
    Tuesday, June 26, 2012 10:03 AM
  • Solution

    I ran netstat -aon and discovered that port 80 was being used by PID 3532
    I used task manager, processes tab and added the PID column to identity process 3532
    The culprit was identifed as Skype
    I opened up Skype and unticked the advanced connection setting "Use port 80 and 443 sa alternatives for incoming connections"
    I reconfigured report server to use port 80 for Report Manager and Web Service URL
    I can now access report server using http://localhost/Reports/Pages/Folder.aspx
    • Marked as answer by jameslester78 Tuesday, June 26, 2012 10:20 AM
    Tuesday, June 26, 2012 10:20 AM