locked
SOLUTION - Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E) RRS feed

  • General discussion

  • I've been pulling my hair out with this problem.  I can create reports in BI Studio and see them return data. After I deploy them to the Report Server I get this error message when I try to execute the report:

    Logon failure: unknown user name or bad password. (Exception from HRESULT: 0x8007052E)

    I played with the data source and tried every conceivable credential option.  Here's the fix (which I picked up on another forum):

    • Goto Reporting Services Configuration (in Start Menu->Programs->Sql Server->Config Tools.
    • Click on Execution Account
    • Uncheck "Specify an execution account"

    That's it. 

    Wednesday, September 6, 2006 1:38 PM

All replies

  • We can update the password for the given account as well :) Thanks Jeff. This saved a lot of time
    Wednesday, December 20, 2006 12:01 PM
  • Hi Jeff,

     

    thanks very much, I was trying all kinds of account settings etc.. But nothing worked. This solution actually worked.

    I've got one question though: does this pose some kind of security problem?

     

    Regards,

    Bert

    Monday, April 16, 2007 12:22 PM
  • Thank you for finding this solution!

     

    Another option to solve this problem is to leave the Execution Account checked and select the following credentials in the data source:

    Unattended report processing account.

    Thursday, May 17, 2007 7:40 PM
  • Thanks  a lot Jeff. Could you please let me know what makes the difference, when i uncheck that?


    Though, it works for me as well.

    Thursday, May 31, 2007 10:40 AM
  • Well, according to Books Online....

     

    Setting this account is optional, but not setting it limits your use of external images and connections to some data sources. When retrieving external image files, the report server checks to see if an anonymous connection can be made. If the connection is password protected, the report server uses the unattended report processing account to connect to the remote server. When retrieving data for a report, the report server either impersonates the current user, prompts the user to provide credentials, uses stored credentials, or uses the unattended processing account if the data source connection specifies None as the credential type. The report server does not allow its service account credentials to be delegated or impersonated when connecting to other computers, so it must use the unattended processing account if no other credentials are available.

    Thursday, May 31, 2007 12:39 PM
  • Another way we solved this problem was to check the "Use as Windows credentials when connecting to the data source" box in the data source definition.

     

    1. Home -> Data Sources
    2. Click on the data source
    3. In the "Connect using" section, click the radio button for "Credentials stored securely in the report server
    4. Enter the appropriate values in the "User name:" and "Password" boxes
    5. Check the box "Use as Windows credentials when connecting to the data source"

    HTH

    Wednesday, October 1, 2008 10:06 PM
  • Man, thank you. I never thought that will interfere with the non automatic execution. I almost feel like a retard cause I never try that obvious thing.

    THANKS!!!
    Tuesday, October 20, 2009 3:02 PM
  • Thanks a lot, it is working for me
    Tuesday, May 18, 2010 11:17 PM
  • Thank you Mr Modzel!

    The permissions on Reporting Services are an absolute nightmare to deal with when you're first getting to grips with it but you've got me up and running.

    Cheers

     

    Thursday, October 28, 2010 10:24 AM
  • Thank you  so much!!! I do benefit from that!
    Thursday, January 13, 2011 8:27 AM
  • yes i gat et, results good, i dont now the reason but

    Ing. Edwin Gonzalez

    Thursday, September 20, 2012 4:02 PM
  • Jeff,

    Thanks for the information. I've being battling with this issue for 2 days. This works perfecty for me. :)

    Wednesday, January 9, 2013 7:30 PM