none
7-zip SSIS task run with SQL agent gives "This operation requires an interactive window station" error. RRS feed

  • Question

  • I have set up the 7-zip parameters to not require a response, and the process task object to have a "hidden" window.  This is also running with a proxy on the SQL agent.  Is there some other proxy setting, or package or job setting that needs to be done to let this run with the SQL agent?  It works fine running under BIDS.

    Thanks,

    John

    Friday, April 18, 2014 8:08 PM

Answers

  • Jonathan - yes, I have the -y parameter in place.

    What ultimately solved the issue for me was to reinstall 7-zip on the server, and then it worked fine.

    Thanks all for the input.

    John

    • Marked as answer by johnecon Wednesday, April 23, 2014 5:43 PM
    Wednesday, April 23, 2014 5:43 PM

All replies

  • Are you receiving a specific error in the SQL Agent?  I would think the SSIS package execution should be all that's required on the proxy.  Does the account/credential have full access to the source files?

    For debugging purposes, have you tried granting the proxy CmdExec access and running as an OS/CmdExec task?  Would it be possible to RDP into the server using the account and run the package with the execute package utility?

    Is the 64-bit version of 7-zip installed on the server (making sure SSIS package doesn't need to run 32 bit)?

    Sunday, April 20, 2014 4:57 AM
  • Actually you can implement zipping unzipping functionality without using any third party tools if you want. You'll just need to include j# redistributable functions for that in a script task.

    See

    http://microsoft-ssis.blogspot.in/2011/01/unzip-files-with-ssis.html 

    

    Please Mark This As Answer if it helps to solve the issue Visakh ---------------------------- http://visakhm.blogspot.com/ https://www.facebook.com/VmBlogs

    Sunday, April 20, 2014 5:30 AM
  • Hi,

    Just asking: have you specified -y to assume Yes on all queries from 7-zip?

    ~ J.

    Wednesday, April 23, 2014 6:58 AM
  • Jonathan - yes, I have the -y parameter in place.

    What ultimately solved the issue for me was to reinstall 7-zip on the server, and then it worked fine.

    Thanks all for the input.

    John

    • Marked as answer by johnecon Wednesday, April 23, 2014 5:43 PM
    Wednesday, April 23, 2014 5:43 PM