none
SQL Server not starting - FallBack certificate initialization failed RRS feed

  • Question

  • I can not start my SqlServer 2008 Express. The problem seemed to start when I changed my "Built In account, Log in as" from Local Service to Local System. If I try to change back to Local Service I get the messagebox with WMI Provider Error, "Cannot find object or property. [0x80092004]".

    Getting a bit confused, but read http://support.microsoft.com/kb/900497    mentioned about 
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib, Value name: Certificate, Type: REG_SZ not having a valid value then 2005 would not starte - my value is blank. Changing it to 0 did not work.

    How can I import a valid certificate using SQL Server Configuration Manager. And how do you turn off Forced Encryption? Not sure if this would fix it, but couldn't hurt.

    ======================================

    2009-03-08 01:39:06.01 Server      Error: 17190, Severity: 16, State: 1.
    2009-03-08 01:39:06.01 Server      FallBack certificate initialization failed with error code: 1.
    2009-03-08 01:39:06.01 Server      Unable to initialize SSL encryption because a valid certificate could not be found, and it is not possible to create a self-signed certificate.
    2009-03-08 01:39:06.01 Server      Error: 17182, Severity: 16, State: 1.
    2009-03-08 01:39:06.01 Server      TDSSNIClient initialization failed with error 0x80092004, status code 0x80. Reason: Unable to initialize SSL support. Cannot find object or property.

    2009-03-08 01:39:06.01 Server      Error: 17182, Severity: 16, State: 1.
    2009-03-08 01:39:06.01 Server      TDSSNIClient initialization failed with error 0x80092004, status code 0x1. Reason: Initialization failed with an infrastructure error. Check for previous errors. Cannot find object or property.

    2009-03-08 01:39:06.01 Server      Error: 17826, Severity: 18, State: 3.
    2009-03-08 01:39:06.01 Server      Could not start the network library because of an internal error in the network library. To determine the cause, review the errors immediately preceding this one in the error log.
    2009-03-08 01:39:06.01 Server      Error: 17120, Severity: 16, State: 1.
    2009-03-08 01:39:06.01 Server      SQL Server could not spawn FRunCM thread. Check the SQL Server error log and the Windows event logs for information about possible related problems.
    2009-03-08 01:39:06.07 spid14s     Clearing tempdb database.

    =====================================

    Any help would be appreciated.

    TheBrenda

    Sunday, March 8, 2009 7:20 AM

Answers

  • I think this may be the answerto this crazy error:FallBack certificate initialization failed with error code: 1.

    I too wanted to change the 'Log on as'' account from NT AUTHORITY\NETWORK SERVICE to 'Local Service' primarialy because my 'filestream' service had 'NT AUTHORITY\LOCAL SERVICE' after reinstalling SQL Server Express 2008 SP1 w/Advance Services, and I wanted to see if this would solve my AW install problems. (I'll explain this in another down the road.) This is where the trouble commenced. I tirelessly googled up and down the Net trying to find a solution for this problem to no avail. Every link I followed was telling me to do all of my alterations w/SSCM. After soo many furstrations and DEAD-ENDS, I went back to my old problem solving skills and tried to evaluate where else in the past had I manipulated SQL Services for my SQL 2000 environment. The $64,000 answer was of all places in  the home of 'SERVICES!' I took a look at mytrusted system Services appl. where all services for my machine runs and looked at the 'Log on' and found that the optional button for 'This account' had been selected with 'NT AUTHORITY\NETWORK SERVICES' were set for this instance. My option was to select the top Local Services button, going to the general tab and selecting the 'start' services & I was back in business!!!

    I waited a few seconds to see if SSCM would be reflective of the change, but NO :() luck!? I next called on some courage to right-click the SQLServerExp2008 line in SSCM & chose the start button. VOWLA . . . Success everything was back in sync again.  I am sure interested in knowing how these to apps got out of sync, but that resolution will have to wait for a while.


    Hope this helps someone else out there.
    TomJ


    Tom Johnson
    • Proposed as answer by tomDarth Wednesday, December 16, 2009 7:18 AM
    • Marked as answer by TheBrenda Thursday, October 18, 2018 12:55 PM
    Wednesday, December 16, 2009 7:18 AM

All replies

  • I have set the Network Force Encryption = NO. And there are no certificates listed on the CERTIFICATE tab.

    Maybe this started when I deleted SQL server 2005? Maybe it took the only certificate?
    Sunday, March 8, 2009 2:21 PM
  • Which OS are you using, is it XP? There is a problem with XP LocalService account and SQL Server initialization. If that is the case then change it to either NetworkService or some other user account (using SQL configuration manager) and then try to start it. If you are not running XP then let us know.

    Also look at the thread: http://social.msdn.microsoft.com/Forums/en-US/sqldataaccess/thread/cd4cbc1d-3e0e-4a54-9e8f-f9df5b669992/#page:2


    Zubair
    Tuesday, March 10, 2009 7:42 PM
  • I think this may be the answerto this crazy error:FallBack certificate initialization failed with error code: 1.

    I too wanted to change the 'Log on as'' account from NT AUTHORITY\NETWORK SERVICE to 'Local Service' primarialy because my 'filestream' service had 'NT AUTHORITY\LOCAL SERVICE' after reinstalling SQL Server Express 2008 SP1 w/Advance Services, and I wanted to see if this would solve my AW install problems. (I'll explain this in another down the road.) This is where the trouble commenced. I tirelessly googled up and down the Net trying to find a solution for this problem to no avail. Every link I followed was telling me to do all of my alterations w/SSCM. After soo many furstrations and DEAD-ENDS, I went back to my old problem solving skills and tried to evaluate where else in the past had I manipulated SQL Services for my SQL 2000 environment. The $64,000 answer was of all places in  the home of 'SERVICES!' I took a look at mytrusted system Services appl. where all services for my machine runs and looked at the 'Log on' and found that the optional button for 'This account' had been selected with 'NT AUTHORITY\NETWORK SERVICES' were set for this instance. My option was to select the top Local Services button, going to the general tab and selecting the 'start' services & I was back in business!!!

    I waited a few seconds to see if SSCM would be reflective of the change, but NO :() luck!? I next called on some courage to right-click the SQLServerExp2008 line in SSCM & chose the start button. VOWLA . . . Success everything was back in sync again.  I am sure interested in knowing how these to apps got out of sync, but that resolution will have to wait for a while.


    Hope this helps someone else out there.
    TomJ


    Tom Johnson
    • Proposed as answer by tomDarth Wednesday, December 16, 2009 7:18 AM
    • Marked as answer by TheBrenda Thursday, October 18, 2018 12:55 PM
    Wednesday, December 16, 2009 7:18 AM
  • I would just like to say a massive thanks Tom - you saved my day!!!!!
    Thursday, July 1, 2010 1:18 PM
  • I had exact the same problem and error log.

    Trouble was the SPN (Service Principal Name) we had set on the SQL service account. We made a typo in de server name. When we corrected the SPN, all SQL services started ... Hope this can help anyone.

     

    Monday, September 6, 2010 7:51 PM
  • You saved my day too..... Thanks 
    Wednesday, September 29, 2010 7:12 PM
  • I think I'm in love...
    Wednesday, November 3, 2010 3:23 PM
  • I had the same problem. Tried to change the 'Log On As' for the sql server service to Local System, but it didn't work.

    The following *did* actually work:

    • run the downloaded installer
    • it extracts files in c:\some-weird-hexadecimal-name
    • copy all files in that folder to somewhere else
    • close the installer (files in c:\some-weird-name are gone)
    • run a command prompt as administrator, and cd to the folder where the copy of the files are
    • then run
    setup /action=RebuildDatabase /InstanceName=SQLEXPRESS /SqlSysAdminAccounts=BUILTIN\Administrators

    Done.
    Monday, August 6, 2012 1:15 PM
  • I had the same sort of problem when upgrading to Windows 8.1 and choosing a Microsoft Account (email address with different password) rather than the original W8 local account as my Windows logon method.

    I couldn't connect via SSMS and had to go to Services.msc and select the MS Account (which is converted to the old local Windows logon name) and supply the email password rather than the old local account password. 

    I was then able to start the SQL service and connect using Windows Authentication via SSMS.

    What I was stuck on was that I had forgotten how to change the logon details for a SQL service and the answer by Tom above reminded me, so thanks.

    Summary: If one changes a local user to use a Microsoft Account in Windows, the old user is still there to connect to via .\OldUserName but one needs the new password applied via services so that the SQL server service gets started.

    Thursday, October 31, 2013 10:48 PM
  • I know it's probably too late to help with the original poster, but we had this same issue and nothing we tried resolved the problem. Finally, we opened a technical incident with Microsoft and this is the solution that we were provided:

    • Take backup of below registry key.

    HKLM\SOFTWARE\Microsoft\Cryptography\MachineGuid This key should ideally have the GUID of the machine without curly braces, so {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx} becomes xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    • Then delete the braces.
    • Try to reboot and start the SQL service . If service don’t start then Uninstall and reinstall SQL.

    The above solution worked on two separate machines exhibiting this problem.

    Monday, June 30, 2014 3:03 PM
  • Thanks :) , been struggling with this problem for days
    Tuesday, April 18, 2017 12:09 PM
  • Registered to say thank you. This worked perfectly!
    Saturday, April 7, 2018 10:14 PM
  • The man of year. :)
    Wednesday, October 10, 2018 9:22 AM
  • Your answer saved the day for me. Many thanks to you.
    Monday, November 5, 2018 1:26 PM
  • Many thanks to you this article helped me at 2019 !!!
    Tuesday, July 16, 2019 3:33 AM