logon failed from sqlcmd but not SQL Mgmt Studio RRS feed

  • Question

  • Having trouble access SQL Exp, getting 18452 ... logon failed ... untrusted domain msg. The situation:

    Vista SP2 Home Premium, x64, not domain joined (hostname:"User-PC"). Just installed SQL Exp. 08 R2 x64, install goes fine, use integrated security, changed to use System accnt ( I think the default was Network). But I can't connect using sqlcmd, logon failed , untrusted domain, msg 18452. So, try it side by side, SQL Mgmt Studio and sqlcmd, SQL Mgmt studio connects fine using integrated sec.. Confirmed this by launching a elevated cmd prompt, (check my id and that I have all the privs using "whoami /all"), all good. Launch SQL Mgmt Studio from this prompt, connects no prob, run "sqlcmd  -S .\SQLExpress", ... logon failed.

    Looked at Win Event log, see the success and failed logons, both are type 3, Security ID "NULL SID". Sqlcmd generates a failure reason of: "An error occured during logon", Status: "0xc000006d", Sub status: "0x0".

    Nothing in SQL Exp ERRORLOG but logging is not very detailed.

    Visuat Studio can't connect to SQLExpress - logon failed but now SQL Exp ERRORLOG records this:

    Error: 17806, Severity: 20, State: 14.
    SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure.  [CLIENT: <local machine>].
    Error: 18452, Severity: 14, State: 1.
    Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. [CLIENT: <local machine>]

    Haven't tried any changes yet. Ideas?


    Sunday, January 9, 2011 7:35 AM


  • Solved. Traced the prob. to my net setup. The clue was this a msg in the Win System Log from Lsasrv about the target name and it showed the fqdn. Did some checks and the fqdn didn't look right, cleaned up my network config (I had customized it for another project), and now it's working.
    • Marked as answer by WesE Sunday, January 9, 2011 7:23 PM
    Sunday, January 9, 2011 7:23 PM