none
Failed to acquire connection from Connection Manager RRS feed

  • Question

  •  

    Unfortunately, SSIS 2005 has been the most buggy, unstable development tool I've ever used by Microsoft next to Reporting Services 2000 (which I'll give a mulligan because 2005 rocked)

     

    In addition to countless issues I have with debugging (link lost, first script file needs to be longer than the second one), bizarre COM issues (The application called an interface that was marshalled for a different thread), the Visual Studio IDE hanging "waiting to complete an internal operation" and hardlocking .....I now finally have a show-stopper

     

    My project was working fine using a data source now all of a sudden, everytime I try to run the project ..it fails to validate and gives me these errors

     

    [Connection manager "ETLDB"] Error: An OLE DB error has occurred. Error code: 0x80040E4D. An OLE DB record is available. Source: "Microsoft SQL Native Client" Hresult: 0x80040E4D Description: "Login failed for user 'appuser'.".

     

    [Execute SQL Task] Error: Failed to acquire connection "ETLDB". Connection may not be configured correctly or you may not have the right permissions on this connection.

     

    The f-ed up thing about all this is that it was working a moment ago and the most frustrating thing is that it works if I execute the package manually using the DTEXEC command line tool - but it fails miserably in the designer.

     

    When I try to edit my OLE DB connection "ETLDB" in the Designer, the password is already set and Test Connection is fine and all my Data Flow tasks can even Preview data ..but when it comes to actually RUNNING the thing, it blows up within the designer.

     

    I can't believe my brief time with SSIS 2005 has been a nightmare

    Friday, June 13, 2008 6:11 PM

All replies

  • Do you have any package configurations enabled (right-click on the package background in the designer, and select Package Configurations)?

     

    Friday, June 13, 2008 9:15 PM
    Moderator
  •  

    Hi all,

    I have the Same issue..

    I have checked my package Configurations i even tried disabling it, still it throws the same error.

    Even if i use a modified Package configuration it again pops up the same error..

    I am stuck with this error for more than a day i am not able to proceed debugging my package ...!!!

    It would be a great help if some one could provide a solution for the same!!!!

    Thanks in advance!!!!!

     

    Wednesday, July 30, 2008 4:32 PM
  • Do you have a valid user name and password stored in the package or in the configuration? What's the package protection level set to? Can you connect to the SQL Server through SSMS?

     

    Wednesday, July 30, 2008 5:14 PM
    Moderator