locked
.NET 4.5.1 Breaks SQL Server 2012 Management Studio Connection RRS feed

  • Question

  • I installed .NET 4.5.1 and rebooted computer running Windows 7 SP1 x64. Then tried to run 2012 SQL Server Management Studio and get error connecting to 2012 SQL server on our internal network. This worked fine before installing .NET 4.5.1.

    I can run 2008 SQL Server Management Studio and it still works fine connecting to our internal 2012 SQL server.

    I uninstall .NET 4.5.1, re-install .NET 4.0 and 4.5 and then 2012 SQL Server Management Studio works fine connecting to our internal 2012 SQL server.

    Tuesday, November 26, 2013 8:05 PM

Answers

All replies

  • Hi,

    Can you check if this is related to any non-IFS LSP installed on the machine.

    Check the More Information section of the following KB article on how to determine if a non-IFS BSP or LSP is installed: http://support.microsoft.com/kb/2568167

    Thanks,


    Vivek Mishra - MSFT


    Tuesday, November 26, 2013 11:02 PM
  • Seems your solution was posted in the WorkAround section of a connect item located here: 

         http://connect.microsoft.com/VisualStudio/feedback/details/809740/net-4-5-1-crashes-sql-connection-in-sql-server-2012-management-studio

    and you stated: 

         Posted by jjjansen46 on 11/26/2013 at 1:25 PM  

         I was able to fix it by running this from cmd: netsh winsock reset 



    I suppot PASS - www.SQLPASS.org

    • Proposed as answer by Papy Normand Thursday, February 6, 2014 10:46 PM
    Saturday, January 18, 2014 1:13 AM