locked
Rebuilding SQL Server system datbases RRS feed

  • Question

  • We had some data lost caused by hardware failure and I have to rebuild system databases.

    I am running the following command where xxxx\xxxxx represent domain\useraccount and getting error below

    setup /ACTION=REBUILDDATABASE /QUIET /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="xxxx\xxxxx-a"; "yyyyyy\yyyyyy"; "zzzzzz\zzzzzzzzz"; /SAPWD=xxxxx

    Error

    The following error occurred:
    The Windows account xxxx\xxxxx-a'; does not exist and cannot be provision
    ed as a SQL Server system administrator.

    Error result: -2068578304
    Result facility code: 1204
    Result error code: 0

    Please review the summary.txt log for further details

    Friday, May 26, 2017 2:09 PM

All replies

  • The Windows account xxxx\xxxxx-a'; does not exist and cannot be provision
    ed as a SQL Server system administrator.

    First question is this a valid login?

    /SQLSYSADMINACCOUNTS -- Provide account name which has admin rights in sql server.

    setup.exe /q /ACTION=RebuildDatabase /INSTANCENAME=MSSQLSERVER /SAPWD="Strong SA Pwd" /SQLCollation=Latin1_General_CI_AS /SQLSYSADMINACCOUNTS="Windows Account that has sysadmin rights”

     

    /q – perform silent installation

    /Action – [RebuildDatabase ] Rebuilding the system databases to change the collation name

    /INSTANCENAME – Name of the instance the collation has to change

    -          If Default Instance then “MSSQLSERVER”

    -          If Named Instance “Named Instance Name”

    /SAPWD – Provide new password for SA login

    -          Enable SA Account if it Disabled setup with Strong Password.

    /SQLCollation – Provide the new collation name of SQL Server

    /SQLSYSADMINACCOUNTS – Provide account name which has admin rights in sql server.

    Thanks,


    Thanks, Satish Kumar. Please mark as this post as answered if my anser helps you to resolves your issue :)


    Friday, May 26, 2017 2:17 PM
  • Hi There,

    you need to know was your SQL server is in mixed mode or Windows authentication only. if it is windows authentication only then sapwd key will not work.

    some corrections to your syntax:

    setup /ACTION=REBUILDDATABASE /QUIET /INSTANCENAME=MSSQLSERVER /SQLSYSADMINACCOUNTS="xxxx\xxxxx-a"; "yyyyyy\yyyyyy"; "zzzzzz\zzzzzzzzz"; /SAPWD=xxxxx

    note: if it is windows authentication then you need to use account name only no password required.

    and also this account should have direct log in account in the sql server. if this account belongs to any group you should use that group name instead of the account name.

    Good luck

    Kumar

    Monday, May 29, 2017 12:22 AM
  • Hi Maggie,

    I see syntax error here. You’d need to remove ‘;’ from you command and separate sysadmin by using a single space:
    /SQLSYSADMINACCOUNTS="xxxx\xxxxx-a" "yyyyyy\yyyyyy" "zzzzzz\zzzzzzzzz"

    If you have any other questions, please let me know.

    Regards,
    Lin

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Shanky_621MVP Wednesday, May 31, 2017 6:37 AM
    Tuesday, May 30, 2017 8:06 AM