none
File System Task fails while copying the directory on the server RRS feed

  • Question

  • Error: 0xC002F304 at File System Task Create Subfolders, File System Task: An error occurred with the following error message: "There is not enough space on the disk. ".

    I am getting the above error in my SSIS package. I am using the file system task to create a new folder and within that new folder I am copying the whole directory (Existing) into this folder. I am creating the new folder by using a variable to create that folder within my file task expression.

    So the file task creates a new folder and copy a few files from the existing directory and then throws an error to say not enough space. The files are in xlsx format around 300 files. file size under 5 mb for all 300 files.

    I can do this with xls format but I am not able to do it by xlsx format.

    Tuesday, September 17, 2019 3:45 PM

Answers

  • Hi minhalraffat,

    Error message: "There is not enough space on the disk"
    This error means the local disk is used up in the SSIS integration runtime node. Check whether your package or custom setup is consuming a lot of disk space:

    If the disk is consumed by your package, it will be freed up after the package execution finishes.
    If the disk is consumed by your custom setup, you'll need to stop the SSIS integration runtime, modify your script, and start the integration runtime again. The whole Azure blob container that you specified for custom setup will be copied to the SSIS integration runtime node, so check whether there's any unnecessary content under that container.

    Please refer to here.

    Best Regards,

    Mona


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by minhalraffat Wednesday, September 18, 2019 2:48 PM
    Wednesday, September 18, 2019 8:31 AM

All replies

  • Hi minhalraffat,

    The error message is very explicit: "There is not enough space on the disk."

    You need to delete not needed files and free some room on the target drive.

    Tuesday, September 17, 2019 3:53 PM
  • Hi minhalraffat,

    The error message is very explicit: "There is not enough space on the disk."

    You need to delete not needed files and free some room on the target drive.

    Yeah, But if I am just copying these same files by just pasting in that particular folder it allows me to do that. So there is no issue with the disk space.
    Tuesday, September 17, 2019 4:30 PM
  • Hi minhalraffat,

    Is it possible that the SSIS File System Task is trying to copy to some other location, not the one that you are checking the storage room.

    Please share a screen shot for both, File System Task settings and File Explorer.


    Tuesday, September 17, 2019 5:29 PM
  • Hi minhalraffat,

    Error message: "There is not enough space on the disk"
    This error means the local disk is used up in the SSIS integration runtime node. Check whether your package or custom setup is consuming a lot of disk space:

    If the disk is consumed by your package, it will be freed up after the package execution finishes.
    If the disk is consumed by your custom setup, you'll need to stop the SSIS integration runtime, modify your script, and start the integration runtime again. The whole Azure blob container that you specified for custom setup will be copied to the SSIS integration runtime node, so check whether there's any unnecessary content under that container.

    Please refer to here.

    Best Regards,

    Mona


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by minhalraffat Wednesday, September 18, 2019 2:48 PM
    Wednesday, September 18, 2019 8:31 AM