Error 193 received when trying to create an ODBC Connection using the SQL Server 2008 r2 Native Driver


  • I recently had the SQL Server 2008 R2 Client installed on my Windows XP laptop.  Ever since, when I try to create a new System DSN connection in the ODBC Administrator using the SQL Server 2008 Native Driver (v10.0 is what shows up in the ODBC Administrator) the process fails with "The setup routines for the SQL Server Native Client 10.0 ODBC Driver could not be loaded due to system error code 193".  Everything that I've been able to find out about this system error suggests that this problem is caused by an error in the way the driver was registered when it was installed (that it was registered as 64 bit when it is really the 32 bit version or vice-versa).  Is there an easy registry correction that will fix this problem?
    Tuesday, January 10, 2012 11:44 PM


  • Hi ElkinsEcon,

    Regarding to your description, seems the installation of the driver mis-registered a 64 bit driver but it is a  32 bit or vise-versa version. As the ODBC driver listing is determined by registry keys that are set on installation of the driver, it is likely that the driver installer has a fault which is causing it to be mis-registered with ODBC.

    Please try to load either a 32 bit driver from the 64 bit version (C:\windows\system32\odbcad32.exe) or trying to load a 64 bit driver from the 32 bit version (C:\windows\syswow64\odbcad32.exe).

    Additional if you build and then run an application as a 32-bit application on a 64-bit operating system, the workaround is try to create the ODBC data source by using the ODBC Administrator tool in %windir%\SysWOW64\odbcad32.exe. To indicate the type of DSN, you can add "_32" to the 32-bit user DSNs and "_64" to the 64-bit user DSNs.

    More information, please refer to The 32-bit version of the ODBC Administrator tool and the 64-bit version of the ODBC Administrator tool display both the 32-bit user DSNs and the 64-bit user DSNs in a 64-bit version of the Windows operating system

    Regards, Amber zhang
    • Marked as answer by Stephanie Lv Tuesday, January 17, 2012 8:00 AM
    Thursday, January 12, 2012 3:29 AM