none
Reporting Services Add-in Installation Error

    Question

  • I have tried several times to get the Reporting Services Add-In to install.  It seems as if everything is going along well except when the installation gets to "Removing Backup" files it hangs and then completely uninstalls the product.  Moreover, the event log simply notes "installation failed".  Has anybody else encountered this?  Thanks in advance for any help.

    Sunday, April 29, 2007 7:04 AM

All replies

  • Yeah I get exactly the same thing - "Removing backup files" just sits there.  Hasn't uninstalled the product yet, maybe I'm too impatient Smile

     

    When I check the activity, the HCINSTAL (which I guess is the right process) is active and consuming CPU, but apart from that nothing... I rebooted the server just in case, and though it seems to think the product is installed I'd like to get a clean install!

    Sunday, May 06, 2007 12:14 PM
  • Am I assuming correctly that this is wrt running SharePointRS.msi? If yes, then the SharePointRS.msi creates a log file in the Temp folder - <Drive>:\Documents and Settings\<user_name>\Local Settings\Temp\RS_SP_<number>.log file 

     

    Could you provide contents of the RS_SP_<number>.log file that corresponds to when you got the error?

     

    thanx,

    Prash  

    Tuesday, May 15, 2007 8:56 PM
    Answerer
  • I am having the exact same problem...This is the error I get from the RS log file!

     

    The web configration file, C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\config\webconfig.dlc.xml, does not have element "configuration/configSections/sectionGroup[@name='SharePoint']" or it is invalid.


    Install error: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\stsadm.exe return error code: -1

     

     

    I opened the xml file and there is no section for configuration...
    Thursday, May 17, 2007 3:45 PM
  •  

    Same error. Eventually it finishes, but the webparts and associated actions are not registered in the site collections. (The Application management Reporting Services settings are available however).

     

     

    Friday, May 18, 2007 7:31 PM
  • I am getting the same error.  Any resolution on this?  It would be nice if the error would show what the config file should look like.  It knows the section is missing...so why not show how to fix it?
    Monday, May 21, 2007 7:09 PM
  • I was told by an MS rep to try two things, neither of which worked:

    1) re-download the add in

    2)

    RESOLUTION:
    ==============
    1. Run the .MSI from a command line with the following command:
    a. msiexec /I SharePointRS.msi SKIPCA=1
    2. Run the rscustomaction.exe file manually from a command line by running this
    command:
    a. %TEMP%\rscustomaction.exe -I
    b. It could be in a different directory underneath %TEMP% though as on
    Fredericks machine it was in the %TEMP%\2 directory.

     

    I was wondering if it could be caused by an underpowered server -- my server/laptop has 1GB of memory and I saw where the req was 2GB.  In any event, I get the same exact problem (hanging on the removing backup files), and at this point cannot get around it

    • Proposed as answer by fjonesjr_1999 Saturday, July 20, 2013 3:27 PM
    Wednesday, June 13, 2007 7:50 PM
  • It took my installation a long, long, long time to 'Remove Backup Files' but it eventually worked.

    The other important thing is to make sure you have set yourself up as a Site Collections Admin in Sharepoint for *all* the Site Collections. 

    When you're running the install, it is modifying the SharePoint site collection to add the new SSRS bits.

    Hope this helps.
    Wednesday, June 13, 2007 10:49 PM
  • The long time and HCInstall process you see during 'Remove Backup Files' are due to the RS Add-in installing RS help in all the languages supported in SharePoint in the various SharePoint Web Applications.

     

    We are considering updating the 'Remove Backup Files' setup UI to be more informative and less confusing in the Katmai timeframe.

     

    HTH,

    Prash

    Thursday, June 21, 2007 6:00 PM
    Answerer
  •  

    I have successfully installed the SQL Reporting Services  add-in for MOSS on a single server farm. However, on our medium farm dev environment, I can not "set server defaults" for reporting services under Central administration site.  I get the following error "An internal error occurred on the report server. See the error log for more details. ---> An internal error occurred on the report server. See the error log for more details. ---> Value does not fall within the expected range."   In addition, I get this same error in our Test Medium farm environment.  

     

      To make things worse, the web parts and the reporting content types do not install correctly in my iltest medium farm either for any site collection eventhough the log file in my temp directory states their were installed and activated.    I have deactivated the feature report server and uninstall it now several times after the repair and removal from add remove programs did not fix the issue. 

     

    Any ideas on how to fix the DEV error and then ge the Test enivronment to install correctly.  I am wondering if their is an issue with using this in a medium farm scenario with 2 front-end web servers. 

    Thursday, August 02, 2007 12:32 AM
  • RESOLUTION:
    ==============
    1. Run the .
    MSI from a command line with the following command:
    a. msiexec /I
    SharePointRS.msi SKIPCA=1
    2. Run the rscustomaction.exe file manually from a command line by running this
    command:
    a. %TEMP%\rscustomaction.exe -I
    b. It could be in a different directory underneath %TEMP% though as on
    Fredericks machine it was in the %TEMP%\2 directory.

     

    I have tried this solution and it worked perfectly.

    BIG THANKS.

    Wednesday, August 15, 2007 12:42 PM
  • who can resolve it?I saw the same error!

    Friday, August 17, 2007 7:13 AM
  • When you run the command line for msiexec (resolution outlined by henkyck), make sure you have changed the working directory to be the folder where the SharePointRS.msi exists.

     

    This was the only way we were able to get the installation to work successfully. 

    Friday, September 14, 2007 5:07 AM
  •  

    I was able to run the command, but i still get this error:

     

    Installing Report Server feature.
    SSRSCustomActionError: SharePoint is installed, but not configured.

    Thursday, August 07, 2008 3:15 PM
  • Can you please clarify whether you are seeing this error when running the msiexec or rscustomaction.exe command? Is the user running the command is part of the local adminitrators group? Additionally, do you see any output in the eventviewer log file when you get this SSRSCustomActionError?  

     

    HTH

    Prash

    Monday, November 03, 2008 6:00 AM
    Answerer
  • I see the same error message. Here is my test deployment environment. All servers are running on a local Hyper-V setup for testing and is a mirror of a deployment in the field.

     

    1. WFE1 - Windows 2003 Enterprise x64. This is the main server in the SharePoint Farm and is a web front end. It is connected to DB1 for it's database.

     

    2. DB1 - Windows 2003 Enterprise x64 with SQL 2005. This is currently hosting a number of databases, including all the SharePoint databases.

     

    3. WFE2 - Windows 2008 Enterprise x64 with SQL 2008.

     

    The current plan is to migrate the web front end from WFE1 to WFE2. I have successfully managed this part of the deployment on my testing rig. WFE1 was then removed. Which leaves me with DB1 and WFE2.

     

    What we want to achieve now is to run Analysis + Reporting Services on WFE2, hooked up to the local SQL 2008 instance. However, we want to leave the content databases on SQL 2005 if at all possible and have SharePoint continue to use that.

     

    I am currently using domain accounts and all applicable permissions have been assigned as far as I can tell.

     

    When I attempt to install rsSharePoint.msi on WFE2 the installation proceeds normally until it reaches the Removing Backup Files stage. At that point it rolls back the installation and fails to install.

     

    If I run rsSharePoint.msi with logging enabled it returns:

     

    Action 17:21:00: RSSP_CAInstallLHorn_64.
    Action 17:21:01: RollbackCleanup. Removing backup files
    CA MSG : Running RSCustomAction
    CA MSG : Launching C:\Users\DEV~1.PAS\AppData\Local\Temp\rsCustomAction.exe with command line parameter /i
    CA MSG : rsCustomAction.exe failed to configure, Error code is: 1
    Action 17:21:01: Rollback. Rolling back action:
    Rollback: RSSP_CAInstallLHorn_64

     

    Then I navigate to the temp folder and open the RS_SP_*.log file. Inside this file I see a different error message.

     

    "SSRSCustomActionError: SharePoint is installed but not configured"

     

    I have not been able to make it work past this point yet, however. SharePoint is installed and it is configured. I can access Central Administration and navigate through everything and use it as per a normal deployment. The demonstration site is up and running and can be used from external clients.

     

    I've tried repeating the installation as a Domain Administrator but that made no difference. I've tried launching it from an Administrative command prompt. In all cases the user is a member of Local Administrators.

     

    I've also tried running with the SKIPCA=1 option, but that refuses to run saying SharePoint is not installed.

     

    The things I will try next:

     

    1. Shift the Default Database Server for SharePoint to SQL 2008.

    2. Setup SQL 2005 Reporting Services, install a web front-end on DB1 and join it to the farm.

     

    Neither of those will satisfy the customer requirements, but on a test rig it might just give me a few more insights into what the problem is. But, I'm still at a bit of a loss at the moment, so if anybody has any ideas I'd appreciate them.

    Thursday, November 20, 2008 1:28 AM
  • Well, I seem to have fixed it but I don't know how. Yet. I had to roll back to an earlier snapshot before I

    started having problems. Then it had the problems running from the installer, but when I opened an elevated command prompt and ran:

     

    msiexec /i rsSharePoint.msi SKIPCA=1

    cd\

    cd %TEMP%

    rsCustomAction /I

     

    it worked and ran all the way through. Now to configure it and get through initial testing of the system.

    Thursday, November 20, 2008 7:40 PM
  • I was getting the same errors on my Sharepoint Farm, since un-install re-install was not an option I performed the following options:

     

    1. Logged on to the server with the Farm Administrator Account
    2. Using SQL 2008 - Ensure Reporting Services installed (Not the Add-in, mine was not) - this may also relieve the "does not have permissions" or the "Invalid Name Space" errors too as I have SQL 2005 also installed
    3. Configure the Reporting servcies using Start >> Programs >> Microsoft SQL Server 2008 >> Configuration Tools >> Reporting Services Configuration Manager (This is important as the add-in needs something to attach to...)
    4. Double Check Settings to ensure no errors
    5. Install Add-in using the CLI (Run 'cmd' with Admin permissions) with the following command :
      1. msiexec /i rsSharePoint.msi SKIPCA=1

    6. Go through the installation screens...

    7. In your cmd window from step 5, type the following commands:

      1. cd \

      2. cd %TEMP%

      3. rsCustomAction /I

    8. If you get a command not found error then more than likely you did not run cmd with Admin Permissions

    9. You should now be ready to go...

    Since everyones installation may differ from mine I thought I would just post what I did and hope it helps someone else out Smile

     

    Good Luck!

    Thursday, December 04, 2008 5:57 PM
  • Is there a solution to this?

    "The web configration file, C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\config\webconfig.dlc.xml, does not have element "configuration/configSections/sectionGroup[@name='SharePoint']" or it is invalid."

    I get the same error.
    Tuesday, December 29, 2009 9:09 PM
  • It seems to be a comment Text in your CA web.config file, remove the comment text from all your Web.config files and It would not Rolling back the installation of RS.
    Wednesday, May 18, 2016 4:09 AM