locked
The Service Broker endpoint is in disabled or stopped state RRS feed

  • Question

  • Hi,

    We have 2 nodes SQL 2016 AG, laatly we get lots of messages on the primary node that syas:

    

    The Service Broker endpoint is in disabled or stopped state.

    We did not had this message before and we van access the AG from its listener.

    Any idea why suddenly we start to getting this error?

    Thanks


    Shahin

    Wednesday, March 25, 2020 11:47 AM

All replies

  • Hello Shahin,

    The message will show when AlwaysOn availability group Listener is created and SQL Server binds the Listener’s IP dynamically. There is no method to suppress the message. These messages are informational message and do not cause any harm and can safely be ignored.

    Here is the similar blog you can refer to: The Service Broker endpoint is in disabled or stopped state in Always on Availability Groups

    And you also can feedback this issue on this website:https://feedback.azure.com/forums/908035-sql-server/suggestions/32907967-alwayson-the-service-broker-endpoint-is-in-disab, This site will serve as a connecting point between you and Microsoft. The more people feedback and vote up this issue, the more likely Microsoft is to fix it.

    Hope it will help.


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Thursday, March 26, 2020 5:43 AM
  • Hi Dawn,

    Thanks for your reply,

    What I dont understand is why we start to get this message just about a week ago? I mean we dont see this message in the SQL logs of last week!! and the AG is already 5 month operational.

    Thanks


    Shahin

    Thursday, March 26, 2020 8:28 AM
  • Hi Shahin,

    Maybe you or someone did some changes lead to this log information. It's hard to recognize the specific changes.

    Changes in the availability group listener has created an availability group listener at first , was that the resource is Online to Offline including the Dynamic DNS Update performed every 24 hours and that the various properties of the cluster resource (dependency , policy, quality policy, etc.) change all included .
    The design of the machine by the cluster service availability group listener every 24 hours for DNS updates to occur on Network Name This causes the logs will be written to Error log.

    Unfortunately, there are lots of people annoyed by this log information. However you won't experience any issues as a result of the message, just ignore it and let it go.

    Best Regards

    Dawn


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 26, 2020 8:58 AM
  • Hello Shahin,

    Here i found a blog mentioned the solution to stop that avalanche of useless messages: apply following script on a SQL Server, where you have Availability Groups and experiencing the issue:

    CREATE ENDPOINT [SSBEndpoint] 
        STATE = STARTED 
        AS TCP  (LISTENER_PORT = 4022, LISTENER_IP = ALL ) 
        FOR SERVICE_BROKER (AUTHENTICATION = WINDOWS);

    More detail, you can refer to ERRORLOG flooded with "Service Broker endpoint" messages

    Hope it will help.

    Best Regards

    Dawn


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 26, 2020 9:25 AM
  • Problem has been resolved, our issue was with some DNS settings

    Shahin

    Tuesday, March 31, 2020 11:25 AM
  • I am so glad to hear that you have resolved your issue. Please mark the solution as answer. This can be beneficial to other community members reading the thread.
    In addition, if you have another questions, please feel free to ask.
    Thanks for your contribution.

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 1, 2020 6:40 AM