locked
Slow Sql Server Management Studio 2012 responses RRS feed

  • Question

  • Hy, 

    I'm using Sql Server Management Studio 2012 on my Win 7 x64 and in the last time it is slow, slow response when i try to edit row in table (right click and edit on table). If you know what to do i would appreciate it!

    Best regards.


    • Edited by ivanmarkic Friday, January 11, 2013 2:01 PM
    Friday, January 11, 2013 2:00 PM

Answers

  • Hi,

    Check performance of a different db or sample/exmaple db available on same system. Seems like problem with DB/indexing.

    Also apply latest service packs of SQL Server and Windows 7.

    Use following query.

    select * from sys.dm_os_wait_stats
    order by wait_time_ms desc

    you can check is to many wait stats

    For  sys.dm_os_wait_stats results check following links

    http://blog.sqlauthority.com/2011/02/03/sql-server-dmv-sys-dm_os_wait_stats-explanation-wait-type-day-3-of-28/

    http://msdn.microsoft.com/en-us/library/ms179984.aspx



    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Waqas

    MS(SPM), MS(E&F), MCP, MCT, MCTS, MCITP, MCSE, MCPD, MCSD, MCDBA , Author
    Twitter: @waqas8777
    Linked In: http://www.linkedin.com/in/waqasm1



    • Edited by Waqas M Tuesday, January 15, 2013 1:43 PM
    • Proposed as answer by Waqas M Wednesday, January 23, 2013 3:44 AM
    • Marked as answer by Maggie Luo Sunday, January 27, 2013 4:49 PM
    Tuesday, January 15, 2013 6:49 AM
  • Hi int,

    Any progress?

    Open SQL Server Management Studio, in the Object Explorer, right-click the server and you could see the Memory and Processors. Have you assign the enough memory and processors to SQL Server?

    Please use System Monitor to monitor the resource usage in SQL Server.

    Monitoring Resource Usage (System Monitor): http://msdn.microsoft.com/en-us/library/ms191246(v=sql.105).aspx.

    Thanks.


    Maggie Luo
    TechNet Community Support

    • Marked as answer by Maggie Luo Sunday, January 27, 2013 4:49 PM
    Tuesday, January 22, 2013 8:53 AM

All replies

  • Hi int,

    Make sure the memory and processor are enough for the SQL Server. Please also apply the Windows 7 Service Pack 1.

    Thanks.


    Maggie Luo
    TechNet Community Support

    Sunday, January 13, 2013 5:12 PM
  • Hi, 

    Everthing is ok with my computer. It is also problem on computer of my colleague's. We have 6 gb ram, core i3 proc, .... 

    Sunday, January 13, 2013 6:27 PM
  • Hi,

    Check performance of a different db or sample/exmaple db available on same system. Seems like problem with DB/indexing.

    Also apply latest service packs of SQL Server and Windows 7.

    Use following query.

    select * from sys.dm_os_wait_stats
    order by wait_time_ms desc

    you can check is to many wait stats

    For  sys.dm_os_wait_stats results check following links

    http://blog.sqlauthority.com/2011/02/03/sql-server-dmv-sys-dm_os_wait_stats-explanation-wait-type-day-3-of-28/

    http://msdn.microsoft.com/en-us/library/ms179984.aspx



    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Waqas

    MS(SPM), MS(E&F), MCP, MCT, MCTS, MCITP, MCSE, MCPD, MCSD, MCDBA , Author
    Twitter: @waqas8777
    Linked In: http://www.linkedin.com/in/waqasm1



    • Edited by Waqas M Tuesday, January 15, 2013 1:43 PM
    • Proposed as answer by Waqas M Wednesday, January 23, 2013 3:44 AM
    • Marked as answer by Maggie Luo Sunday, January 27, 2013 4:49 PM
    Tuesday, January 15, 2013 6:49 AM
  • Hi int,

    Any progress?

    Open SQL Server Management Studio, in the Object Explorer, right-click the server and you could see the Memory and Processors. Have you assign the enough memory and processors to SQL Server?

    Please use System Monitor to monitor the resource usage in SQL Server.

    Monitoring Resource Usage (System Monitor): http://msdn.microsoft.com/en-us/library/ms191246(v=sql.105).aspx.

    Thanks.


    Maggie Luo
    TechNet Community Support

    • Marked as answer by Maggie Luo Sunday, January 27, 2013 4:49 PM
    Tuesday, January 22, 2013 8:53 AM
  • I experienced the same.

    The problem was solved in SSMS by choosing “Named pipes” as “network protocol” in the options menu.

    • Proposed as answer by Nikola Pepic Thursday, October 3, 2013 12:26 PM
    Tuesday, September 17, 2013 8:55 AM
  • I found this solution to be helpful. I've had slow response from SSMS 2012. I've tried editing hosts file, disabling IPv6...to no avail.
    I'd like to add that I've applied all the available windows updates related to SQL 2012. Finally, switching to Named pipes did the trick. The response now is virtually realtime...
    Thursday, October 3, 2013 12:26 PM
  • Can you be a little more specific?  If I open SQL Server Configuration Manager, there are 3 option nodes where you can select Named Pipes:

    1. SQL Native Client 11.0 Configuration (32bit)/Client Prototcols

    2. SQL Server Network Configuration

    3. SQL Native Client 11.0 Configuration/Client Prototcols

    In options 1 and 3, the choice is enabled/disabled and "Order"

    In option 2, the choice is just enabled/disabled

    In my current configuration, Named Pipes is enabled and set as Order=3 in options 1 and 3, and set to "Disabled" in option 2.

    Also, do you have to restart SQL Server after changing options?

    Thanks

    Ron


    • Edited by rsaritzky2 Tuesday, November 5, 2013 10:09 PM
    Tuesday, November 5, 2013 10:07 PM
  • Ron,

    Did you find any answer for your query?

    Can some one tell me how to choose “Named pipes” as “network protocol” from the options menu of SSMS in SQL server 2012 ?

    Syed

    Sunday, December 22, 2013 6:47 AM