none
The datasource , 'db name', contains an ImpersonationMode that that is not supported for processing operations TABULAR, NOT MULTI RRS feed

  • Question

  • I am getting this error after changing all my connections to a new server. Searching the error always takes me to MDX Multidimensional problems, I am developing a Tabular model in VS2015 for a 2012 server. So there is no inherit...

    It has worked up until the source database needed to be changed. Now I get that error. This happens all the time and it seems like the only fix is to delete my project and create a new one and import the model from the server.

    Uggg.

    Thursday, January 14, 2016 10:26 PM

Answers

  • I found out that I had to switch the providers to be able to reset the impersonation mode. No matter what I did it would not let me change it from the ad service account I had created to use my own credentials. It would let me enter my credentials and test them. But it would always revert back to the previous account.
    Tuesday, January 19, 2016 3:51 AM

All replies

  • Hi Uggg,

    According to your description, you need to change the connection of you SQL Server Analysis Services tabular model, right?

    In a tabular model, we can change the connection in Model menu. In SQL Server Data Tools (SSDT), click the Model menu, and then click Existing Connections. Select the data source connection you want to modify, and then click Edit. In the Edit Connection dialog box, click Browse to locate another database of the same type but with a different name or location.

    I have tested it on my local environment, we cannot reproduce this issue. In you scenario, please ensure that the operations are correct, please refer to the link below to see the details.
    https://msdn.microsoft.com/en-us/library/gg492147.aspx

    If this is not what you want, please provide us more information, so that we can reproduce this issue and make further analysis.

    Regards,


    Charlie Liao
    TechNet Community Support

    Friday, January 15, 2016 5:30 AM
    Moderator
  • I found out that I had to switch the providers to be able to reset the impersonation mode. No matter what I did it would not let me change it from the ad service account I had created to use my own credentials. It would let me enter my credentials and test them. But it would always revert back to the previous account.
    Tuesday, January 19, 2016 3:51 AM
  • I seem to be having the same issue. I'd appreciate your help. What do you mean by "the providers"? The providers of what?
    Thursday, February 9, 2017 1:56 PM
  • I changed it to below and the issue resolved. I thought to mention it here so that it is helpful to others:

    Microsoft SQL Server 2008 and later OLE DB Provider for SQL Server, SQL Server Native Client OLE DB Provider, .NET Framework Data Provider for SQL Client

    Reference:

    https://docs.microsoft.com/en-us/sql/analysis-services/tabular-models/data-sources-supported-ssas-tabular


    If this post answers your query, please click "Mark As Answer" or "Vote as Helpful".

    Friday, August 18, 2017 2:19 PM