none
SQL Server 2008 stopped being accessible Remotely while installing Visual Source Safe 2005 RRS feed

  • Question

  • Help!!
    I have a SQL Server 2008 R2 that is running on Windows Server 2008 and configured on a non standard port number (50000). I'm not sure if that is relevant, but I thought I should let be known
    I've been connecting to it remotely from my computer and everything seems to be fine.
    But when I was installing Visual Source Safe 2005, it suddenly stop being accessible remotely.

    The steps:
    1. I installed VSS into the server
    2. I created a Directory Based VSS Database
    3. I shared the VSS database Folder on the network and to a few users
    Then my boss told me he couldn't access the database

    The error message that I've been getting from my computer's SQL Management Studio, trying to connect to the server is:
    "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060)"

    I checked:
    I can connect to SQL Server locally through SQL Server Management Studio
    I still can connect through FTP
    I still can connect through Remote Desktop
    SQL Server Network Configuration | Protocols | TCP/IP is enabled
    SQL Server Service | SQL Browser is running and Log on as Local Service
    Firewall | Inbound Rule is set  (I did  not change anything in the firewall)

    Can anyone help me diagnose and resolve this problem?

     

    Roy

    Thursday, December 16, 2010 6:10 AM

Answers

  • Hi Chaitanya,

    I solved the problem myself.

    I checked if the firewall is causing the problem by disabling it for a minute and my SQL Server Management Studio worked. So it is a firewall problem.

    Then I checked the firewall rule for it and the properties looked correct but it wasn't working, so I recreated the rule again with a different name and it worked.

     

    Thursday, December 16, 2010 11:52 AM

All replies

  • Check the following:

    • From the Remote machine, try to do a Telnet to the server on the port 50000. If this is failing, then probably the port 50000 might be blocked.
    • Try to force the TCP/IP protocol for connecting to the Server from the remote machine. You can use tcp:ServerName,50000 and check the connectivity from SSMS remotely.
    • You can also try forcing NamedPipe protocol, if that is enabled on Server.
    • On the remote machine, check if there are any aliases created. Goto Start>Run>cliconfg. This will open Client Network Utility. On the aliases tab, check if there are any aliases created for this server. If there are, try to delete them and check the connectivity.

    http://technet.microsoft.com/en-us/magazine/dd450973.aspx [Configure Remote Server Connections]

    http://social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/97a0ddf7-d23e-4723-b49f-463943180172 [How to Configure Remote Connections To SQL Server 2008 R2 Express]

    Hope this helps..


    Chaitanya
    Thursday, December 16, 2010 7:53 AM
  • Hi Chaitanya,

    I solved the problem myself.

    I checked if the firewall is causing the problem by disabling it for a minute and my SQL Server Management Studio worked. So it is a firewall problem.

    Then I checked the firewall rule for it and the properties looked correct but it wasn't working, so I recreated the rule again with a different name and it worked.

     

    Thursday, December 16, 2010 11:52 AM
  • Hi,

    If the SQL Server instance is configured to use dynamic ports, its TCP/IP port may be changed after restarting each time. So, you may need to reconfigure Windows Firewall each time. Besides, please add UDP 1434 port that SQL Server Browser Services is listening on to Windows Firewall Exception as well.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 17, 2010 3:38 AM
    Moderator