none
Need Setup Help: "The ReportServerVirtualDirectory element is missing"

    Question

  • I am getting setup problems with Reporting Services 2005.

    When I try to connect through SQL Server Management Studio, the browser in the connect dialog can see the Reporting Services 2005 instance, but when I try to connect, I get an error dialog with the message, "The Report Services instance could not be found (Microsoft.SqlServer.Management.UI.RSClient)"

    I manually setup ReportServer and ReportManageer virtual directories in IIS to point to the corresponding directories within the Reporting Services installation. Was I supposed to do this manually? Was the installer supposed to set this up?

    Anyway, when I browse to http://localhost/ReportServer/ I get:

        *  The report server has encountered a configuration error. See the report server log files for more information. (rsServerConfigurationError)
              o Access to the path 'C:\Program Files\Microsoft SQL Server\MSSQL.4\Reporting Services\ReportServer\RSReportServer.config' is denied.

    When I browse to http://localhost/ReportManager/ I get:

    An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.

    Anyone know what I'm doing wrong and what I can do to fix?
    Tuesday, September 19, 2006 3:26 PM

Answers

  • RS 2005 comes with a Configuration Tool that creates the virtual directories, connects to the repository, updates the config files etc...

    Find it at Start -> All Programs -> Microsoft SQL Server 2005 -> Configuration Tools -> Reporting Services Configuration

    Tuesday, September 19, 2006 5:23 PM

All replies

  • RS 2005 comes with a Configuration Tool that creates the virtual directories, connects to the repository, updates the config files etc...

    Find it at Start -> All Programs -> Microsoft SQL Server 2005 -> Configuration Tools -> Reporting Services Configuration

    Tuesday, September 19, 2006 5:23 PM
  • Bingo. That did it. Thanks Adam!
    Tuesday, September 19, 2006 7:48 PM
  • Hi, can you help me with this?

    I still having this error and when I go to "Reporting Services Configuration" everything is OK with a green check, but the "Report Manager Virtua Directory" still appears with a Red X indicating that is "Not Configured", I push the New Button, and I get no errors in the "Task Status", it says the virtual directory was created and asigned, but the Red X is still there.

    I later delete the vortual directory in the IIS Console and created, but is the same, I already tried changing the name os the virtual directory wne I press the new button, but nothing seems to work.

    I've searched for this, but this is the only sites that appears.

    Can you help me?

    If you need something like a screen shot, just mail me!

     

    Thanks!

    Monday, January 29, 2007 2:43 AM
  • hi Abasilis.

    Look at "Report Server Virtual Directory" above the "Report Manager Virtual Directory". That's probably not configured which is why you have that red x. Set that up and the red 'x' will go away.

    Wednesday, March 14, 2007 4:42 PM
  • Yes, you are right.  I have the same problem and it is fixed now.  Thanks.
    Friday, April 27, 2007 1:06 AM
  • Well, this is not the problem. but I resolved, because I formatted the Laptop because I had another problems with my sound card and my wireless network card. Problem solved, but I have to reinstalled 3 times, because each time appears a diferent error. That happens when you use a free product, because I installed SQL Server 2005 and in the first installation of the report services everythig works fine.

     

    Thanks anyway..

    • Proposed as answer by ATECH AO Thursday, April 1, 2010 8:25 AM
    Friday, April 27, 2007 6:09 PM
  • Try looking in the file "C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\Reports\RSWebApplication.config"

     

    for this line:

      <ReportServerVirtualDirectory>????</ReportServerVirtualDirectory>

     

    Is there no text where the ????'s are? If there is text, is it the correct name for the ReportServer virtual directory?

     

    In my case, for some reason it was empty, there was no text where the ????'s are. When I filled in the text "ReportServer" (without the quotes) in that spot, then refreshed the browser-window that had the error "An error occurred while parsing the configuration file. The ReportServerVirtualDirectory element is missing.", the error went away and instead the normal Report Manager home web page showed up. In my case, no amount of playing with the configuration tool solved this, but this manual intervention did.

     

    Good luck.

    • Proposed as answer by Ken C. Lin Tuesday, June 23, 2009 1:41 AM
    Tuesday, May 1, 2007 4:48 PM
  • DanaLive,

     

    I had the same problem and added the text as you suggested to fix the problem.

     

    I also noticed right above the virtual directory tag is a URL tag. Does anyone know if this should be set as well? 

    Code Snippet
    <Configuration>
     <UI>
      <ReportServerUrl></ReportServerUrl>
      <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>
      <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>
     </UI>

     

     

    Thanks,

    Johnny

    Tuesday, May 22, 2007 7:04 PM
  • Brilliant, thank you!
    Friday, June 22, 2007 1:13 AM
  • This is just a pointer for the report manager to know where to look for the server, so if they're on different machines or of you are usiong HTTPS to secure the server you need to populate it, otherwise you shouldn't need to.
    Monday, July 2, 2007 1:15 PM
  • Thanks everyone for the information. However I still had a problem with getting Reporting Services to work. Here is what fixed it for me:

     

    Under Web Service Identity, Select the Drop Down for Report Server and Report Manager and change the Default AppPool to RS.Net.0AppPool.

     

    This corrected the errors I was having, hope this helps.

    Tuesday, July 3, 2007 2:10 PM
  • Changing the app pool has fixed the issue because it probably runs under a different identity to the original one i.e. an account that matches the rs service.
    Tuesday, July 10, 2007 10:52 AM
  • I'm also installing new and this fix also worked for me.  Man I'm glad I found MSDN.  I tried support.microsoft.com for this error and no luck.

    I suspect this problem originally occurred because I did the Report Server Configuration and IIS was not running.

    Wednesday, August 1, 2007 12:10 AM
  •  

    Thanks DanaLive!

     

    I had also the same problem; the GUI was showing all ok but the value was missing in the file.  Manual Fix did it for me also!

     

    Thanks!

     

    Daniel.

    Friday, November 9, 2007 1:41 PM
  • I had to also edit the RSWebApplication.config file in order to get it beyond the above error.  now I am getting the below dreaded error.

     

    Object reference not set to an instance of an object.

     

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
       Microsoft.ReportingServices.UI.GlobalApp.Application_AuthenticateRequest(Object sender, EventArgs e) +44
       System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64
    

    As you can see there appears to be a problem with my authentication.  If anyone could help it would be greatly appreciated.

     

    TIA

     

    John

    Friday, November 9, 2007 6:43 PM
    • Access to the path 'C:\Program Files\Microsoft SQL Server\MSSQL.4\Reporting Services\ReportServer\RSReportServer.config' is denied.

    Hey incase any of you cant fix up this problem using the suggestions provided by the feeds you can use the below mentioned steps, as these worked for me.
    • browse to the specified RSReportServer.config file . rightclick>>properties
    • go to the security tab and add a user by name <machinename>\ASPNET.
    • provide full access rights to the user and press OK
    • just refresh the default website and browse to the report server .
    • there you see the report server working fine.

    Cheers,
    Chandan.
    Friday, January 11, 2008 5:27 AM
  • Thank you very much for the solution. It seems that after resolving this problem there was no error message anymore

     

    Thursday, February 28, 2008 4:20 PM


  • I had the same issue after I had done the following

    • uninstalled a previous SQL and Report Server installaiton
    • checked for and removed any latent registry settings
    • checked for and removed any latent SQL directory folders
    • installed SQL with reporting services ( I did note that the installation would not let me use default setting for reporting services as it had done before because the files where already in use. )


    That last item turned out to be the issue.  IIS still had references to the Reports and ReportServer under web sites in IIS Manager.  I deleted these and then the Reporting Configuration Manager worked like a charm.  Then I was able to pull up what I would expect to see in the browser.
    Tuesday, March 4, 2008 2:10 AM
  • Thanks a Million Danalive!!!!!

     

    Spent the last two days on Server 2008 64 bit, 2005 SQL 64 bit trying to get my ReportServer/Reports HTTP page to come up (frustrating to say the least). Found the link to this page:

    • Followed your instructions as listed
    • Saved the file
    • Refreshed my HTTP page
    • BAM!  Reporting services home page.
    • Your a life saver!

    Thanks again!

     

    wyatt2112

    Saturday, March 15, 2008 3:42 PM
  • Great Post
    fixed my issue!

    Thanks
    Wednesday, March 26, 2008 12:07 AM
  • I wanted to thank TejasP,
    With that green check that is easy step to overlook.
    Thursday, April 3, 2008 2:01 PM
  • Adam, I had similar problem and adding the Virtual Directory in the config file helped. Now I can get to the Home of the Virtual Directory, but I am getting;

    "The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version."

    Note that I installed SQL 2005 and then applied SP2, before configuring Reporting Services.

     

    JK

    Friday, April 11, 2008 3:04 PM
  •  

    This worked for me also.

    I used local Database Server SQL server X64 standard edition and Report Server same edition, Windows 2003 SP2 X64 Enterprise.

     

    I deployed multiple Report Servers and very often that Reporting configuration services tool did the job right.

    Tuesday, April 15, 2008 11:08 AM
  •  

    Thanks DanaLive!  Worked for me as well!
    Friday, April 25, 2008 5:08 PM
  • Lookin the RSWebApplication.config for the "<ReportServerUrl>"

     

    It will look something like this

    <ReportServerUrl></ReportServerUrl>

     

    Change it to

    <ReportServerUrl>http://machinename/reportserver</ReportServerUrl>

    Note: Use your machine name do not use localhost.

     

    Attempt to load the page again; if it still fails ~ run iisreset; and try again.

    Saturday, May 3, 2008 4:47 PM
  • You may be right but in my case both are sitting on the same box and I still need to fill in the blank with the default name which is 'ReportServer':

    <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>

    ....a buggy XML but many thanks to you guys.

    Wednesday, May 21, 2008 8:41 PM
  • This solved my problem too. Config said all is well, but ReportServerVirtualDirectory element is missing appeared on the browser.  The RSWebApplication.config file had
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
    instead of
    <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>

    Thanks DanaLive
    • Proposed as answer by Crazycrist21st Tuesday, December 8, 2009 5:49 AM
    Friday, September 5, 2008 2:43 PM
  • Danalive,

    You are "The Man"
    Tuesday, February 10, 2009 6:12 PM
  • This solved my problem too. Config said all is well, but ReportServerVirtualDirectory element is missing appeared on the browser.  The RSWebApplication.config file had
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
    instead of
    <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>

    Thanks DanaLive

    This really works.
    Thanks Sir.
    Tuesday, December 8, 2009 5:49 AM
  • You just saved me hours/days of frustration! Your fix brought up my Report Manager Home Page without issue!

    I can't thank you enough!

    State of WA IT Employee

    Wednesday, March 31, 2010 6:46 PM
  • <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>

    that fixed my problem. Thanks!

    Saturday, October 30, 2010 3:12 PM
  • DanaLive, your solution fixed my issue.

    Thank you.

    Tuesday, December 21, 2010 7:28 PM
  • Thanks DanaLive and Johnny for further clarification. That works perfectly for me. Saved me 2 sleepless night.

     

    Thanks

    Psalm

    Wednesday, June 22, 2011 9:13 AM
  • Thank you a million DanaLIve - this was the issue for me. You saved me hours of work and much, much stress. Hurray for the internet, google and most of all those who use it. 
    Sunday, July 10, 2011 12:38 AM
  • thanks to DanaLive from me too

    That pesky green tick led me away from the correct path!

    cheers!

    Paul

    Wednesday, June 20, 2012 11:50 AM
  • Thanks DanaLive

    your suggestion fixed it for me!!

    Wednesday, December 12, 2012 12:25 AM