none
Stumped - how do you install SQL Profiler?

    Question

  • Hi everyone

    I've just installed SQL 2008 Express (I installed the express edition because I need support for user instances).

    Now I want to install SQL Profiler. I understand it doesn't come with SQL Express, so I've got the DVD for SQL Server 2008 Enterprise Edition. The problem is that whether I choose "New SQL Installation" or "Add Features to Existing Installation", there's no option to install SQL Profiler. The only client tools that appear in the installation screen are:
    - Business Intelligence Development Studio
    - Management Tools - Basic
    - SQL Client Connectivity SDK.

    SQL Profiler's got to be in there somewhere... tearing my hair out!

    Thanks

    Joe
    Saturday, October 18, 2008 4:37 AM

Answers

  • OK - I solved it:

    1. Uninstall SQL 2008 Express
    2. Run SQL 2008 Enterprise setup and install advanced client tools
    3. When it reports error 2203, return to step 2 and try again twice
    4. Reinstall SQL 2008 Express
    Sunday, October 19, 2008 8:14 AM

All replies

  • OK - I solved it:

    1. Uninstall SQL 2008 Express
    2. Run SQL 2008 Enterprise setup and install advanced client tools
    3. When it reports error 2203, return to step 2 and try again twice
    4. Reinstall SQL 2008 Express
    Sunday, October 19, 2008 8:14 AM
  • Thanks for posting the solution, as I probably wouldn't have taken the time to kick through to it myself otherwise.

    A couple things to note:
    • I was in the same state, but had to remove ALL traces of 'SQL anything' via 'Add or Remove Programs' before it worked for me
    • With the RTM version, I believe the 'advanced client tools' are known as 'Management Tools - Complete'
    • With this kind of hybrid installation, once Express is installed, things seem to be effectively "locked down".  That is, no other options are selectable to add to the SQL installation. So, if you wanted, say, the Integration Services tools (i.e., BIDS), it must be installed when running the Enterprise setup because it won't be a selectable option once Express is in place.
    Thanks again!
    T

    one fish, two fish, red fish, bluefish
    • Proposed as answer by ThereIsNoGod Sunday, June 14, 2009 2:54 AM
    Tuesday, January 6, 2009 5:51 PM
  • After going thru all these step i found the true solution...

    Remove the management tools basic feature alone... by going thru the uninstall sql server then selecting that feature alone to uninstall...

    After you uninstall "Management tools Basic" it will let you reinstall "Complete" the next time u run add features...

    I never tried it with express still on but i suspect it won't change since this is installed as a shared feature...

    Thanks Again! And here is where i give back ... till next time....

    This should be the absolute answer :)
    • Proposed as answer by ivadima Thursday, May 26, 2011 7:46 PM
    Sunday, June 14, 2009 3:00 AM
  • @ ThereIsNoGod: This didn't work for me. As Joe said, for me I had to completely uninstall the SQL engine itself first (I had installed the express version originally)
    Monday, November 9, 2009 2:18 PM
  • This is what worked for me:

    1. Went into Add/Remove Programs and did Change/Remove on SQL Server 2008 R2
    2. Chose "Remove"
    3. A bit further in, chose "Shared Features" then "Management Tools - Basic" and waited until completion.
    4. Ran Setup.exe and went to New Install....damn! only offered the Basic option.
    5. Chose it anyway, but could not reinstall because Visual Studio 2008 needed SP1.
    6. Downloaded that and ran it. Failed because it needed a Preparation Tool.
    7. Downloaded that and installed it.
    8. Installed SP1, which took ages.
    9. Ran Setup.exe again and this time it gave "Management Tools - Basic" and "Management Tools - Complete".
    10. Chose both, and it worked!
    Wednesday, September 22, 2010 9:06 AM
  • Hi,

    first, you need to 'upgrade' your SQL Server edition. You don't need to uninstall anything, just upgrade the edition.

    1) Maintenance / Edition Upgrade.

    2) Start adding new 'business' features like Profiler etc. 

     

    Regards,
    Lada

     

    Wednesday, November 10, 2010 4:05 PM
  • This last approach did not work for me. I had to uninstall everything like the others said.
    • Proposed as answer by GeneNaden Wednesday, July 6, 2011 2:46 PM
    Wednesday, July 6, 2011 2:34 PM
  • This worked great for me. I was upgrading from SQL Server 2008R2 Express to SQL Server 2008R2 Developer edition.
    Friday, August 5, 2011 6:30 PM
  • Hi guys,

     

    I successfully installed SQL Server Profiler 2008 R2 Profiler without uninstalling SQL 2008 R2 Express with the help of my colleague.

     

    To install, first make sure you have the Enterprise Edition DVD.

    run the setup.exe of the installer with these parameters:

     

    setup.exe /FEATURES=Tools /Q  /INDICATEPROGRESS  /ACTION=Install /INSTANCENAME=SQLSERVER2008R2Ent /BROWSERSVCSTARTUPTYPE=Automatic /AGTSVCACCOUNT=”NT AUTHORITY\NETWORK SERVICE”  /IACCEPTSQLSERVERLICENSETERMS
    


     where the value of "/INSTANCENAME" is equal to the instance name of the Server Instance that you wish you use.

     

    *i know i replied to an old thread, but i posted it here anyway to help the guys who'll later found this*


    http://randolfarevalo.blogspot.com
    • Proposed as answer by ran2k9 Wednesday, September 28, 2011 8:01 AM
    Wednesday, September 28, 2011 8:00 AM
  • This works for me, thank you!  Btw, this worked using a SQL Server 2008R2 Trial installer over my existing SQLExpress 2008R2 instance.  I thought for certain that MS would have disallowed that behavior... but it works.
    Friday, September 30, 2011 11:13 PM
  • Thanks ran2k9, that worked for me! BTW, I was told this upgrade would go smoothly, after years of contrary experience I still wanted to believe but correctly anticipated the crushing tedium...
    Monday, November 28, 2011 2:24 PM
  • Perfect - thanks, Randolf, worked for me.
    Wednesday, December 14, 2011 9:40 AM
  • This works for me, smart installation.
    Monday, July 16, 2012 8:52 AM
  • I like this solution.....
    Wednesday, November 21, 2012 4:26 PM
  • Thank you Ran2k9 that worked!
    Friday, December 28, 2012 9:22 PM
  • worked for me
    Wednesday, January 9, 2013 2:17 PM
  • This is really helpful. ran2k9 thanks a lot!

    • Edited by Bluezealot Saturday, February 16, 2013 5:33 AM
    Saturday, February 16, 2013 5:31 AM
  • Running it with the parameters as stated above worked for me!

    Thanks :)

    Christina

    Wednesday, June 19, 2013 9:03 PM
  • Still usefull info in 2014 ...

    This did not work with the /INSTANCENAME parameter - I was getting version mismatch errors. When I removed the /INSTANCENAME switch completely the install worked perfectly. This would not work through the install gui because of the version mismatch - feature options were disabled.

    Thanks for the help.

    Tuesday, August 26, 2014 5:23 PM