Can't debug SQL queries - receiving "Failed to start debugger" message


  • I'm trying to debug a SQL query with Juneau using Visual Studio 2010 SP1, but when I do, I get a an error message saying:

    "Failed to start debugger"

    Which is followed by a message that says:

    Unable to start program 'MSSQL:://<my database server name>/?/sys=0'.

    I'm using SQL Server 2008.  Has anyone else encountered this?

    Monday, August 01, 2011 3:17 PM


All replies

  • Hello Evan,


    For the error you are seeing, could you provide more details on what you did to start the debugging.


    Also, could you ensure that the user account under which VS is running has sysadmin privileges on SQL Server instance.




    Vikrant Arora

    Microsoft Corp.

    Monday, August 01, 2011 8:52 PM
  • Hi: I have the same issue:

    The error stated: Unable to access the SQL Server debugging interface. The VS debugger cannot connect to the remote computer. A firewall may be preventing communication via DCOM to the remote computer.

    Then when you press OK it shows:


    Unable to start program MSSQL://db server IP/?/=0


    The DB server machine has Farewall OFF.


    Thanks in advance!

    Wednesday, August 10, 2011 3:24 PM
  • We have been able to reproduce this issue in our product and will be fixing it in our upcoming releases.


    Unfortunately, there is no easy workaround for this issue that I can suggest. Could you see if the following works for you:

    1. Disable the firewall temporarily on the client machine

    2. Close all instances of VS. Ensure that no devenv.exe process is running in the task manager.

    3. Start a new instance of VS and see if debugging works now.


    I would be interested in hearing back on this issue. Do let me know if the above steps solves the issue.



    Vikrant Arora

    Microsoft Corp.

    Monday, August 15, 2011 10:07 PM


    I got the same error. I followed all your recommendations but I am still getting this error. Does it mean that there is no way for me to use Juneau?

    Wednesday, August 17, 2011 7:32 PM
  • DDB007 - your issue looks a little different from the original poster's; yours appears to be an issue unrelated to Juneau (but please correct me if you think otherwise). Few questions -

    1. Are you running VS/Juneau as Administrator on the client machine?

    2. Are you a system administrator on the remote computer?

    3. Can you debug against the remote computer from SQL Server Management Studio, on the same client machine as the one you're running VS/Juneau on?

    3. You did mention this but just to confirm, are the firewalls turned off on both the client and server machines?

    4. What are the operating systems on both machines?

    5. Have you checked your DCOM settings on the client machine? On Win7: Start -> Run -> dcomcnfg.exe -> Component Services -> Computers -> My Computer -> (right-click) Properties -> COM Security -> Access Permissions -> Edit Limits, make sure that ANONYMOUS LOGON has 'Allow' checked for 'Remote Access'. (Make sure NOT to uncheck anything that is currently checked)

    Sorry you're having trouble; hope this helps...


    Adi Unnithan | Software Design Engineer | SQL Server Developer Tools | Please mark the post as answered if it sufficiently answers your question
    Thursday, August 18, 2011 3:33 AM
  • DDB007,

    Since the time of this post, we have released SSDT CTP4, a new version of SQL Server Data Tools. This new release is available via our website here - In order to install SSDT CTP4, you must first remove SQL Server Developer Tools CTP3, Code-named "Juneau" from your machine. The steps for doing this can be found here -

    If you are still experiencing problems in this debugging space, please download SSDT CTP4 and see if your issues still exist when using this new version. Please let us know if you are still experiencing problems after updgrading, but if not, please mark this thread as answered!





    Adam Mahood Program Manager SQL Server Data Tools
    Wednesday, December 28, 2011 11:28 PM