The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Developing Universal Windows apps!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 locked
[UWP]Error : DEP6100 : The following unexpected error occurred during bootstrapping stage RRS feed

  • Question

  • Hi,

                 I'm trying to build for Universal Windows Platform. I have created new empty UWP C# Project in VS2015 and tried to run it on Windows Phone 10 Insider build Number 10581.

    In known issues of the release notes for this build mentioned that,

    => Deploying Silverlight apps through Visual Studio to your phone won’t work in this build. You can deploy UWP apps to your phone without any issues.

    But I'm getting the following error.

    Severity    Code    Description    Project    File    Line
    Error        Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.':
    SEHException - External component has thrown an exception.    App1        
    Severity    Code    Description    Project    File    Line
    Error        Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found.    App1

    Help out to solve this issue.

    Friday, October 30, 2015 12:21 PM

All replies

  • Download and install the emulator from https://dev.windows.com/en-us/downloads/windows-10-developer-preview

    Fixed the issue with deploying apps for me.

    Friday, October 30, 2015 12:31 PM
  • I get the same error when trying to deploy a universal app to my nokia 1020 build 10581.  the same app works fine in the emulators.

    text of output

    1>Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.': 
    1>SEHException - External component has thrown an exception.

    


    Tom

    Thursday, November 5, 2015 4:54 AM
  • I get the same error when trying to deploy a universal app to my nokia 1020 build 10581.  the same app works fine in the emulators.

    text of output

    1>Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.': 
    1>SEHException - External component has thrown an exception.

    


    Tom


    The same here, Lumia 1320, might be when be update to the RC it gets solved, but I preffer wait to the release version

    Juan Pablo G.C.

    Monday, November 9, 2015 10:56 AM
  • I faced the same problem with this configuration:
    Visual Studio 2015: 14.0.24627.00 Update 1 RC
    Phone OS: 10.0.10581.0
    Any attempt to deploy UWP app to my phone failed while deploying to emulators was ok. Reinstalling of SDK and emulators did not help me. Very frustrating!

    Fortunately, I was crazy enough to experiment more and these steps helped me. You can try too:
    1. Plug-in you phone to computer over USB cable.
    2. Open Device Manager from PC control panel.
    3. Open Portable Devices category and uninstall your phone device (right click, then uninstall).
    4. Open Universal Serial Bus devices category and uninstall all devices corresponding your phone (I had 3 such entries). Select the checkbox 'Delete the driver software for this device' where prompted.
    5. Unplug your phone from USB and then plug-in it back. The system will reinstall all necessary drivers and woohooo!!! Now Visual Studio can deploy to device again by pressing F5!!!
    P.S. There is no need to enable 'Device discovery' and 'Device Portal' on your phone.

    • Proposed as answer by Esword Thursday, January 14, 2016 8:46 AM
    Tuesday, November 10, 2015 8:53 PM
  • What version of Windows Desktop do you have? I am just with the desktop release version 10.240, might be that is the issue, because 4.- the checkbox does not appear, also I entered in the properties of the (3 entries) and uninstalls (tells that deletes the driver) but I do not think so (in this version I mean)


    Juan Pablo G.C.

    Thursday, November 12, 2015 8:44 AM
  • I get the same error when trying to deploy a universal app to my nokia 1020 build 10581.  the same app works fine in the emulators.

    text of output

    1>Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.': 
    1>SEHException - External component has thrown an exception.

    


    Tom


    I get the same error with my Lumia 640 after upgrade to 10581. Even uninstall the my phone and USB device, the error message still have.
    Thursday, November 12, 2015 4:11 PM
  • What version of Windows Desktop do you have?

    I have 10.10240 too. The checkbox is visible in second entry only, after you right-click and select 'uninstall'.
    Thursday, November 12, 2015 5:02 PM
  • I just tried your steps but (sadly) am still getting the same error

    Restoring NuGet packages...

    To prevent NuGet from restoring packages during build, open the Visual Studio Options dialog, click on the Package Manager node and uncheck 'Allow NuGet to download missing packages during build.'

    1>------ Deploy started: Project: ZenAwakenerUniversal, Configuration: Release ARM ------

    1>Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.':

    1>SEHException - External component has thrown an exception.

    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    I'm going to try to attach an image from Device Manager to compare to your result... but the gist is this

    1- plugin in phone

    2- open device manager

    3- remove "Old_1020" from the list of Portable Devices

    4- delete all three entries for Nokia Lumia 909 in Universal Serial Bus Devices

    5- rebooted with lumia 1020 disconnected

    6- plugged in the phone /USB and saw device manager showing exactly the same entries (did you show that on your machine?)

    -- ran my universal app to the Device and got the error shown

    I'll try your process again

    **I did NOT get a check box to remove the drivers from the system when I did the uninstall.  My system is acting like the drivers have not been removed....

    tom

    [update]-- I tried every way of removing the 1020 from the system that I could think of... it was clear that a complete reinstall of the device (Lumia 1020) had been done by my development machine.  However the result was the same.  I tried all developer settings on the phone... nothing changed.  The message that I'm getting is that the "device is already in use"... so VS can't connect to it.  As I said, I've tried everything I can think of to shutdown other connections to the phone.. to no avail.  This broke in the latest build 10581.  Please fix this in the next build.  I can't release my Universal Apps till I CAN TEST THEM ON HARDWARE... <sigh>


    Tom


    • Edited by tbink Thursday, November 12, 2015 6:46 PM new tests and results
    Thursday, November 12, 2015 6:09 PM
  • What version of Windows Desktop do you have? I am just with the desktop release version 10.240, might be that is the issue, because 4.- the checkbox does not appear, also I entered in the properties of the (3 entries) and uninstalls (tells that deletes the driver) but I do not think so (in this version I mean)


    Juan Pablo G.C.


    Where do you find the desktop release version?... I'm not finding that version #?

    Tom

    Thursday, November 12, 2015 7:08 PM
  • Just cmd and ver, I have updated now to desktop  Microsoft Windows [Version 10.0.10586] but the same

    Juan Pablo G.C.

    Thursday, November 12, 2015 7:18 PM
  • just checked (thank you)... my version is 10240 but I'm not going to update to 10586 since it didn't make any difference for you.

    Tom

    Thursday, November 12, 2015 7:44 PM
  • I did find this page (and made the changes stated:

    For Windows 10 desktop

    Use gpedit.msc to set the group policies to enable your device, unless you have Windows 10 Home Edition. If you do have Home Edition, you need to use regedit or PowerShell commands to set the registry keys directly to enable your device.

    Dn706236.wedge(en-us,WIN.10).gifUse gpedit to enable your device

    1. Open a cmd prompt with administrator privileges.
    2. Run Gpedit.msc.
    3. Go to Local Computer Policy > Computer Configuration > Administrative Templates > Windows Components > App Package Deployment
    4. Edit the policies to enable the following:
      • Allow all trusted apps to install (Enables your device for sideloading apps)
      • Allows development of Windows Store apps and installing them from an integrated development environment (IDE) (Enables your device for development from Visual Studio)
    5. Reboot your machine.

    but it didn't make any difference... my Lumia 1020 is still not being seen by VS

    1>------ Deploy started: Project: ZenAwakenerUniversal, Configuration: Release ARM ------

    1>Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.':

    1>DeviceException - The data necessary to complete this operation is not yet available.

    1>Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found. The data necessary to complete this operation is not yet available.

    1>

    ========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========

    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


    Tom

    Here's the source page:

    https://msdn.microsoft.com/library/windows/apps/xaml/dn706236.aspx?f=255&MSPPError=-2147217396 


    • Edited by tbink Thursday, November 12, 2015 7:49 PM added info
    Thursday, November 12, 2015 7:46 PM
  • Just cmd and ver, I have updated now to desktop  Microsoft Windows [Version 10.0.10586] but the same

    Juan Pablo G.C.

    Update this are sreenshots trying to deploy and reinstalling drivers any clue?


    Juan Pablo G.C.

    Thursday, November 12, 2015 7:58 PM
  • Guys, try first to install latest emulators from https://go.microsoft.com/fwlink/p/?LinkId=615095 then deploy to emulators, then try to deploy to your devices, if failed, try to uninstall USB drivers as described above. The checkbox is visible for only one entry, second one in my case. Good luck. And of course, make sure your winphone10 has enabled 'Developer mode'...
    • Edited by Sergioko Thursday, November 12, 2015 8:48 PM
    Thursday, November 12, 2015 8:04 PM
  • update...

    I updated Windows to version to 10586 (current)... no change in the error message when trying to connect to Lumia 1020 from VS (aargh)


    Tom

    Friday, November 13, 2015 1:04 AM
  • Guys, try first to install latest emulators from https://go.microsoft.com/fwlink/p/?LinkId=615095 then deploy to emulators, then try to deploy to your devices, if failed, try to uninstall USB drivers as described above. The checkbox is visible for only one entry, second one in my case. Good luck. And of course, make sure your winphone10 has enabled 'Developer mode'...

    SUCCESS!

    Here's what's different about what I did...

    1- updated to the latest version Win10 via Update [10586]. But that alone didn't fix the issue

    2- downloaded the latest emulators and successfully ran my app in one.  But that didn't fix the Device issue when I tried it

    3-
    a- with Lumia 1020 plugged (USB): Device Manager 1- uninstall the 3 USB Bus Devices (never saw a checkbox).. and ignore the restart request 2- uninstall the phone from Portable Devices

    b- unplug 1020 and reboot machine

    c- after reboot, plug 1020 and Device Manager shows the reinstallation

    4- open VS and set Any CPU, deploy App to Emulator (4.5 phone) success

    5- set ARM deploy my App to Device (1020 phone) success

    6- Debug to Device success

    ---- I had a problem when I didn't FIRST deploy to an Emulator before changing to Device... so it works but it's finicky...  BUT IT WORKS YEA!


    Tom

    Friday, November 13, 2015 5:53 AM
  • I can't do those steps. I can uninstall the drivers but I cant install or test on emulator as my ancient PC doesnt support hardware virtualization so I cant even install the emulators

    Monday, November 16, 2015 8:35 PM
  • I can't do those steps. I can uninstall the drivers but I cant install or test on emulator as my ancient PC doesnt support hardware virtualization so I cant even install the emulators


    yes... I have VS 2015 running on an older (not THAT old) machine but with a lesser/older graphics card and it just barely works to develop Universal Apps.  It has problems with rendering in Design Mode/View.  If you can upgrade your graphics card that might do it for you...

    Tom

    Tuesday, November 17, 2015 5:40 PM
  • I can't do those steps. I can uninstall the drivers but I cant install or test on emulator as my ancient PC doesnt support hardware virtualization so I cant even install the emulators


    yes... I have VS 2015 running on an older (not THAT old) machine but with a lesser/older graphics card and it just barely works to develop Universal Apps.  It has problems with rendering in Design Mode/View.  If you can upgrade your graphics card that might do it for you...

    Tom

    The error is a deployment error. I doubt the graphics card has anything to do with it. I have no problems developing on my PC other than the lack of an emulator.
    Wednesday, November 18, 2015 7:36 PM
  • [excuse my eng]

    Tom, many many thanks! I had all these troubles for a month+. I did what you recommend and magic - my lumia 435 is my new dev device.

    Thanks!


    Slava V.

    Monday, November 30, 2015 6:11 PM
  • [excuse my eng]

    Tom, many many thanks! I had all these troubles for a month+. I did what you recommend and magic - my lumia 435 is my new dev device.

    Thanks!


    Slava V.


    Your very welcome Slava!

    Tom

    Monday, November 30, 2015 6:40 PM
  • Guys, try first to install latest emulators from https://go.microsoft.com/fwlink/p/?LinkId=615095 then deploy to emulators, then try to deploy to your devices, if failed, try to uninstall USB drivers as described above. The checkbox is visible for only one entry, second one in my case. Good luck. And of course, make sure your winphone10 has enabled 'Developer mode'...

    SUCCESS!

    Here's what's different about what I did...

    1- updated to the latest version Win10 via Update [10586]. But that alone didn't fix the issue

    2- downloaded the latest emulators and successfully ran my app in one.  But that didn't fix the Device issue when I tried it

    3-
    a- with Lumia 1020 plugged (USB): Device Manager 1- uninstall the 3 USB Bus Devices (never saw a checkbox).. and ignore the restart request 2- uninstall the phone from Portable Devices

    b- unplug 1020 and reboot machine

    c- after reboot, plug 1020 and Device Manager shows the reinstallation

    4- open VS and set Any CPU, deploy App to Emulator (4.5 phone) success

    5- set ARM deploy my App to Device (1020 phone) success

    6- Debug to Device success

    ---- I had a problem when I didn't FIRST deploy to an Emulator before changing to Device... so it works but it's finicky...  BUT IT WORKS YEA!


    Tom

    I'd rather this didnt get marked as the answer. I know it obviously works for some of you but surely, installing emulators for a device build and jumping through these hoops isnt the answer? Have Microsoft acknowledged this issue at all?
    Tuesday, December 1, 2015 3:27 PM
  • Downloading the newest emulators (10586) is what did the trick for me. Not sure how much of the rest of this voodoo is necessary, but it was a struggle figuring this out. Thanks everyone and especially Tom for figuring this out.
    Friday, December 4, 2015 8:18 PM
  • OK I got it working now after updating Visual Studio to Update 1 which includes an updated SDK. Presumably its that which adds compatibility for the latest version of Windows 10 mobile
    Friday, December 4, 2015 8:29 PM
  • I've just updated the phone to 10.0.10586.29 and Visual Studio again stopped deploying the app with the error:

    Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found...


    SOLUTION was very simple:

    1. Have the phone connected to PC
    2. Start Device Manager on PC
    3. Open "Universal Serial Bus devices" node and uninstall the first entry for your phone (no need to uninstall all three)
    4. Disconnect phone USB cable, then reconnect it again.
    5. Deploy the app from Visual Studio - now it should work!!!

    Try these simple steps before doing heavy stuff like reinstalling emulators and update SDKs...

    • Proposed as answer by Sergioko Friday, December 11, 2015 12:31 PM
    Friday, December 11, 2015 12:29 PM
  • Update Windows SDK 10586.15, then you can deploy with VS2015.

    http://download.microsoft.com/download/6/A/2/6A2ECE81-C934-4E47-91CC-52DA00A65345/sdksetup.exe


    Hack~ok Windows Phone 7

    Friday, March 4, 2016 6:47 AM