none
SSRS 2016 KPIs no longer refresh after upgrade to CU2 RRS feed

  • Question

  • I set up a refresh plan for my KPIs on SQL Server 2016 RC and it worked fine. After installing the CU2 upgrade, the KPIs no longer seem to refresh when the underlying dataset is refreshed via the cache refresh plan. Does anyone know what the issue is and how to get the KPIs to refresh again?
    Monday, October 10, 2016 2:11 PM

Answers

  • Hi Tom,

    Based on your description, I have create the refresh plan on both SSRS 2016 CU1 (version 13.0.1601.5) and CU2 (version 13.0.2164.0) environment. However I didn't encounter your issue. The KPI at both side will be refreshed when the DataSet cache is refreshed and I refreshed the Web Portal. Please refer:

    SSRS 2016 CU1:

    SSRS 2016 CU2:

    So in your scenario, please verify that your DataSet cache refresh succeeded. Also it will be more helpful to troubleshoot your issue if you can share us your KPI structure or DataSet cache with screenshots.

    If you still have any questions, please feel free to ask.

    Thanks,

    Xi Jin.

    Wednesday, October 12, 2016 7:50 AM
    Moderator

All replies

  • Hi Tom306,

    According to your description, you have specified a refresh plan for your KPIs. And this plan can work fine in the older version of Reporting Service 2016. However when you update your SSRS 2016 to CU2, this plan doesn't work. Right?

    I have made some test in my local SSRS 2016 CU2 environment Version 13.0.2164.0. As creating a KPI by using DataSet field, then just update the DataSet field. However the KPI will not be refreshed until I refresh the DataSet field in the KPI manually.

    You should know that when we create a KPI, its values will be stored in the Catalog table of Report Server DataBase. Generally it will always call the old values in this table until you refresh it manually. So in your scenario, as you said you set up a refresh plan for the KPIs. How did you specify this refresh plan? Could you please share us more detailed information about your refresh plan if possible?

    Thanks,

    Xi Jin.


    Tuesday, October 11, 2016 2:35 AM
    Moderator
  • I set up caching for the dataset used by the KPIs by setting the Cache expiration to 'Cache expires on a schedule' and then selected a shared schedule that updates the data every minute. I also set up a cache refresh plan that runs every minute. I use this same refresh plan for paginated reports as well and they are being refreshed. Just not the KPIs. When I load the data in the Data Preview option of the dataset, I can see the correct values being returned, but they are not displayed in the KPI. As I mentioned, this worked before the upgrade to CU2.

    Thanks for your help.

    Tuesday, October 11, 2016 12:48 PM
  • Hi Tom,

    Based on your description, I have create the refresh plan on both SSRS 2016 CU1 (version 13.0.1601.5) and CU2 (version 13.0.2164.0) environment. However I didn't encounter your issue. The KPI at both side will be refreshed when the DataSet cache is refreshed and I refreshed the Web Portal. Please refer:

    SSRS 2016 CU1:

    SSRS 2016 CU2:

    So in your scenario, please verify that your DataSet cache refresh succeeded. Also it will be more helpful to troubleshoot your issue if you can share us your KPI structure or DataSet cache with screenshots.

    If you still have any questions, please feel free to ask.

    Thanks,

    Xi Jin.

    Wednesday, October 12, 2016 7:50 AM
    Moderator
  • Hi Xi,

    I have the same caching configuration as you show above in your screenshots. I've tried everything I can think of except a fresh installation of the original release version of 2016. It was working with that version, so I am going to roll back the CU2. Maybe in the next upgrade, this issue will be fixed.

    Thanks for your help.

    Wednesday, October 12, 2016 2:01 PM
  • We had a similar issue after the CU2 upgrade, but I can't verify it was the CU2 as it could've been a user. We only use 2 data sets on KPIs and both of them stopped working the day after the upgrade. When I went to investigate the "Cache Expires on a Schedule" button had been changed to "Cache expires after X minutes."  Again I can't verify if the CU2 did it or a user, the timing may be coincidental. 
    Wednesday, November 2, 2016 8:01 PM
  • Experienced same issue here after the upgrade. Had to reconfigure all the KPIs settings to make them work. Got so frustrated that I ended up deleted all the KPIs.
    Saturday, December 10, 2016 9:15 AM