none
Access Denied when Printing/Publishing RRS feed

  • Question

  • I pushed a update to my staging server that updated our report viewer control from a dinasour version to the latest version.

    The reports all show up fine but when clicking on print or export the user gets a error such as the one shown below -

    Access Denied
    You don't have permission to access "http://website.com/staging/Reserved.ReportViewerWebControl.axd?" on this server.

    Reference #18.d6430d6.1563384398.98984d

    ______________

    A hack I did that makes it work - A changed URL that gives the error -

    https://mywebsite/staging/oldsite/Reserved.ReportViewerWebControl.axd?ReportSession=4pkobe55ntryhl45db1u1q45&Culture=1033&CultureOverrides=True&UICulture=1033&UICultureOverrides=True&ReportStack=1&ControlID=2c6c83b9ac5543fdb1b0211a26f9d5f5&RSProxy=http%3a%2f%2f123.456.789%2freportserver&OpType=Export&FileName=Readiness&ContentDisposition=OnlyHtmlInline&Format=PDF

    Take note of the RSProxy=http%3a%2f%2f123.456.789%2freportserver line. If I remove that line from the URL it works without issue. Obviously its not a acceptable solution to tell my users that they have to remove a line from a URL to get something to work. Is there a way to remove this proxy parameter from the print/export option so it works as intended?


    Some additional information:

    My website is served through HTTPS only. The report server is served off HTTP.
    The print/export function works when I run it on my personal development site. Both sites hit the same webserver.
    We use IIS8.

    I tried looking at the configuration of the report server and my IIS but I can't find anything that would lead to this issue. Any ideas?

    Thursday, July 18, 2019 5:44 PM

Answers

  • So we were able to fix this issue and I wanted to reply here in case anyone else got the problem. I will also answer your questions.

    Issue exist on the custom website. When I refer to print/export I am talking about the report viewer's buttons for those two. For Export the error would appear on its own page after clicking the format you would like to download. Ex: PDF would cause a popup of a page with the error.

    And if you clicked print, inside the preview that comes up the error would display.

    Now, The FIX:

    We were having it point to a IP address on our network - Ex: http://123.23.45.67/Reportserver

    Later we upgraded to version 15 and go the issue. To fix the issue we instead pointed to the fully qualified name of the report server instead of the IP that we were using. Ex: http://fullservername.ourwebsite.com/ReportServer fixed the issue.

    Thanks for the quick reply by the way.


    • Marked as answer by Dwood96 Friday, July 19, 2019 1:05 PM
    • Edited by Dwood96 Friday, July 19, 2019 1:09 PM
    Friday, July 19, 2019 1:05 PM

All replies

  • Hi Dwood96

    According to your description , seems get some confused about your issue .

    • Where does the issue exist ? in your custom website or the ssrs web portal , seems it was in the custom web site .
    • When did the user get the issue ? print or export ? does the print button is the browser print button or the report viewer print button ? how does the issue render ?you could offer the correspond image to us .
    • What the detailed report viewer version you use.
    • Does the two web site exist any difference in configuration ? seems it was the permission issue , check if your user have the permission to download the report in your website , seems it was more related to iis scope.

    Reference : Report viewer Permission denied

    Hoping for your reply.

    Best Regards,

    Eric Liu


    Best Regards, Eric Liu MSDN Community Support Please remember to click Mark as Answer if the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread.

    Friday, July 19, 2019 5:42 AM
  • So we were able to fix this issue and I wanted to reply here in case anyone else got the problem. I will also answer your questions.

    Issue exist on the custom website. When I refer to print/export I am talking about the report viewer's buttons for those two. For Export the error would appear on its own page after clicking the format you would like to download. Ex: PDF would cause a popup of a page with the error.

    And if you clicked print, inside the preview that comes up the error would display.

    Now, The FIX:

    We were having it point to a IP address on our network - Ex: http://123.23.45.67/Reportserver

    Later we upgraded to version 15 and go the issue. To fix the issue we instead pointed to the fully qualified name of the report server instead of the IP that we were using. Ex: http://fullservername.ourwebsite.com/ReportServer fixed the issue.

    Thanks for the quick reply by the way.


    • Marked as answer by Dwood96 Friday, July 19, 2019 1:05 PM
    • Edited by Dwood96 Friday, July 19, 2019 1:09 PM
    Friday, July 19, 2019 1:05 PM