none
Error 14258: Cannot perform this operation while SQLServerAgent is starting. Try again later.

    Question

  • I'm getting the following error on two of my SQL Servers -

    Error 14258: Cannot perform this operation while SQLServerAgent is starting. Try again later.

    The only solution that I have seen is the same solution that Microsoft has published in the following article - KB303287 [http://support.microsoft.com/?scid=http%3a%2f%2fwww.support.microsoft.com%2fkb%2f303287%2fen-us%2f]

    The solution is to unflag the use of NT Fibers.  However, our software application provider is advising us against doing this.  Is there another fix anywhere that I could get my hands on - another solution?

    Thanks in advance.

    Friday, December 30, 2005 8:40 PM

Answers

  • SQLAgent jobs fails because of the reason that it waits for event to signal recovery is complete.

    Currently the only solution is to switch to thread mode.

    http://msdn.microsoft.com/sql/default.aspx?pull=/library/en-us/dnsqldev/html/sqldev_02152005.asp

    Above article recommends that you stay away from fiber mode and focus your tuning efforts on other things. If you run into a situation where you feel strongly you need fiber mode, it's probably worth a call into Microsoft Product Support Services to confirm your diagnosis.

    Thanks,

    Gops Dwarak

    Tuesday, January 03, 2006 9:06 PM
  • Thanks very much for the reply and for the extra information as well.  My situation actually started when we attempted to create and use a local machine account to run the SQLSERVERAGENT service.  I'm not sure if this brings more into play or not.  I took the service back to using a different priviledged domain account to run the service and I'm not getting the errors currently. 

    I would, however, much rather run this service as a local user for security reasons.  I have not yet taken a fresh look at Microsoft's best practices on this issue [the service account], but I will be taking a look at that as well.

    thanks again.

    Tuesday, January 03, 2006 9:22 PM

All replies

  • SQLAgent jobs fails because of the reason that it waits for event to signal recovery is complete.

    Currently the only solution is to switch to thread mode.

    http://msdn.microsoft.com/sql/default.aspx?pull=/library/en-us/dnsqldev/html/sqldev_02152005.asp

    Above article recommends that you stay away from fiber mode and focus your tuning efforts on other things. If you run into a situation where you feel strongly you need fiber mode, it's probably worth a call into Microsoft Product Support Services to confirm your diagnosis.

    Thanks,

    Gops Dwarak

    Tuesday, January 03, 2006 9:06 PM
  • Thanks very much for the reply and for the extra information as well.  My situation actually started when we attempted to create and use a local machine account to run the SQLSERVERAGENT service.  I'm not sure if this brings more into play or not.  I took the service back to using a different priviledged domain account to run the service and I'm not getting the errors currently. 

    I would, however, much rather run this service as a local user for security reasons.  I have not yet taken a fresh look at Microsoft's best practices on this issue [the service account], but I will be taking a look at that as well.

    thanks again.

    Tuesday, January 03, 2006 9:22 PM
  • We are having the same problem with our SQL Server Agent as well, and our started when we switched from the system account to a user account that was setup specifically for SQL.

    Our server has 4 processors so I think that is why the server was originally flagged to run in fiber mode, however, I think we are going to have to switch back to thread mode because there are so many processes that this is killing by staying in fiber mode.

    Anyway, if you  have found out any further information on this subject I would greatly appreciate any advice you might have.

    Thanks,

    Lee

    Tuesday, February 14, 2006 8:45 PM
  •  

    We are having the same problem with our SQL Server Agent as well, 

    The server is NOT flagged to run in fiber mode

     

    Do you  know how to fix it?

     

    Thanks,

    Oleg

    Saturday, May 12, 2007 7:14 PM
  • As mentioned above in the posts, change the log on account from local system account to a specified account, even if its the same account that you are signed on to the server. Worked like a charm for me..

     

    thanks guys...

     

     

    Sunday, May 13, 2007 11:16 AM
  • Oleg

    Have you referred to the article above and steps defined.

    Also if you are using distributed transactions its might worth to enable the mSDTC to auto start.

    Sunday, May 13, 2007 12:34 PM
    Moderator
  • Right on!  How Fibre Mode got switched on will be vexing me now.  At least server agent is running and I can see what is going on.  When server agent hangs with a 14258, it seems to be running in enterprise manager but none of my jobs show a history from the point of failure.

    I may have popped on the checkbox when i was looking at sql server properties.  When the server was bounced last week to finish a patch the agent did not come back when Fibre Mode was enabled and hung all my agent jobs.  That's the best I can do.  Careful when you browse a production machine...  I have DTS packages running on shedule so this turned out to be a big deal.

    I will see tomorrow if everything runs ok.  At least the error is clear when I try to edit the jobs.  I would think a melitious attack to have caused real damage so I blame myself.  Nothing in the security logs tells me any different.  Thanks.

     

    Thursday, September 27, 2007 4:52 PM
  • I got errer as below, looked all the links, still not working.  Can anyone help?

    Error 14258: Cannot perform this operation while SQLServerAgent is starting
    • Proposed as answer by Ganesh 24 Saturday, September 18, 2010 6:45 AM
    Thursday, October 02, 2008 3:13 PM
  • Just try the below query

    sp_configure 'allow updates',1
    go
    reconfigure with override
    go
    sp_configure 'lightweight pooling',0
    go
    reconfigure with override
    go

    • Proposed as answer by AshishGupta Tuesday, September 18, 2012 4:54 PM
    Saturday, September 18, 2010 6:46 AM
  • I changed alias local host server value under Connection in SQL Server Agent properties to an inaccurate value and got this error.  Cleared out bad value and restarted service.  Fixed problem.
    Friday, November 25, 2011 3:18 PM