none
i can not connect to the data base its asking for connecting to a server when i browse on my pc i can not find any server file. help? RRS feed

  • Question

  • I have download licensed sql server 2014 management studio express service pack 1 after installing when i opened the application i could not connect to the database because there is no server available it says to browse in the computer but there is no server file please tell me where i can find that file or do i need to download it additionally.  
    Monday, June 12, 2017 2:20 AM

Answers

All replies

  • It looks like you installed only client tools  and now you need install SQL Server engine 

    https://www.microsoft.com/en-US/download/details.aspx?id=42299


    Best Regards,Uri Dimant SQL Server MVP, http://sqlblog.com/blogs/uri_dimant/

    MS SQL optimization: MS SQL Development and Optimization
    MS SQL Consulting: Large scale of database and data cleansing
    Remote DBA Services: Improves MS SQL Database Performance
    SQL Server Integration Services: Business Intelligence

    Monday, June 12, 2017 4:39 AM
    Moderator
  • Or you can connect to an already installed SQL Server on a remote machine using the Server name from management studio
    Monday, June 12, 2017 4:46 AM
  • Yes i saw that option enter server name but when i browse i can not see any server please tell me how do i connect

    Monday, June 12, 2017 4:54 AM
  • Know i have reinstalled the software and extracted all the files to a new location which file should i chose when i browse for server while connecting the database engine.
    Monday, June 12, 2017 5:15 AM
  • I think the following steps will be helpful: 

    1. Download Express 32BIT\SQLEXPR_x86_ENU.exe from the above link that Uri provided.

    2. Run SQLEXPR_x86_ENU.exe as Administrator so that the installation files are extracted to a temp folder

    3. From the extracted temp folder, run SETUP.EXE and perform the installation.

    4. After installation, run ,management studio and in the Connect to Server dialog box, specify the server name as 'MachineName\sqlexpress' (sqlexpress is the default instance name for express installation). And you can specify Windows Authentication and try to connect.

    Monday, June 12, 2017 6:56 AM