none
Unable to Connect - Target Machine Actively Refused the Connection RRS feed

  • Question

  • Hi all,

    I've got a SQL 2012 CU3 single node cluster installation setup with DB Engine, RS and AS. DB and RS work just fine, but I've got issues with the AS.

    The AS Service is running and it looks up and running, but when I try to connect to it, I get an error "the target machine actively refused the connection" when trying to connect to RDLSCSQL2\SCSM2012DW which is the virtual cluster name and the instance name.

    I found an article at http://indepthsql.wordpress.com/2012/01/17/part-2-analysis-service-is-not-accessible-error-a-connection-could-not-be-made-to-redirector-ensure-that-sql-browser-is-running/ which pretty much describes my problem, so following his guidance, I tried to connect to RDLSCSQL2 without the instance name and sure enough, it works, so I added permission for the AS Service Account to the SQL Browser Service installation folder but to no avail.

    As this is a cluster (albeit single node currently) I don't really want to have to do an uninstall and re-install to try and get AS working if I can as you can't remove and re-add features in clustered installations.

    Anyone got anything I can try?


    Richard Green MCSE Windows Server 2003, MCTS Desktop Virtualization

    Thursday, September 6, 2012 2:44 PM

Answers

  • Hi Richard,

    After make sure SQL Browser Service is started, please check if all the services run under the same Service account.

    Please feel free to ask if you have any question.

    Thanks,
    Eileen

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.


    • Edited by Eileen Zhao Tuesday, September 18, 2012 8:47 AM
    • Marked as answer by Eileen Zhao Tuesday, September 25, 2012 8:12 AM
    Tuesday, September 18, 2012 8:46 AM

All replies

  • Check if named Pipes and TCP IP Protocols are enabled and see if starting that helps.
    Thursday, September 6, 2012 4:32 PM
  • Check if named Pipes and TCP IP Protocols are enabled and see if starting that helps.

    Using SQL Configuration Manager, I see that TCP/IP and Named Pipes are enabled, but I have no way of knowing if this is only applying to the DB Engine, or the SSAS. Aside from looking in the configuration file in the SSAS installation directory and the SQL Browser service ASConfig directories, are there any other ways of looking at it?

    Thanks
    Richard


    Richard Green MCSE Windows Server 2003, MCTS Desktop Virtualization

    Friday, September 7, 2012 3:29 PM
  • Similar problem here.

    Clustered 2012 tabular analysis services instance across two nodes. If the resource group is running on node A it's OK, I can connect by server\instance. If I fail it over to node B I cannot connect by server\instance (actively refused). Connecting by server without \instance works.

    I found a KB article that suggests this can occur when SSAS is started using SSCM instead of failover cluster manager, and to stop and restart with FCM. I did not restart with SSCM, but I stopped and restarted with FCM anyway - this did not change the symptoms.

    The SSAS service account is currently running as an admin account on the machine, so it can't be the directory permissions talked about by the OP (I saw the same article).

    This obiously looks like some kind of browser redirection issue but exactly what causes it... I have no idea.

    I also installed a clustered 2012 multidimensional instance across the same two nodes, and this has no problem.

    Event log on the virtual host for the tabular cluster shows the following error:

    "Failed to initialize SQLSQM timer. One of the following can be the source of the problem: registry doesn't contain all necessary information, server instance name can not be retrieved correctly, failure during timer creation, etc."

    Tuesday, September 11, 2012 5:26 AM
  • Hi Richard,

    After make sure SQL Browser Service is started, please check if all the services run under the same Service account.

    Please feel free to ask if you have any question.

    Thanks,
    Eileen

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.


    • Edited by Eileen Zhao Tuesday, September 18, 2012 8:47 AM
    • Marked as answer by Eileen Zhao Tuesday, September 25, 2012 8:12 AM
    Tuesday, September 18, 2012 8:46 AM
  • I had the same error connecting to Analysis Services on our newly installed SQL Cluster Service with 3 nodes, two instances.  Our Internet search led us to this knowledge base article:http://support.microsoft.com/kb/2658571 regarding an 'Error when you connect to a named instance of SQL Server 2012 Analysis Services by using IPv6: "No connection could be made because the target machine actively refused it"'.  We had not modified the install for IPv6 and were not intending to use IPV6, but we were receiving the same error on ports numbered above 50000.

    Stopping the service via the Cluster Manager, and removing the PortIPv6 entry under Instances in the msmdredir.ini file found here: <drive>\Program Files (x86)\Microsoft SQL Server\90\Shared\ASConfig did the trick of allowing a connection to Analysis Services.

    I suspect that something about the initial installation 'encouraged' the IPv6 behavior and the SQL Server disallowed that connection, producing the "active refusal" behavior.

    We did not have to modify SQL Browser Service account settings.

    • Proposed as answer by Devin Kibler Friday, October 12, 2012 2:46 AM
    • Edited by Devin Kibler Friday, October 12, 2012 2:50 AM
    Friday, October 12, 2012 2:45 AM
  • I had similar issue with my SQL 2014 RTM. Your reference to the article helped.

    Thanks.


    SQLCHANTer

    Wednesday, January 28, 2015 2:20 AM
  • This is how I fixed the issue.

    I am using SQL 2016 (hosted in an Azure VM) and I started to experience the same issue this morning. No connection could be established from a remote host! Completely out of the blue (actually some updates were installed yesterday, but none of them related to SQL 2016).

    This server has been working fine for months and I tried everything under the sun:

    • From the server itself, SQL profiler shows that SSAS does not even get a connection attempt.
    • Firewalls are turned off for all VMs in this environment.
    • SSAS has a fixed port: 49205.
    • Tried connecting with fixed port and named instance. None of them work.
    • Tried rebooting the SQL server.
    • Tried disabling IPv6 on the network interface of the SSAS server.
    • The netstat cmdlet showed port 49205 as listening.
    • Nothing worked...

    So from the server itself I tried to telnet to its ip address (e.g. 10.0.0.200:49205) and it also did not work. Then I tried connecting to the SSAS instance from Management Studio also via the IP and port number but it also did not work. So I wondered that perhaps there was an issue with the port number...

    So I changed the port to 49206. It worked.

    Then I changed the port back to my original 49205 value. It kept on working.

    Then I cursed MSFT and went on with the rest of my day :)





    • Proposed as answer by pmdci Wednesday, October 19, 2016 9:50 AM
    • Edited by pmdci Wednesday, October 19, 2016 1:47 PM
    Wednesday, October 19, 2016 9:48 AM